summaryrefslogtreecommitdiff
path: root/sys-auth/ykpers/ykpers-1.17.2.ebuild
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-10-06 00:56:23 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-10-06 00:56:23 +0200
commitdcc902d2c4e58835e9d8a709575038780de64058 (patch)
tree445a3e72fa7cc93935ee2c8bc88a96a3684f27e2 /sys-auth/ykpers/ykpers-1.17.2.ebuild
parentf7eb63336462f8e02254f603196cad22fdc07989 (diff)
downloadgentoo-dcc902d2c4e58835e9d8a709575038780de64058.tar.gz
gentoo-dcc902d2c4e58835e9d8a709575038780de64058.tar.xz
sys-auth/ykpers: Version bump
Package-Manager: portage-2.2.22
Diffstat (limited to 'sys-auth/ykpers/ykpers-1.17.2.ebuild')
-rw-r--r--sys-auth/ykpers/ykpers-1.17.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-auth/ykpers/ykpers-1.17.2.ebuild b/sys-auth/ykpers/ykpers-1.17.2.ebuild
new file mode 100644
index 00000000000..ef4e2a8a5a9
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.17.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="http://yubico.github.io/yubikey-personalization/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND="
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+src_install() {
+ DOCS=( doc/. AUTHORS ChangeLog NEWS README )
+ autotools-utils_src_install
+
+ use consolekit && udev_dorules *.rules
+}