summaryrefslogtreecommitdiff
path: root/sys-block/afacli
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/afacli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/afacli')
-rw-r--r--sys-block/afacli/Manifest1
-rw-r--r--sys-block/afacli/afacli-4.1.ebuild38
-rwxr-xr-xsys-block/afacli/files/afacli24
-rw-r--r--sys-block/afacli/metadata.xml7
4 files changed, 70 insertions, 0 deletions
diff --git a/sys-block/afacli/Manifest b/sys-block/afacli/Manifest
new file mode 100644
index 00000000000..0f9ff56b9c4
--- /dev/null
+++ b/sys-block/afacli/Manifest
@@ -0,0 +1 @@
+DIST afa-apps-snmp.2807420-A04.tar.gz 966308 SHA256 0b7abd0308e8cff6824b47e435e81579f2464ddc5fb9a87d478eb87778176fd2
diff --git a/sys-block/afacli/afacli-4.1.ebuild b/sys-block/afacli/afacli-4.1.ebuild
new file mode 100644
index 00000000000..950d2753331
--- /dev/null
+++ b/sys-block/afacli/afacli-4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit rpm
+
+MY_PV=${PV}-0
+DESCRIPTION="Dell AACRAID-based PERC RAID controller management tool"
+HOMEPAGE="http://linux.dell.com/"
+SRC_URI="ftp://ftp.dell.com/scsi-raid/afa-apps-snmp.2807420-A04.tar.gz"
+
+LICENSE="Dell"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~x86"
+IUSE=""
+
+RESTRICT="strip mirror test"
+
+RDEPEND="sys-libs/lib-compat"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ rpm_unpack "${S}"/afaapps-${MY_PV}.i386.rpm || die "failed to unpack RPM"
+}
+
+src_compile() {
+ echo "Nothing to compile."
+}
+
+src_install() {
+ dosbin "${FILESDIR}"/afacli
+ newsbin usr/sbin/afacli afacli.bin
+ dodoc usr/sbin/getcfg.afa
+}
diff --git a/sys-block/afacli/files/afacli b/sys-block/afacli/files/afacli
new file mode 100755
index 00000000000..5596094228c
--- /dev/null
+++ b/sys-block/afacli/files/afacli
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+# Get the major number of the aac ioctl device node
+aacdev_major=$(egrep '[[:space:]]aac$' /proc/devices 2>/dev/null | awk '{print $1}' 2>/dev/null)
+aacdev_node=/dev/afa0
+
+# AACRAID device node major number found
+if [ -z "${aacdev_major}" ]; then
+ echo "ERROR: failed to determine device node major number"
+ exit 1
+fi
+if [ -e "${aacdev_node}" ]; then
+ if ! rm -f "${aacdev_node}"; then
+ echo "ERROR: failed to remove existing device node ${aacdev_node}"
+ exit 1
+ fi
+fi
+if ! mknod "${aacdev_node}" c "${aacdev_major}" 0; then
+ echo "ERROR: failed to create device node ${aacdev_node}"
+ exit 1
+fi
+
+# Start the real afacli binary
+"${0%/*}/afacli.bin" "${@}"
diff --git a/sys-block/afacli/metadata.xml b/sys-block/afacli/metadata.xml
new file mode 100644
index 00000000000..a40624fba8f
--- /dev/null
+++ b/sys-block/afacli/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>