summaryrefslogtreecommitdiff
path: root/sys-block/sas2ircu
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/sas2ircu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/sas2ircu')
-rw-r--r--sys-block/sas2ircu/Manifest2
-rw-r--r--sys-block/sas2ircu/metadata.xml11
-rw-r--r--sys-block/sas2ircu/sas2ircu-19.ebuild98
3 files changed, 111 insertions, 0 deletions
diff --git a/sys-block/sas2ircu/Manifest b/sys-block/sas2ircu/Manifest
new file mode 100644
index 00000000000..f221dd21b51
--- /dev/null
+++ b/sys-block/sas2ircu/Manifest
@@ -0,0 +1,2 @@
+DIST SAS2IRCU_P19.zip 2664125 SHA256 e5bb0bc37099016d6f7486f623cb74baeef9903afdd0610a7c8850331ff8b3d5 SHA512 99f5092e1344747912b081f4f9e22a1f22d55e5a951583f5482213a38a1faa7cd890b573fdeb50d4770bb862d970364ccaff982969813edd9581e80bc39e2bdf WHIRLPOOL 9e173c5f4ade04a7fecb994f98c4d7457375c559c7f0e9994d38e3a2b1847577084449ee0ab1a3ece06e5a57c74ae41294b135aeffa396aa56120d5a6a0ea37d
+DIST SAS2IRCU_User_Guide.pdf 794046 SHA256 b39867aab18d60180a21d34d01476216aa07d6b2af5368713f7bb16cba249506 SHA512 515869794be428ffbefcbfadac992912fb0eebab0cda640b315b4a231b5f25f1205978605f108b9009380015f3058c47e0ce4352c693ef23ab31980ea8b821a0 WHIRLPOOL 2ce68f5e2880d2c865164fde7d69669893b547da71d784c84194116a3aa491b2f2d72e932217ef0e265fbf1f67289bcb8d29bb010cf21a2ca2d8f1acb367774f
diff --git a/sys-block/sas2ircu/metadata.xml b/sys-block/sas2ircu/metadata.xml
new file mode 100644
index 00000000000..f2fe9421c29
--- /dev/null
+++ b/sys-block/sas2ircu/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+</maintainer>
+<use>
+ <flag name="efi">Install EFI variant as well</flag>
+</use>
+</pkgmetadata>
diff --git a/sys-block/sas2ircu/sas2ircu-19.ebuild b/sys-block/sas2ircu/sas2ircu-19.ebuild
new file mode 100644
index 00000000000..2358ca2d1c5
--- /dev/null
+++ b/sys-block/sas2ircu/sas2ircu-19.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit mount-boot
+
+DESCRIPTION="LSI MPT-SAS2 controller management tool"
+HOMEPAGE="http://www.lsi.com/support/Pages/download-results.aspx?component=Storage+Component&productfamily=Host+Bus+Adapters&productcode=0&assettype=Miscellaneous&productname=&keyword=SAS2IRCU"
+LICENSE="LSI"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~ppc64 ~amd64-fbsd ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="efi doc"
+RESTRICT="strip fetch mirror"
+DEPEND=""
+RDEPEND=""
+QA_PREBUILT="opt/lsi/sas2ircu boot/efi/sas2ircu.efi"
+
+MY_PN=SAS2IRCU
+MY_P="${MY_PN}_P${PV}"
+
+DISTFILE_BIN=${MY_P}.zip
+DISTFILE_DOC=SAS2IRCU_User_Guide.pdf
+DOC_PV=12
+
+SRC_URI="
+http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/Host%20Bus%20Adapters%20Common%20Files/SAS_SATA_6G_P${PV}/$DISTFILE_BIN
+doc? ( http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/Host%20Bus%20Adapters%20Common%20Files/SAS_SATA_6G_P${DOC_PV}/SAS2IRCU_User_Guide.pdf )
+"
+
+LICENSE_URL="http://www.lsi.com/cm/License.do?url=&prodName=&subType=Miscellaneous&locale=EN"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_nofetch() {
+ elog "LSI has a mandatory click-through license on thier binaries."
+ elog "Please visit $HOMEPAGE and download ${DISTFILE_BIN} from the Miscellaneous section."
+ elog "After downloading, move ${MY_P} into $DISTDIR"
+ if use doc; then
+ elog "Please also download 'SAS-2 Integrated RAID Configuration Utility User Guide' (${DISTFILE_DOC}) "
+ elog "and also place it into $DISTDIR"
+ fi
+}
+
+supportedcards() {
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "LSI SAS 2004"
+ elog "LSI SAS 2008"
+ elog "LSI SAS 2108"
+ elog "LSI SAS 2208"
+ elog "LSI SAS 2304"
+ elog "LSI SAS 2308"
+ elog "Dell PERC H200, H700"
+ elog "IBM System x3200 M2 (4367, 4368)"
+ elog "IBM System x3200 M3 (7327, 7328)"
+ elog "IBM System x3250 M2 (4190, 4191, 4194)"
+ elog "IBM System x3250 M3 (4251, 4252, 4261)"
+ elog "IBM System x3350 (4192, 4193)"
+ elog "IBM System x3400 (7973, 7974, 7975, 7976)"
+ elog "IBM System x3400 M2 (7836, 7837)"
+ elog "IBM System x3455 (7940, 7941)"
+ elog "IBM System x3500 (7977)"
+ elog "IBM System x3500 M2 (7839)"
+ elog "IBM System x3550 (7978, 1913)"
+ elog "IBM System x3550 M2 (7946, 4198)"
+ elog "IBM System x3650 (7979, 1914)"
+ elog "IBM System x3650 M2 (7947, 4199)"
+ elog "IBM System x3650 NAS (7979)"
+ elog "IBM System x3655 (7985, 7943)"
+ elog "IBM System x3755 (8877, 7163)"
+ elog "IBM System x3850 M2 (7141, 7144, 7233, 7234)"
+ elog "IBM System x3850 X5 (7145, 7146)"
+ elog "IBM System x3950 M2 (7141, 7233, 7234)"
+ elog "IBM System x3950 X5 (7145)"
+}
+
+src_unpack() {
+ unpack ${DISTFILE_BIN}
+}
+
+src_install() {
+ exeinto /opt/lsi/
+ use amd64 || use x86 && doexe sas2ircu_linux_x86_rel/sas2ircu
+ use ppc64 && doexe sas2ircu_linux_x86_rel/sas2ircu
+ use amd64-fbsd && doexe sas2ircu_freebsd_amd64_rel/sas2ircu
+ use x86-fbsd && doexe sas2ircu_freebsd_i386_rel/sas2ircu
+ use x64-solaris || use x86-solaris && doexe sas2ircu_solaris_x86_rel/sas2ircu
+ use sparc-solaris && doexe sas2ircu_solaris_sparc_rel/sas2ircu
+ if use efi; then
+ exeinto /boot/efi/
+ doexe sas2ircu_efi_ebc_rel/sas2ircu.efi
+ fi
+ dodoc Readme_Release_Notes_SAS2IRCU_Phase_17.00.00.00.txt
+ dodoc SAS2IRCU_Phase${PV}.0-${PV}.00.00.00.pdf
+ use doc && dodoc "${DISTDIR}"/$DISTFILE_DOC
+}