summaryrefslogtreecommitdiff
path: root/sys-block/scsirastools
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/scsirastools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/scsirastools')
-rw-r--r--sys-block/scsirastools/Manifest3
-rw-r--r--sys-block/scsirastools/files/scsirastools-1.5.6-glibc-2.10.patch87
-rw-r--r--sys-block/scsirastools/metadata.xml10
-rw-r--r--sys-block/scsirastools/scsirastools-1.5.4.ebuild61
-rw-r--r--sys-block/scsirastools/scsirastools-1.5.6.ebuild65
-rw-r--r--sys-block/scsirastools/scsirastools-1.5.7.ebuild65
6 files changed, 291 insertions, 0 deletions
diff --git a/sys-block/scsirastools/Manifest b/sys-block/scsirastools/Manifest
new file mode 100644
index 00000000000..eef964c770e
--- /dev/null
+++ b/sys-block/scsirastools/Manifest
@@ -0,0 +1,3 @@
+DIST scsirastools-1.5.4.tar.gz 632340 SHA256 d22c4917d8d2277710ea6bd4742874a62fc5666154ee6715966216daa865297c
+DIST scsirastools-1.5.6.tar.gz 549895 SHA256 fc3663bdd78ef14c75cc45d1922329a1be80a433627b4936593175f728b5b48a
+DIST scsirastools-1.5.7.tar.gz 677348 SHA256 0b53e731cb03b4200e5f46b5e79b20e329939c276d65b15835ceba0a1fd4055a
diff --git a/sys-block/scsirastools/files/scsirastools-1.5.6-glibc-2.10.patch b/sys-block/scsirastools/files/scsirastools-1.5.6-glibc-2.10.patch
new file mode 100644
index 00000000000..de874bad291
--- /dev/null
+++ b/sys-block/scsirastools/files/scsirastools-1.5.6-glibc-2.10.patch
@@ -0,0 +1,87 @@
+diff -ur scsirastools-1.5.6.orig/src/getmd.c scsirastools-1.5.6/src/getmd.c
+--- scsirastools-1.5.6.orig/src/getmd.c 2007-02-02 21:16:38.000000000 +0200
++++ scsirastools-1.5.6/src/getmd.c 2009-08-05 22:51:00.000000000 +0300
+@@ -81,7 +81,7 @@
+ } else return (-1); /*not found*/
+ }
+
+-static int getline(FILE * fd, char *buf, int len)
++static int get_line(FILE * fd, char *buf, int len)
+ {
+ int i;
+ int ch;
+@@ -119,7 +119,7 @@
+ sraidstr = strlen(raidstr);
+ strcpy(mdpart, "/dev/sda1"); /* default */
+ strcpy(rdev, "/dev/md0"); /* default */
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* look for raiddev string */
+ i = findmatch(buf, rlen, raidstr, sraidstr, 0);
+diff -ur scsirastools-1.5.6.orig/src/sgraidmon.c scsirastools-1.5.6/src/sgraidmon.c
+--- scsirastools-1.5.6.orig/src/sgraidmon.c 2007-10-16 01:15:15.000000000 +0300
++++ scsirastools-1.5.6/src/sgraidmon.c 2009-08-05 22:51:00.000000000 +0300
+@@ -330,7 +330,7 @@
+ rdev[0] = 0; /* default rdev (mddev) */
+ strcpy(mdpart, "/dev/sdz1"); /* default mdpart */
+ foundit = 0;
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* check for comment */
+ if (buf[0] == '#') continue;
+@@ -392,7 +392,7 @@
+ if (fd == NULL) return (np);
+ sraidstr = strlen(raidstr);
+ sdevstr = strlen(devstr);
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* check for comment */
+ if (buf[0] == '#') continue;
+diff -ur scsirastools-1.5.6.orig/src/sgsafte.c scsirastools-1.5.6/src/sgsafte.c
+--- scsirastools-1.5.6.orig/src/sgsafte.c 2007-09-13 00:45:29.000000000 +0300
++++ scsirastools-1.5.6/src/sgsafte.c 2009-08-05 22:51:00.000000000 +0300
+@@ -231,7 +231,7 @@
+ rdev[0] = 0; /* default rdev (mddev) */
+ strcpy(mdpart, "/dev/sdz1"); /* default mdpart */
+ foundit = 0;
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* look for raiddev string */
+ i = findmatch(buf, rlen, raidstr, sraidstr, 0);
+@@ -284,7 +284,7 @@
+ fd = fopen(raidfile, "r");
+ if (fd == NULL) return (np);
+ sraidstr = strlen(raidstr);
+- while ((rlen = getline(fd, buf, 80)) > 0) { /* process each line */
++ while ((rlen = get_line(fd, buf, 80)) > 0) { /* process each line */
+ buf[rlen] = 0; /* stringify */
+ /* look for raiddev string */
+ i = findmatch(buf, rlen, raidstr, sraidstr, 0);
+diff -ur scsirastools-1.5.6.orig/src/sgsubmon.c scsirastools-1.5.6/src/sgsubmon.c
+--- scsirastools-1.5.6.orig/src/sgsubmon.c 2007-10-16 17:03:39.000000000 +0300
++++ scsirastools-1.5.6/src/sgsubmon.c 2009-08-05 22:51:00.000000000 +0300
+@@ -159,7 +159,7 @@
+ return;
+ }
+
+-int getline(FILE * fd, char *buf, int len)
++int get_line(FILE * fd, char *buf, int len)
+ {
+ int i;
+ int ch;
+diff -ur scsirastools-1.5.6.orig/src/sgsubmon.h scsirastools-1.5.6/src/sgsubmon.h
+--- scsirastools-1.5.6.orig/src/sgsubmon.h 2007-09-13 00:38:28.000000000 +0300
++++ scsirastools-1.5.6/src/sgsubmon.h 2009-08-05 22:50:59.000000000 +0300
+@@ -124,7 +124,7 @@
+ void itoh(uchar * chp, int len, char *str);
+ void dumpbufr(FILE * fdout, uchar * bufp, int mlen, char *hdr);
+ void dump_buf(FILE * fdout, uchar * bufp, int mlen, char *hdr, char fascii);
+-int getline(FILE * fd, char *buf, int len) ;
++int get_line(FILE * fd, char *buf, int len) ;
+ int findmatch(char *buffer,int sbuf, char *pattern,int spattern,char figncase);
+ int fillstr(char *to, uchar *from,int len);
+ int IsSATA(int idev);
diff --git a/sys-block/scsirastools/metadata.xml b/sys-block/scsirastools/metadata.xml
new file mode 100644
index 00000000000..eba19a18142
--- /dev/null
+++ b/sys-block/scsirastools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">scsirastools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-block/scsirastools/scsirastools-1.5.4.ebuild b/sys-block/scsirastools/scsirastools-1.5.4.ebuild
new file mode 100644
index 00000000000..2d4da1c58b2
--- /dev/null
+++ b/sys-block/scsirastools/scsirastools-1.5.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools
+
+DESCRIPTION="Serviceability for SCSI Disks and Arrays"
+HOMEPAGE="http://scsirastools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+DEPEND="sys-apps/rescan-scsi-bus
+ sys-apps/sg3_utils"
+#RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ # this builds a really old mdadm
+ sed -i.orig \
+ -e '/^SUBDIRS/s,mdadm.d,,' \
+ -e '/^SUBDIRS/s,files,,' \
+ "${S}"/Makefile.am || die "sed Makefile.am failed"
+ cd "${S}"
+ eautoreconf
+ # i386 ELF binaries in tarball = bad
+ rm -f "${S}"/files/alarms*
+
+ # Fix up /sbin instances to be /usr/sbin instead
+ for i in src/sgraidmon.c src/sgdiskmon.c ; do
+ sed -i "${S}"/${i} \
+ -e '/evtcmd\[\].*\"\/sbin\//s,/sbin/,/usr/sbin/,' \
+ || die "Failed to set /sbin in sources"
+ done
+}
+
+src_compile() {
+ econf --sbindir=/usr/sbin \
+ || die "econf failed"
+ emake \
+ || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ docdir="/usr/share/doc/${PF}/"
+ emake install DESTDIR="${D}" datato="${D}${docdir}" \
+ || die "emake install failed"
+ dosbin files/sgevt
+ dosbin files/mdevt
+ # unneeded files
+ rm -f "${D}"${docdir}/{SCSIRAS,COPYING}
+ # install modepage files
+ insinto /usr/share/${PN}
+ doins files/*.mdf
+ # new docs
+ dodoc ChangeLog AUTHORS TODO
+ # ensure that other docs from the emake install are compressed too.
+ prepalldocs
+}
diff --git a/sys-block/scsirastools/scsirastools-1.5.6.ebuild b/sys-block/scsirastools/scsirastools-1.5.6.ebuild
new file mode 100644
index 00000000000..0c3d2c1ed74
--- /dev/null
+++ b/sys-block/scsirastools/scsirastools-1.5.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils
+
+DESCRIPTION="Serviceability for SCSI Disks and Arrays"
+HOMEPAGE="http://scsirastools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND="sys-apps/rescan-scsi-bus
+ sys-apps/sg3_utils"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ # this builds a really old mdadm
+ sed -i \
+ -e '/RPMB/d' \
+ -e '/^SUBDIRS/s,mdadm.d,,' \
+ -e '/^SUBDIRS/s,files,,' \
+ "${S}"/Makefile.am || die "sed Makefile.am failed"
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ eautoreconf
+ # i386 ELF binaries in tarball = bad
+ rm -f "${S}"/files/alarms*
+
+ # Fix up /sbin instances to be /usr/sbin instead
+ for i in src/sgraidmon.c src/sgdiskmon.c ; do
+ sed -i "${S}"/${i} \
+ -e '/evtcmd\[\].*\"\/sbin\//s,/sbin/,/usr/sbin/,' \
+ || die "Failed to set /sbin in sources"
+ done
+}
+
+src_compile() {
+ econf --sbindir=/usr/sbin \
+ || die "econf failed"
+ emake \
+ || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ docdir="/usr/share/doc/${PF}/"
+ emake install DESTDIR="${D}" datato="${D}${docdir}" \
+ || die "emake install failed"
+ dosbin files/sgevt
+ dosbin files/mdevt
+ # unneeded files
+ rm -f "${D}"${docdir}/{SCSIRAS,COPYING}
+ # install modepage files
+ insinto /usr/share/${PN}
+ doins files/*.mdf
+ # new docs
+ dodoc ChangeLog AUTHORS TODO
+ # ensure that other docs from the emake install are compressed too.
+ prepalldocs
+}
diff --git a/sys-block/scsirastools/scsirastools-1.5.7.ebuild b/sys-block/scsirastools/scsirastools-1.5.7.ebuild
new file mode 100644
index 00000000000..fa1f40877aa
--- /dev/null
+++ b/sys-block/scsirastools/scsirastools-1.5.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils
+
+DESCRIPTION="Serviceability for SCSI Disks and Arrays"
+HOMEPAGE="http://scsirastools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/rescan-scsi-bus
+ sys-apps/sg3_utils"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # this builds a really old mdadm
+ sed -i \
+ -e '/RPMB/d' \
+ -e '/^SUBDIRS/s,mdadm.d,,' \
+ -e '/^SUBDIRS/s,files,,' \
+ Makefile.am || die "sed Makefile.am failed"
+ epatch "${FILESDIR}"/${PN}-1.5.6-glibc-2.10.patch
+ eautoreconf
+ # i386 ELF binaries in tarball = bad
+ rm -f "${S}"/files/alarms*
+
+ # Fix up /sbin instances to be /usr/sbin instead
+ for i in src/sgraidmon.c src/sgdiskmon.c ; do
+ sed -i "${S}"/${i} \
+ -e '/evtcmd\[\].*\"\/sbin\//s,/sbin/,/usr/sbin/,' \
+ || die "Failed to set /sbin in sources"
+ done
+}
+
+src_compile() {
+ econf --sbindir=/usr/sbin \
+ || die "econf failed"
+ emake \
+ || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ docdir="/usr/share/doc/${PF}/"
+ emake install DESTDIR="${D}" datato="${D}${docdir}" \
+ || die "emake install failed"
+ dosbin files/sgevt
+ dosbin files/mdevt
+ # unneeded files
+ rm -f "${D}"${docdir}/{SCSIRAS,COPYING}
+ # install modepage files
+ insinto /usr/share/${PN}
+ doins files/*.mdf
+ # new docs
+ dodoc ChangeLog AUTHORS TODO
+ # ensure that other docs from the emake install are compressed too.
+ prepalldocs
+}