summaryrefslogtreecommitdiff
path: root/sys-block
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-29 12:35:58 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-29 12:35:58 -0500
commit3b9b96be4fb14e9510861752387d94ce9d0a8345 (patch)
tree16fa1f0fdeaa98fda50b18fe6f94a5159d757d98 /sys-block
parentb9b896f3f927a57afde1c63a6ff387fc08996666 (diff)
downloadgentoo-3b9b96be4fb14e9510861752387d94ce9d0a8345.tar.gz
gentoo-3b9b96be4fb14e9510861752387d94ce9d0a8345.tar.xz
sys-block/spindown: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/spindown/files/spindownd.initd-r14
-rw-r--r--sys-block/spindown/spindown-0.4.0-r5.ebuild45
2 files changed, 47 insertions, 2 deletions
diff --git a/sys-block/spindown/files/spindownd.initd-r1 b/sys-block/spindown/files/spindownd.initd-r1
index f35908fe847..64a6ec5f73d 100644
--- a/sys-block/spindown/files/spindownd.initd-r1
+++ b/sys-block/spindown/files/spindownd.initd-r1
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
SPINDOWND_BIN="/usr/sbin/spindownd"
diff --git a/sys-block/spindown/spindown-0.4.0-r5.ebuild b/sys-block/spindown/spindown-0.4.0-r5.ebuild
new file mode 100644
index 00000000000..8eced94b72c
--- /dev/null
+++ b/sys-block/spindown/spindown-0.4.0-r5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Spindown is a daemon that can spin down idle disks"
+HOMEPAGE="https://code.google.com/p/spindown"
+SRC_URI="https://spindown.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-apps/sg3_utils"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-CFLAGS-LDFLAGS.patch
+ eapply_user
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ insinto /etc
+ newins spindown.conf.example spindown.conf
+ newinitd "${FILESDIR}"/spindownd.initd-r1 spindownd
+ newconfd "${FILESDIR}"/spindownd.confd-r1 spindownd
+ dosbin spindownd
+ dodoc CHANGELOG README TODO spindown.conf.example
+}
+
+pkg_postinst() {
+ elog "Before starting spindownd the first time"
+ elog "you should modify /etc/spindown.conf"
+ elog
+ elog "To start spindownd by default"
+ elog "you should add it to the default runlevel:"
+ elog " rc-update add spindownd default"
+}