summaryrefslogtreecommitdiff
path: root/sys-boot/palo/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-boot/palo/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-boot/palo/files')
-rw-r--r--sys-boot/palo/files/99palo3
-rw-r--r--sys-boot/palo/files/palo-1.92-toolchain.patch20
-rw-r--r--sys-boot/palo/files/palo-1.95-toolchain.patch27
-rw-r--r--sys-boot/palo/files/palo.conf8
4 files changed, 58 insertions, 0 deletions
diff --git a/sys-boot/palo/files/99palo b/sys-boot/palo/files/99palo
new file mode 100644
index 00000000000..8caea49f51a
--- /dev/null
+++ b/sys-boot/palo/files/99palo
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+palo -v
diff --git a/sys-boot/palo/files/palo-1.92-toolchain.patch b/sys-boot/palo/files/palo-1.92-toolchain.patch
new file mode 100644
index 00000000000..b72947b6369
--- /dev/null
+++ b/sys-boot/palo/files/palo-1.92-toolchain.patch
@@ -0,0 +1,20 @@
+--- a/palo/Makefile
++++ b/palo/Makefile
+@@ -14,7 +14,7 @@
+ ifeq ($(strip ${OS}),HP-UX)
+ CFLAGS=-g -O -I../include -I../lib -I$(PA)/include
+ else
+-CFLAGS=-g -O -I../include -I../lib
++CFLAGS+= -O -I../include -I../lib
+ endif
+
+ # LDFLAGS=-Wl,-Bstatic
+@@ -34,7 +34,7 @@
+ $(CC) $(CFLAGS) $(LDFLAGS) -o palo palo.a build.o
+
+ palo.a: $(OFILES)
+- ar rv palo.a $?
++ $(AR) rv palo.a $?
+
+ mkbootable: $(OFILES2)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o mkbootable $(OFILES2)
diff --git a/sys-boot/palo/files/palo-1.95-toolchain.patch b/sys-boot/palo/files/palo-1.95-toolchain.patch
new file mode 100644
index 00000000000..1e70f2d5ebf
--- /dev/null
+++ b/sys-boot/palo/files/palo-1.95-toolchain.patch
@@ -0,0 +1,27 @@
+--- a/palo/Makefile
++++ b/palo/Makefile
+@@ -12,13 +12,12 @@
+ OS := $(shell uname -s)
+ CC?=cc
+ ifeq ($(strip ${OS}),HP-UX)
+-CFLAGS=-g -O -I../include -I../lib -I$(PA)/include
++CFLAGS=-O -I../include -I../lib -I$(PA)/include
+ else
+-CFLAGS=-g -O -I../include -I../lib -D_FILE_OFFSET_BITS=64
++CFLAGS=-O -I../include -I../lib -D_FILE_OFFSET_BITS=64
+ endif
+
+ # LDFLAGS=-Wl,-Bstatic
+-LDFLAGS=
+
+ OFILES2=mkbootable.o elf64.o load.o paloio.o elf32.o error.o gzip.o
+
+@@ -34,7 +33,7 @@
+ $(CC) $(CFLAGS) $(LDFLAGS) -o palo palo.a build.o
+
+ palo.a: $(OFILES)
+- ar rv palo.a $?
++ $(AR) rv palo.a $?
+
+ mkbootable: $(OFILES2)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o mkbootable $(OFILES2)
diff --git a/sys-boot/palo/files/palo.conf b/sys-boot/palo/files/palo.conf
new file mode 100644
index 00000000000..8880b50b5f1
--- /dev/null
+++ b/sys-boot/palo/files/palo.conf
@@ -0,0 +1,8 @@
+# Please read the palo --help output for more info
+# Non-commented lines are treated as command line arguments
+
+--commandline=2/vmlinux root=/dev/sda4
+--init-partitioned=/dev/sda
+
+#Uncomment this if you want a rescue kernel
+#--recoverykernel=/boot/vmlinux.old