summaryrefslogtreecommitdiff
path: root/sys-cluster/c3
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/c3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/c3')
-rw-r--r--sys-cluster/c3/Manifest1
-rw-r--r--sys-cluster/c3/c3-4.0.1.ebuild56
-rw-r--r--sys-cluster/c3/metadata.xml5
3 files changed, 62 insertions, 0 deletions
diff --git a/sys-cluster/c3/Manifest b/sys-cluster/c3/Manifest
new file mode 100644
index 00000000000..88d86c55f33
--- /dev/null
+++ b/sys-cluster/c3/Manifest
@@ -0,0 +1 @@
+DIST c3-4.0.1.tar.gz 55142 SHA256 263db9a724a8a6595e110f61d60878897acde23c30a8d8e7ed4238261094cd06 SHA512 a8ace5605709dd713f1686f3e13cd635d0d38224c835b43d0a02f255ddbd77fb9bbd4bbc0a1fac2d08a84bea2e98215264681381d9e9113ae737cc3a23a8dc89 WHIRLPOOL a3c6cbf1782b1ecabb0fa455bab8219fdeba353000e2e871aaa0be92ee3f25370b350c36b4287c08441a35f8c5eeefe12188f0dba11f808b348539a777850de0
diff --git a/sys-cluster/c3/c3-4.0.1.ebuild b/sys-cluster/c3/c3-4.0.1.ebuild
new file mode 100644
index 00000000000..a38f3c5daae
--- /dev/null
+++ b/sys-cluster/c3/c3-4.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="The Cluster Command and Control (C3) tool suite"
+HOMEPAGE="http://www.csm.ornl.gov/torc/C3/"
+SRC_URI="http://www.csm.ornl.gov/torc/C3/Software/${PV}/${P}.tar.gz"
+LICENSE="C3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Everything it needs is in "system" (profiles/base/packages)
+DEPEND=""
+
+src_compile() {
+ :
+}
+
+src_install() {
+ # The Install-c3 script is a complete hack, so we do this ourselves.
+ # CHANGELOG says it's FHS-compliant to put stuff here, so we'll believe it.
+ local C3DIR="/opt/c3-4"
+ dodir ${C3DIR}
+
+ # "libraries"
+ insinto ${C3DIR}
+ doins *.py
+
+ # tools
+ exeinto ${C3DIR}
+ # Everything's in the same dir, so we need to weed out non-tool things
+ local TOOL
+ for TOOL in $(find ${S} -maxdepth 1 -type f -name 'c*' -not -name '*.*'); do
+ doexe ${TOOL}
+ done
+ # Get systemimager-using tool out of bin, since systemimager isn't in
+ # portage
+ dodoc ${D}/${C3DIR}/cpushimage
+ rm ${D}/${C3DIR}/cpushimage
+
+ dodoc README README.scale CHANGELOG KNOWN_BUGS
+ docinto contrib
+ dodoc contrib/*
+
+ doman man/man*/*
+
+ # Create env.d file
+ echo "PATH=${C3DIR}" > ${T}/40${PN}
+ echo "ROOTPATH=${C3DIR}" >> ${T}/40${PN}
+ doenvd ${T}/40${PN}
+}
+
+pkg_postinst() {
+ einfo "Because systemimager is not in Portage, cpushimage"
+ einfo "has been installed to /usr/share/doc/${P}/."
+}
diff --git a/sys-cluster/c3/metadata.xml b/sys-cluster/c3/metadata.xml
new file mode 100644
index 00000000000..348e6c4de81
--- /dev/null
+++ b/sys-cluster/c3/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cluster</herd>
+</pkgmetadata>