summaryrefslogtreecommitdiff
path: root/sys-cluster/glusterfs/glusterfs-3.2.7.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/glusterfs/glusterfs-3.2.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/glusterfs/glusterfs-3.2.7.ebuild')
-rw-r--r--sys-cluster/glusterfs/glusterfs-3.2.7.ebuild122
1 files changed, 122 insertions, 0 deletions
diff --git a/sys-cluster/glusterfs/glusterfs-3.2.7.ebuild b/sys-cluster/glusterfs/glusterfs-3.2.7.ebuild
new file mode 100644
index 00000000000..ffd564e4b2b
--- /dev/null
+++ b/sys-cluster/glusterfs/glusterfs-3.2.7.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+inherit autotools elisp-common eutils multilib python versionator
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="http://www.gluster.org/"
+SRC_URI="http://ftp.gluster.com/pub/gluster/${PN}/$(get_version_component_range '1-2')/${PV}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="emacs extras +fuse infiniband static-libs vim-syntax"
+
+RDEPEND="emacs? ( virtual/emacs )
+ fuse? ( >=sys-fs/fuse-2.7.0 )
+ infiniband? ( sys-infiniband/libibverbs )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/bison
+ sys-devel/flex"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.1.0-parallel-build.patch" \
+ "${FILESDIR}/${PN}-docdir.patch" \
+ "${FILESDIR}/glusterd-3.2.0-workdir.patch"
+ sed -i -e "s/ -ggdb3//g" -e "s/ -m64//g" argp-standalone/configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable fuse fuse-client) \
+ $(use_enable infiniband ibverbs) \
+ $(use_enable static-libs static) \
+ --enable-georeplication \
+ --disable-bdb \
+ --docdir=/usr/share/doc/${PF} \
+ --localstatedir=/var
+}
+
+src_compile() {
+ emake
+ if use emacs ; then
+ elisp-compile extras/glusterfs-mode.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use emacs ; then
+ elisp-install ${PN} extras/glusterfs-mode.el* || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}/glusterfs.vim"
+ insinto /usr/share/vim/vimfiles/syntax; doins extras/glusterfs.vim
+ fi
+
+ if use extras ; then
+ newbin extras/backend-xattr-sanitize.sh glusterfs-backend-xattr-sanitize
+ newbin extras/backend-cleanup.sh glusterfs-backend-cleanup
+ newbin extras/migrate-unify-to-distribute.sh glusterfs-migrate-unify-to-distribute
+ newbin extras/disk_usage_sync.sh glusterfs-disk-usage-sync
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ newinitd "${FILESDIR}/${PN}.initd" glusterfsd
+ newinitd "${FILESDIR}/glusterd.initd" glusterd
+ newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+ keepdir /var/log/${PN}
+ keepdir /var/lib/glusterd
+
+ python_convert_shebangs -r 2 "${ED}"
+}
+
+pkg_postinst() {
+ elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+ elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+ elog " /etc/init.d/glusterd start"
+ elog
+ elog "For static configurations, the glusterfsd startup script can be multiplexed."
+ elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+ elog "separate service. To create additional instances of the glusterfsd service"
+ elog "simply create a symlink to the glusterfsd startup script."
+ elog
+ elog "Example:"
+ elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
+ elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+ elog "You can now treat glusterfsd2 like any other service"
+ elog
+ ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+ ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+ ewarn "run GlusterFS."
+
+ if [[ ${REPLACING_VERSIONS} < 3.1 ]]; then
+ elog
+ elog "You are upgrading from a previous version of ${PN}, please read:"
+ elog "http://www.gluster.com/community/documentation/index.php/Gluster_3.0_to_3.2_Upgrade_Guide"
+ fi
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}