summaryrefslogtreecommitdiff
path: root/sys-cluster/libcircle
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/libcircle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/libcircle')
-rw-r--r--sys-cluster/libcircle/Manifest1
-rw-r--r--sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild44
-rw-r--r--sys-cluster/libcircle/metadata.xml12
3 files changed, 57 insertions, 0 deletions
diff --git a/sys-cluster/libcircle/Manifest b/sys-cluster/libcircle/Manifest
new file mode 100644
index 00000000000..28bac28f119
--- /dev/null
+++ b/sys-cluster/libcircle/Manifest
@@ -0,0 +1 @@
+DIST libcircle-0.2.0_rc1.tar.gz 351901 SHA256 59ed75c0bdf2b24f96fbc0230848a5aab57d4eab5a68895489d59a7f68ddd2ee SHA512 1ce07ae012c281fe3e6fbae29bf48e1079768ed5f92f9375c3be02880bed1b1feee6630b31560d7129f76640990e94da1753f55b11a0a8977adaaf9e51144044 WHIRLPOOL 984713d28ee80f686daea7d419a1135360bcda542f904a1aa4ea0ef03b87482e60c2c0858a9e6fd85d7bde1ef557bd61c717ba924f942dfd82d7cbeb9a2e0359
diff --git a/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild b/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild
new file mode 100644
index 00000000000..3dd4c2759e3
--- /dev/null
+++ b/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/hpc/${PN}.git http://github.com/hpc/${PN}.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/hpc/${PN}/archive/${PV/_rc/-rc.}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
+
+DESCRIPTION="an API for distributing embarrassingly parallel workloads using self-stabilization"
+HOMEPAGE="https://github.com/hpc/libcircle"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="doc test"
+
+RDEPEND="virtual/mpi"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )"
+
+DOCS=( HACKING.md README.md )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable test tests)
+ $(use_enable doc doxygen)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${BUILD_DIR}/doc/html/" )
+ autotools-utils_src_install
+}
diff --git a/sys-cluster/libcircle/metadata.xml b/sys-cluster/libcircle/metadata.xml
new file mode 100644
index 00000000000..b3a83b96a3a
--- /dev/null
+++ b/sys-cluster/libcircle/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hpc/libcircle</remote-id>
+ </upstream>
+</pkgmetadata>