summaryrefslogtreecommitdiff
path: root/sys-cluster/openais
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/openais
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/openais')
-rw-r--r--sys-cluster/openais/Manifest1
-rw-r--r--sys-cluster/openais/metadata.xml14
-rw-r--r--sys-cluster/openais/openais-1.1.4-r1.ebuild46
3 files changed, 61 insertions, 0 deletions
diff --git a/sys-cluster/openais/Manifest b/sys-cluster/openais/Manifest
new file mode 100644
index 00000000000..99cb251d685
--- /dev/null
+++ b/sys-cluster/openais/Manifest
@@ -0,0 +1 @@
+DIST openais-1.1.4.tar.gz 566559 SHA256 974b4959f3c401c16156dab31e65a6d45bbf84dd85a88c2a362712e738c06934
diff --git a/sys-cluster/openais/metadata.xml b/sys-cluster/openais/metadata.xml
new file mode 100644
index 00000000000..e1b15c2588a
--- /dev/null
+++ b/sys-cluster/openais/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <longdescription>
+ The OpenAIS Standards Based Cluster Framework is an OSI Certified implementation of
+ the Service Availability Forum Application Interface Specification (AIS).
+ The Application Interface Specification is a software API and policies which are
+ used to develop applications that maintain service during faults.
+ Restarting and failover of applications is also provided for those
+ deploying applications which may not be modified. The OpenAIS software is built
+ to operate as plugins to the Corosync Cluster Engine.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-cluster/openais/openais-1.1.4-r1.ebuild b/sys-cluster/openais/openais-1.1.4-r1.ebuild
new file mode 100644
index 00000000000..440d958aa26
--- /dev/null
+++ b/sys-cluster/openais/openais-1.1.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools base
+
+DESCRIPTION="Open Application Interface Specification cluster framework"
+HOMEPAGE="http://www.openais.org/"
+SRC_URI="ftp://ftp:${PN}.org@${PN}.org/downloads/${P}/${P}.tar.gz"
+
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="amd64 hppa x86 ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND="<sys-cluster/corosync-2.0.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( "${S}/AUTHORS" "${S}/README.amf" )
+
+src_prepare() {
+ # respect CFLAGS
+ sed -i -e "s/\$OPT_CFLAGS \$GDB_FLAGS//" configure.ac || die
+ # respect LDFLAGS
+ sed -i -e "s/\$(CFLAGS) -shared/\$(CFLAGS) \$(LDFLAGS) -shared/" \
+ services/Makefile.am || die
+ # don't install docs
+ sed -i -e "/^dist_doc/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --localstatedir=/var
+}
+
+src_install() {
+ base_src_install
+ rm -rf "${D}"/etc/init.d/openais || die
+ use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.a || die
+}