summaryrefslogtreecommitdiff
path: root/sys-cluster
diff options
context:
space:
mode:
authorGraeme Lawes <graemelawes@gmail.com>2017-08-17 23:37:59 -0400
committerMichał Górny <mgorny@gentoo.org>2017-08-19 20:20:34 +0200
commit3868a4ae836f49d059d295c39a94a1fca4675d4a (patch)
tree21e283f7b7bcd8bdfd4936fac1316ede8ff7e2e4 /sys-cluster
parent0e0fa054d2f24c7ff4512a1c48dde3f30841c2dc (diff)
downloadgentoo-3868a4ae836f49d059d295c39a94a1fca4675d4a.tar.gz
gentoo-3868a4ae836f49d059d295c39a94a1fca4675d4a.tar.xz
sys-cluster/teleport: don't pre-strip binaries
Needed to patch Makefile to allow BUILDFLAGS to be overridden. This will be fixed in later upstream releases.
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/teleport/files/teleport-makefile-buildflags.patch11
-rw-r--r--sys-cluster/teleport/teleport-2.2.0.ebuild4
-rw-r--r--sys-cluster/teleport/teleport-2.2.1.ebuild4
-rw-r--r--sys-cluster/teleport/teleport-2.2.4.ebuild4
-rw-r--r--sys-cluster/teleport/teleport-9999.ebuild2
5 files changed, 21 insertions, 4 deletions
diff --git a/sys-cluster/teleport/files/teleport-makefile-buildflags.patch b/sys-cluster/teleport/files/teleport-makefile-buildflags.patch
new file mode 100644
index 00000000000..d3da35350d8
--- /dev/null
+++ b/sys-cluster/teleport/files/teleport-makefile-buildflags.patch
@@ -0,0 +1,11 @@
+--- work/src/github.com/gravitational/teleport/Makefile
++++ work/src/github.com/gravitational/teleport/Makefile
+@@ -12,7 +12,7 @@
+ PWD ?= `pwd`
+ TELEPORT_DEBUG ?= no
+ GITTAG=v$(VERSION)
+-BUILDFLAGS := $(ADDFLAGS) -ldflags '-w -s'
++BUILDFLAGS ?= $(ADDFLAGS) -ldflags '-w -s'
+
+ RELEASE=teleport-$(GITTAG)-`go env GOOS`-`go env GOARCH`-bin
+ BINARIES=$(BUILDDIR)/tsh $(BUILDDIR)/teleport $(BUILDDIR)/tctl
diff --git a/sys-cluster/teleport/teleport-2.2.0.ebuild b/sys-cluster/teleport/teleport-2.2.0.ebuild
index 73701f3ef24..3fafc3ed333 100644
--- a/sys-cluster/teleport/teleport-2.2.0.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.0.ebuild
@@ -27,8 +27,10 @@ DEPEND="
>=dev-lang/go-1.8.3"
RDEPEND=""
+PATCHES=( "${FILESDIR}"/${PN}-makefile-buildflags.patch )
+
src_compile() {
- GOPATH="${S}" emake -C src/${EGO_PN%/*}
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*}
pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
popd >/dev/null || die
diff --git a/sys-cluster/teleport/teleport-2.2.1.ebuild b/sys-cluster/teleport/teleport-2.2.1.ebuild
index 73701f3ef24..3fafc3ed333 100644
--- a/sys-cluster/teleport/teleport-2.2.1.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.1.ebuild
@@ -27,8 +27,10 @@ DEPEND="
>=dev-lang/go-1.8.3"
RDEPEND=""
+PATCHES=( "${FILESDIR}"/${PN}-makefile-buildflags.patch )
+
src_compile() {
- GOPATH="${S}" emake -C src/${EGO_PN%/*}
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*}
pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
popd >/dev/null || die
diff --git a/sys-cluster/teleport/teleport-2.2.4.ebuild b/sys-cluster/teleport/teleport-2.2.4.ebuild
index d4cdaf815da..90fddb344c0 100644
--- a/sys-cluster/teleport/teleport-2.2.4.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.4.ebuild
@@ -28,8 +28,10 @@ DEPEND="
>=dev-lang/go-1.8.3"
RDEPEND=""
+PATCHES=( "${FILESDIR}"/${PN}-makefile-buildflags.patch )
+
src_compile() {
- GOPATH="${S}" emake -C src/${EGO_PN%/*}
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*}
pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
popd >/dev/null || die
diff --git a/sys-cluster/teleport/teleport-9999.ebuild b/sys-cluster/teleport/teleport-9999.ebuild
index 99620ea6684..3e870fac4bd 100644
--- a/sys-cluster/teleport/teleport-9999.ebuild
+++ b/sys-cluster/teleport/teleport-9999.ebuild
@@ -28,7 +28,7 @@ DEPEND="
RDEPEND=""
src_compile() {
- GOPATH="${S}" emake -C src/${EGO_PN%/*}
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*}
pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
popd >/dev/null || die