summaryrefslogtreecommitdiff
path: root/sys-devel/crossdev
diff options
context:
space:
mode:
authorLara Maia <dev@lara.click>2016-02-18 12:51:24 -0200
committerLara Maia <dev@lara.click>2016-02-18 12:53:43 -0200
commit83ff3dd2c6eea0aeb079ccfcd57f0608d9572827 (patch)
tree533b01bdc6928fb0ac436d857025104287f47395 /sys-devel/crossdev
parent0df5c304227f251ff704d2353883983bc0df2d6e (diff)
downloadgentoo-83ff3dd2c6eea0aeb079ccfcd57f0608d9572827.tar.gz
gentoo-83ff3dd2c6eea0aeb079ccfcd57f0608d9572827.tar.xz
sys-devel/crossdev: Update crossdev to use new path for functions.sh
https://bugs.gentoo.org/show_bug.cgi?id=538656
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/crossdev-20151026-r1.ebuild42
-rw-r--r--sys-devel/crossdev/crossdev-99999999.ebuild12
-rw-r--r--sys-devel/crossdev/files/use-new-path-for-functions.sh.patch11
3 files changed, 62 insertions, 3 deletions
diff --git a/sys-devel/crossdev/crossdev-20151026-r1.ebuild b/sys-devel/crossdev/crossdev-20151026-r1.ebuild
new file mode 100644
index 00000000000..eb84933ea66
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20151026-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils
+ sys-apps/gentoo-functions"
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
+}
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}
diff --git a/sys-devel/crossdev/crossdev-99999999.ebuild b/sys-devel/crossdev/crossdev-99999999.ebuild
index 3b816c239cf..eb84933ea66 100644
--- a/sys-devel/crossdev/crossdev-99999999.ebuild
+++ b/sys-devel/crossdev/crossdev-99999999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
+inherit eutils
if [[ ${PV} == "99999999" ]] ; then
EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
@@ -26,7 +27,12 @@ RDEPEND=">=sys-apps/portage-2.1
>=app-portage/portage-utils-0.55
app-shells/bash
!sys-devel/crossdev-wrappers"
-DEPEND="app-arch/xz-utils"
+DEPEND="app-arch/xz-utils
+ sys-apps/gentoo-functions"
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
+}
src_install() {
default
diff --git a/sys-devel/crossdev/files/use-new-path-for-functions.sh.patch b/sys-devel/crossdev/files/use-new-path-for-functions.sh.patch
new file mode 100644
index 00000000000..8607fc13483
--- /dev/null
+++ b/sys-devel/crossdev/files/use-new-path-for-functions.sh.patch
@@ -0,0 +1,11 @@
+--- crossdev.orig 2016-02-18 12:28:49.926442767 -0200
++++ crossdev 2016-02-18 12:32:25.962433210 -0200
+@@ -15,7 +15,7 @@
+
+ CONFIGROOT="${PORTAGE_CONFIGROOT}/etc/portage"
+
+-source /etc/init.d/functions.sh || exit 1
++source /lib/gentoo/functions.sh || exit 1
+ esyslog() { :; }
+ die_logs() {
+ echo