summaryrefslogtreecommitdiff
path: root/sys-devel/crossdev
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-11-19 23:09:14 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-11-19 23:09:27 +0000
commitd0fa1795fcd5f556c5ca856e8fd786021980912a (patch)
treed36b49591be45a997c79101eacc77e2d5165680c /sys-devel/crossdev
parent06ec1a5b748a6ec707f0f02596496d330dd97d85 (diff)
downloadgentoo-d0fa1795fcd5f556c5ca856e8fd786021980912a.tar.gz
gentoo-d0fa1795fcd5f556c5ca856e8fd786021980912a.tar.xz
sys-devel/crossdev: bump up to 20171119
Bug: https://bugs.gentoo.org/638182 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20171119.ebuild35
-rw-r--r--sys-devel/crossdev/crossdev-99999999.ebuild5
3 files changed, 39 insertions, 2 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 3c8692ffac6..d59f525cff1 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,2 +1,3 @@
DIST crossdev-20151026.tar.xz 22160 SHA256 ad5ff1cc334325f83f60f87f9a6d795c606317665042cece9d8f12297312ca28 SHA512 f60efd4ad867efd0eb33de5fe327ccbfe73b574c97507bc0edd7ef141ad74c035ae2a0d446180e6a9eb5f43197f44933a452245feec849bacfb03fc07067edd0 WHIRLPOOL 7a8f556e53e7142ccf9c56d6daf700b33d66e530d85e5a5ed5b154a52bbba450956381af06f7b5748a6a82a43666a8c1b7d879296869dadd090e8887fc623ea9
DIST crossdev-20160602.tar.xz 22292 SHA256 12dcbbdedc3f89a7b782c2b61c2956da050cfc95eef860a2f2701bfc89c77ce9 SHA512 580cc51e599086a14c51153e656d30b5c2f0e08c7601384d3e082716edeaa532e832b515df2517618cc51be187fcf8738db10e412a5635a16d0bb58b1631a53e WHIRLPOOL 7ccc23cd01030e1b55266784448187ab30ded10b229b03886faf739fd5d1ed07d73c60fb950c1c28c81e7dd309324bd740d8439640113241f493973ba79b53cd
+DIST crossdev-20171119.tar.xz 22596 SHA256 87825ce1b914248008f5be7abaf9f60733ba509ed3f8bb0050fe6b1219d575ef SHA512 3b8d7b89adf06d5ffef169ed1015532220c997731e083fd73c27d80ea09a6a7efd456734104aa58ef386426f9a04fed3147f37aefe4106c378a0b865bfffb2f0 WHIRLPOOL f6b88c77cd49f15b8a59d0ffdf942a2db44fc398ecc09087a3f22cd81a2922ac3320df0eded06039fca0a40165f2a713ca5c25f2ece93bd9ea2fc7b1291cc40e
diff --git a/sys-devel/crossdev/crossdev-20171119.ebuild b/sys-devel/crossdev/crossdev-20171119.ebuild
new file mode 100644
index 00000000000..73d9c469006
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20171119.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
+ fi
+}
diff --git a/sys-devel/crossdev/crossdev-99999999.ebuild b/sys-devel/crossdev/crossdev-99999999.ebuild
index 724d297db4a..73d9c469006 100644
--- a/sys-devel/crossdev/crossdev-99999999.ebuild
+++ b/sys-devel/crossdev/crossdev-99999999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
if [[ ${PV} == "99999999" ]] ; then
inherit git-r3
EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
else
SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
fi
@@ -28,6 +28,7 @@ DEPEND="app-arch/xz-utils"
src_install() {
default
+
if [[ "${PV}" == "99999999" ]] ; then
sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
fi