summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/files/9999
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-20 23:22:58 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-22 17:11:46 +0200
commitfeeb9f07adda22b56a732141522cc3ad57820aeb (patch)
treec3799c0d238c36da8e3a105d779373e8331a12c8 /sys-devel/llvm/files/9999
parent2bafef730e634bbb6a29e2807e4ebdde0c899c65 (diff)
downloadgentoo-feeb9f07adda22b56a732141522cc3ad57820aeb.tar.gz
gentoo-feeb9f07adda22b56a732141522cc3ad57820aeb.tar.xz
sys-devel/llvm: Strip external projects off the live ebuild
Diffstat (limited to 'sys-devel/llvm/files/9999')
-rw-r--r--sys-devel/llvm/files/9999/0009-cmake-Use-system-llvm-lit-when-lit.py-does-not-exist.patch33
-rw-r--r--sys-devel/llvm/files/9999/0010-lit-setup.py-Install-as-llvm-lit-as-cmake-expects-it.patch30
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-devel/llvm/files/9999/0009-cmake-Use-system-llvm-lit-when-lit.py-does-not-exist.patch b/sys-devel/llvm/files/9999/0009-cmake-Use-system-llvm-lit-when-lit.py-does-not-exist.patch
new file mode 100644
index 00000000000..7245af07d2e
--- /dev/null
+++ b/sys-devel/llvm/files/9999/0009-cmake-Use-system-llvm-lit-when-lit.py-does-not-exist.patch
@@ -0,0 +1,33 @@
+From bcdf2c49b7686046f8a9a5664f0e46117997baf4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 21 Aug 2016 23:19:40 +0200
+Subject: [PATCH 09/10] cmake: Use system llvm-lit when lit.py does not exist
+ in srcdir
+
+Modify the add_lit_target function to use lit.py from LLVM_MAIN_SRC_DIR
+only when one does exist there, and otherwise fall back to looking for
+system install of llvm-lit. This is based on a similar conditional in
+clang's CMakeLists.txt, and makes it possible to run clang's tests when
+built separately from LLVM with no access to the original sources.
+
+Patch: https://reviews.llvm.org/D23742
+---
+ cmake/modules/AddLLVM.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/modules/AddLLVM.cmake b/cmake/modules/AddLLVM.cmake
+index 83a2359..87540d5 100644
+--- a/cmake/modules/AddLLVM.cmake
++++ b/cmake/modules/AddLLVM.cmake
+@@ -1081,7 +1081,7 @@ function(add_lit_target target comment)
+ if (NOT CMAKE_CFG_INTDIR STREQUAL ".")
+ list(APPEND LIT_ARGS --param build_mode=${CMAKE_CFG_INTDIR})
+ endif ()
+- if (LLVM_MAIN_SRC_DIR)
++ if(EXISTS ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
+ set (LIT_COMMAND ${PYTHON_EXECUTABLE} ${LLVM_MAIN_SRC_DIR}/utils/lit/lit.py)
+ else()
+ find_program(LIT_COMMAND llvm-lit)
+--
+2.9.3
+
diff --git a/sys-devel/llvm/files/9999/0010-lit-setup.py-Install-as-llvm-lit-as-cmake-expects-it.patch b/sys-devel/llvm/files/9999/0010-lit-setup.py-Install-as-llvm-lit-as-cmake-expects-it.patch
new file mode 100644
index 00000000000..53726aa3f5e
--- /dev/null
+++ b/sys-devel/llvm/files/9999/0010-lit-setup.py-Install-as-llvm-lit-as-cmake-expects-it.patch
@@ -0,0 +1,30 @@
+From 242fd2cbad1075d4cc0e3a3b64652dbc766bd117 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 21 Aug 2016 23:20:11 +0200
+Subject: [PATCH 10/10] lit/setup.py: Install as llvm-lit (as cmake expects it)
+
+Modify the setup.py for lit to install the entry point as llvm-lit
+(instead of lit) since this is the name expected by functions in
+AddLLVM.cmake.
+
+Patch: https://reviews.llvm.org/D23743
+---
+ utils/lit/setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/utils/lit/setup.py b/utils/lit/setup.py
+index 10de6bb..c57e0aa 100644
+--- a/utils/lit/setup.py
++++ b/utils/lit/setup.py
+@@ -71,7 +71,7 @@ http://llvm.org/svn/llvm-project/llvm/trunk/utils/lit.
+ packages = find_packages(),
+ entry_points = {
+ 'console_scripts': [
+- 'lit = lit:main',
++ 'llvm-lit = lit:main',
+ ],
+ }
+ )
+--
+2.9.3
+