summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-3.8.0-r3.ebuild
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-22 15:43:14 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-22 17:11:50 +0200
commit11d093e4ec16f42e733d605dccf3100d4bb435ba (patch)
tree430bb5398c01766b2874e1226a187749ffa98f69 /sys-devel/llvm/llvm-3.8.0-r3.ebuild
parent4ab9c2e321dbe726cbf8083adc157d1bc63e36de (diff)
downloadgentoo-11d093e4ec16f42e733d605dccf3100d4bb435ba.tar.gz
gentoo-11d093e4ec16f42e733d605dccf3100d4bb435ba.tar.xz
sys-devel/llvm: Group all patches by newest version applicable
Diffstat (limited to 'sys-devel/llvm/llvm-3.8.0-r3.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.8.0-r3.ebuild34
1 files changed, 17 insertions, 17 deletions
diff --git a/sys-devel/llvm/llvm-3.8.0-r3.ebuild b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
index 98b01a89ef9..5196fe41612 100644
--- a/sys-devel/llvm/llvm-3.8.0-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
@@ -142,32 +142,32 @@ src_prepare() {
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
# Fix libdir for ocaml bindings install, bug #559134
- eapply "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-multilib.patch
+ eapply "${FILESDIR}"/9999/0001-cmake-Install-OCaml-modules-into-correct-package-loc.patch
# Do not build/install ocaml docs with USE=-doc, bug #562008
- eapply "${FILESDIR}"/cmake/${PN}-3.7.0-ocaml-build_doc.patch
+ eapply "${FILESDIR}"/9999/0002-cmake-Make-OCaml-docs-dependent-on-LLVM_BUILD_DOCS.patch
# Make it possible to override Sphinx HTML install dirs
# https://llvm.org/bugs/show_bug.cgi?id=23780
- eapply "${FILESDIR}"/cmake/0002-cmake-Support-overriding-Sphinx-HTML-doc-install-dir.patch
+ eapply "${FILESDIR}"/9999/0003-cmake-Support-overriding-Sphinx-HTML-doc-install-dir.patch
# Prevent race conditions with parallel Sphinx runs
# https://llvm.org/bugs/show_bug.cgi?id=23781
- eapply "${FILESDIR}"/cmake/0003-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+ eapply "${FILESDIR}"/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
- eapply "${FILESDIR}"/cmake/0004-cmake-Do-not-install-libgtest.patch
+ eapply "${FILESDIR}"/9999/0005-cmake-Do-not-install-libgtest.patch
# Allow custom cmake build types (like 'Gentoo')
- eapply "${FILESDIR}"/cmake/${PN}-3.8-allow_custom_cmake_build_types.patch
+ eapply "${FILESDIR}"/9999/0006-cmake-Remove-the-CMAKE_BUILD_TYPE-assertion.patch
# Fix llvm-config for shared linking and sane flags
# https://bugs.gentoo.org/show_bug.cgi?id=565358
- eapply "${FILESDIR}"/llvm-3.8-llvm-config.patch
+ eapply "${FILESDIR}"/3.8.1/llvm-config.patch
# Restore SOVERSIONs for shared libraries
# https://bugs.gentoo.org/show_bug.cgi?id=578392
- eapply "${FILESDIR}"/llvm-3.8-soversion.patch
+ eapply "${FILESDIR}"/9999/0008-cmake-Restore-SOVERSIONs-on-shared-libraries.patch
# disable use of SDK on OSX, bug #568758
sed -i -e 's/xcrun/false/' utils/lit/lit/util.py || die
@@ -177,13 +177,13 @@ src_prepare() {
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
- eapply "${FILESDIR}"/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
+ eapply "${FILESDIR}"/3.8.1/clang/gentoo-runtime-gcc-detection-v3.patch
# Support gcc4.9 search paths
# https://github.com/llvm-mirror/clang/commit/af4db76e059c1a3
- eapply "${FILESDIR}"/clang-3.8-gcc4.9-search-path.patch
+ eapply "${FILESDIR}"/3.8.1/clang/gcc4.9-search-path.patch
- eapply "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
+ eapply "${FILESDIR}"/3.8.1/clang/darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
sed -i -e "s^@EPREFIX@^${EPREFIX}^" \
@@ -191,24 +191,24 @@ src_prepare() {
# Install clang runtime into /usr/lib/clang
# https://llvm.org/bugs/show_bug.cgi?id=23792
- eapply "${FILESDIR}"/cmake/clang-0001-Install-clang-runtime-into-usr-lib-without-suffix-3.8.patch
- eapply "${FILESDIR}"/cmake/compiler-rt-0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
+ eapply "${FILESDIR}"/3.8.1/clang/0001-Install-clang-runtime-into-usr-lib-without-suffix.patch
+ eapply "${FILESDIR}"/3.8.1/compiler-rt/0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
# Do not force -march flags on arm platforms
# https://bugs.gentoo.org/show_bug.cgi?id=562706
- eapply "${FILESDIR}"/cmake/${PN}-3.8.0-compiler_rt_arm_march_flags.patch
+ eapply "${FILESDIR}"/3.8.1/compiler-rt/arm_march_flags.patch
# Make it possible to override CLANG_LIBDIR_SUFFIX
# (that is used only to find LLVMgold.so)
# https://llvm.org/bugs/show_bug.cgi?id=23793
- eapply "${FILESDIR}"/cmake/clang-0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
+ eapply "${FILESDIR}"/3.8.1/clang/0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
# Fix git-clang-format shebang, bug #562688
python_fix_shebang tools/clang/tools/clang-format/git-clang-format
# Fix 'stdarg.h' file not found on Gentoo/FreeBSD, bug #578064
# https://llvm.org/bugs/show_bug.cgi?id=26651
- eapply "${FILESDIR}"/clang-3.8-compiler-rt-fbsd.patch
+ eapply "${FILESDIR}"/3.8.1/compiler-rt/fbsd.patch
pushd projects/compiler-rt >/dev/null || die
@@ -226,7 +226,7 @@ src_prepare() {
sed -e 's/add_subdirectory(readline)/#&/' \
-i tools/lldb/scripts/Python/modules/CMakeLists.txt || die
# Do not install bundled six module
- eapply "${FILESDIR}"/${PN}-3.8-lldb_six.patch
+ eapply "${FILESDIR}"/3.8.1/lldb/six.patch
fi
# User patches