summaryrefslogtreecommitdiff
path: root/sys-devel/llvm
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-09-10 17:20:26 +0200
committerFabian Groffen <grobian@gentoo.org>2016-09-10 17:20:41 +0200
commit2a73d6a0d8612d1d396b0bf436a0ed9d9affb25c (patch)
tree8abb89b1b21f48d4f9840064d4050242cece354a /sys-devel/llvm
parent052b6bbf6cde1d2808849fffb459c675957dc217 (diff)
downloadgentoo-2a73d6a0d8612d1d396b0bf436a0ed9d9affb25c.tar.gz
gentoo-2a73d6a0d8612d1d396b0bf436a0ed9d9affb25c.tar.xz
sys-devel/llvm: fix patches for 3.4.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/files/3.4.2/clang/darwin_build_fix.patch (renamed from sys-devel/llvm/files/clang-3.4-darwin_build_fix.patch)0
-rw-r--r--sys-devel/llvm/files/3.4.2/clang/gentoo-install.patch (renamed from sys-devel/llvm/files/clang-3.4-gentoo-install.patch)0
-rw-r--r--sys-devel/llvm/files/3.4.2/clang/gentoo-runtime-gcc-detection-v3.patch (renamed from sys-devel/llvm/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch)0
-rw-r--r--sys-devel/llvm/files/3.4.2/gentoo-install.patch (renamed from sys-devel/llvm/files/llvm-3.4-gentoo-install.patch)0
-rw-r--r--sys-devel/llvm/llvm-3.4.2-r100.ebuild12
5 files changed, 6 insertions, 6 deletions
diff --git a/sys-devel/llvm/files/clang-3.4-darwin_build_fix.patch b/sys-devel/llvm/files/3.4.2/clang/darwin_build_fix.patch
index 113b04bc663..113b04bc663 100644
--- a/sys-devel/llvm/files/clang-3.4-darwin_build_fix.patch
+++ b/sys-devel/llvm/files/3.4.2/clang/darwin_build_fix.patch
diff --git a/sys-devel/llvm/files/clang-3.4-gentoo-install.patch b/sys-devel/llvm/files/3.4.2/clang/gentoo-install.patch
index 0a1d9eb3c35..0a1d9eb3c35 100644
--- a/sys-devel/llvm/files/clang-3.4-gentoo-install.patch
+++ b/sys-devel/llvm/files/3.4.2/clang/gentoo-install.patch
diff --git a/sys-devel/llvm/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch b/sys-devel/llvm/files/3.4.2/clang/gentoo-runtime-gcc-detection-v3.patch
index 49f10853340..49f10853340 100644
--- a/sys-devel/llvm/files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
+++ b/sys-devel/llvm/files/3.4.2/clang/gentoo-runtime-gcc-detection-v3.patch
diff --git a/sys-devel/llvm/files/llvm-3.4-gentoo-install.patch b/sys-devel/llvm/files/3.4.2/gentoo-install.patch
index a2ba7dee47e..a2ba7dee47e 100644
--- a/sys-devel/llvm/files/llvm-3.4-gentoo-install.patch
+++ b/sys-devel/llvm/files/3.4.2/gentoo-install.patch
diff --git a/sys-devel/llvm/llvm-3.4.2-r100.ebuild b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
index 5e73596754a..0f5e951dbdc 100644
--- a/sys-devel/llvm/llvm-3.4.2-r100.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
@@ -84,16 +84,16 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
- epatch "${FILESDIR}"/${PN}-3.4-gentoo-install.patch
+ epatch "${FILESDIR}"/3.6.2/nodoctargz.patch
+ epatch "${FILESDIR}"/3.4.2/gentoo-install.patch
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
- epatch "${FILESDIR}"/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
+ epatch "${FILESDIR}"/3.4.2/clang/gentoo-runtime-gcc-detection-v3.patch
- epatch "${FILESDIR}"/clang-3.4-gentoo-install.patch
- epatch "${FILESDIR}"/clang-3.4-darwin_build_fix.patch
- epatch "${FILESDIR}"/clang-3.4-darwin_prefix-include-paths.patch
+ epatch "${FILESDIR}"/3.4.2/clang/gentoo-install.patch
+ epatch "${FILESDIR}"/3.4.2/clang/darwin_build_fix.patch
+ epatch "${FILESDIR}"/3.9.0/clang/darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
fi