summaryrefslogtreecommitdiff
path: root/sys-devel/llvm
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-04 08:22:05 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-04 08:41:45 +0200
commitb80d7440f3e73f502744c3b4b5bbde62a4927cf3 (patch)
tree105cfb1179a311cc5c6d3aa6cf5be1b8300472c9 /sys-devel/llvm
parentcca4fb9bd9652c727fe6f05d2d0620de816ab7ac (diff)
downloadgentoo-b80d7440f3e73f502744c3b4b5bbde62a4927cf3.tar.gz
gentoo-b80d7440f3e73f502744c3b4b5bbde62a4927cf3.tar.xz
sys-devel/llvm: Sphinx race condition has been fixed upstream
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/files/3.9.0/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch (renamed from sys-devel/llvm/files/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch)0
-rw-r--r--sys-devel/llvm/llvm-3.7.1-r3.ebuild2
-rw-r--r--sys-devel/llvm/llvm-3.8.0-r3.ebuild2
-rw-r--r--sys-devel/llvm/llvm-3.8.1-r2.ebuild2
-rw-r--r--sys-devel/llvm/llvm-3.8.1.ebuild2
-rw-r--r--sys-devel/llvm/llvm-3.9.0.ebuild2
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
7 files changed, 5 insertions, 9 deletions
diff --git a/sys-devel/llvm/files/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch b/sys-devel/llvm/files/3.9.0/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
index 94a81574d6e..94a81574d6e 100644
--- a/sys-devel/llvm/files/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+++ b/sys-devel/llvm/files/3.9.0/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
diff --git a/sys-devel/llvm/llvm-3.7.1-r3.ebuild b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
index 5b809750bb8..0b988553395 100644
--- a/sys-devel/llvm/llvm-3.7.1-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
@@ -151,7 +151,7 @@ src_prepare() {
# Prevent race conditions with parallel Sphinx runs
# https://llvm.org/bugs/show_bug.cgi?id=23781
- eapply "${FILESDIR}"/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+ eapply "${FILESDIR}"/3.9.0/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
diff --git a/sys-devel/llvm/llvm-3.8.0-r3.ebuild b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
index 7731a4baba2..b08f4d65cca 100644
--- a/sys-devel/llvm/llvm-3.8.0-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
@@ -152,7 +152,7 @@ src_prepare() {
# Prevent race conditions with parallel Sphinx runs
# https://llvm.org/bugs/show_bug.cgi?id=23781
- eapply "${FILESDIR}"/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+ eapply "${FILESDIR}"/3.9.0/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
diff --git a/sys-devel/llvm/llvm-3.8.1-r2.ebuild b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
index f16aca4a8c5..d2cdc518f0d 100644
--- a/sys-devel/llvm/llvm-3.8.1-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
@@ -153,7 +153,7 @@ src_prepare() {
# Prevent race conditions with parallel Sphinx runs
# https://llvm.org/bugs/show_bug.cgi?id=23781
- eapply "${FILESDIR}"/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+ eapply "${FILESDIR}"/3.9.0/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
diff --git a/sys-devel/llvm/llvm-3.8.1.ebuild b/sys-devel/llvm/llvm-3.8.1.ebuild
index 036de496bb5..29b637d22d0 100644
--- a/sys-devel/llvm/llvm-3.8.1.ebuild
+++ b/sys-devel/llvm/llvm-3.8.1.ebuild
@@ -152,7 +152,7 @@ src_prepare() {
# Prevent race conditions with parallel Sphinx runs
# https://llvm.org/bugs/show_bug.cgi?id=23781
- eapply "${FILESDIR}"/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+ eapply "${FILESDIR}"/3.9.0/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
# Prevent installing libgtest
# https://llvm.org/bugs/show_bug.cgi?id=18341
diff --git a/sys-devel/llvm/llvm-3.9.0.ebuild b/sys-devel/llvm/llvm-3.9.0.ebuild
index f80239a4644..9ec259c6e5a 100644
--- a/sys-devel/llvm/llvm-3.9.0.ebuild
+++ b/sys-devel/llvm/llvm-3.9.0.ebuild
@@ -165,7 +165,7 @@ src_prepare() {
# Prevent race conditions with parallel Sphinx runs
# https://llvm.org/bugs/show_bug.cgi?id=23781
- eapply "${FILESDIR}"/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+ eapply "${FILESDIR}"/3.9.0/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
# Allow custom cmake build types (like 'Gentoo')
eapply "${FILESDIR}"/9999/0006-cmake-Remove-the-CMAKE_BUILD_TYPE-assertion.patch
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 471783794b0..5e378021715 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -102,10 +102,6 @@ src_prepare() {
# Python is needed to run tests using lit
python_setup
- # Prevent race conditions with parallel Sphinx runs
- # https://llvm.org/bugs/show_bug.cgi?id=23781
- eapply "${FILESDIR}"/9999/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
-
# Allow custom cmake build types (like 'Gentoo')
eapply "${FILESDIR}"/9999/0006-cmake-Remove-the-CMAKE_BUILD_TYPE-assertion.patch