summaryrefslogtreecommitdiff
path: root/sys-devel/qconf
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-devel/qconf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-devel/qconf')
-rw-r--r--sys-devel/qconf/Manifest1
-rw-r--r--sys-devel/qconf/metadata.xml8
-rw-r--r--sys-devel/qconf/qconf-1.5_pre717-r1.ebuild39
3 files changed, 48 insertions, 0 deletions
diff --git a/sys-devel/qconf/Manifest b/sys-devel/qconf/Manifest
new file mode 100644
index 00000000000..23f9859cd51
--- /dev/null
+++ b/sys-devel/qconf/Manifest
@@ -0,0 +1 @@
+DIST qconf-1.5_pre717.tar.bz2 42010 SHA256 16ece50ac3f9533cf05d7abb44a025503ef8a3ea985fb70ba4c2224f27fdf903
diff --git a/sys-devel/qconf/metadata.xml b/sys-devel/qconf/metadata.xml
new file mode 100644
index 00000000000..1aecc7ea300
--- /dev/null
+++ b/sys-devel/qconf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>pva@gentoo.org</email>
+<name>Peter Volkov</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild b/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild
new file mode 100644
index 00000000000..a7b8ac604e0
--- /dev/null
+++ b/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit multilib qt4-r2
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="http://delta.affinix.com/qconf/"
+SRC_URI="http://delta.affinix.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Fake ./configure. Fails on unknown options
+ ./configure \
+ --prefix=/usr/ \
+ --qtdir=/usr/$(get_libdir)/ || die "./configure failed"
+
+ [ ! -f Makefile ] && die "./configure failed"
+
+ eqmake4
+}
+
+src_install() {
+ dobin qconf || die
+ dodoc README TODO || die
+ insinto /usr/share/${PN}
+ doins -r conf modules
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+}