summaryrefslogtreecommitdiff
path: root/sys-devel
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-19 10:11:19 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-19 10:14:11 +0100
commitaf187ea04d3e2a7e0dc69e80d4a2ba4bffbdc7d7 (patch)
treec80532e739d44c2d8aea7a077cfcb43a5db0ae89 /sys-devel
parent864db8ccb3437179cb775ffa59b580ccd102208a (diff)
downloadgentoo-af187ea04d3e2a7e0dc69e80d4a2ba4bffbdc7d7.tar.gz
gentoo-af187ea04d3e2a7e0dc69e80d4a2ba4bffbdc7d7.tar.xz
sys-devel/clang-runtime: Add 4.0.0rc1
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-4.0.0_rc1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-4.0.0_rc1.ebuild b/sys-devel/clang-runtime/clang-runtime-4.0.0_rc1.ebuild
new file mode 100644
index 00000000000..d224ca01584
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-4.0.0_rc1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="0"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV} )
+ )
+ libcxx? ( ~sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( ~sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"