summaryrefslogtreecommitdiff
path: root/sys-fs/atari-fdisk
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/atari-fdisk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/atari-fdisk')
-rw-r--r--sys-fs/atari-fdisk/Manifest2
-rw-r--r--sys-fs/atari-fdisk/atari-fdisk-0.7.1.5.1.ebuild42
-rw-r--r--sys-fs/atari-fdisk/atari-fdisk-0.7.1.5.4.ebuild42
-rw-r--r--sys-fs/atari-fdisk/metadata.xml7
4 files changed, 93 insertions, 0 deletions
diff --git a/sys-fs/atari-fdisk/Manifest b/sys-fs/atari-fdisk/Manifest
new file mode 100644
index 00000000000..b699f5a0874
--- /dev/null
+++ b/sys-fs/atari-fdisk/Manifest
@@ -0,0 +1,2 @@
+DIST atari-fdisk_0.7.1-5.1.tar.gz 67705 SHA256 91eeb9db76b3f99ce48128281a00494a0a2ca43d5ef6bd3690adcf22bb5fcb95 SHA512 80e5e4ed1a1dd3d7fbfed68e33e43864d593f084921c699beca100ddbd5e8adb2da36badd6fc467417d3e80855b484f87576c78700ccfa763c5c7644370275f9 WHIRLPOOL 3b4d66163598d7896beb011d5c86ae481664fbbdd7f243bb2943531d7164924a867e242cf89fd4d664e5feb942c4c272623f3fb0be58685ae533d100be9aa02d
+DIST atari-fdisk_0.7.1-5.4.tar.gz 47576 SHA256 81ddb3a0d0088fb32011cede6deacb98a2b97da24fc8b2efe87dc45da601b96f
diff --git a/sys-fs/atari-fdisk/atari-fdisk-0.7.1.5.1.ebuild b/sys-fs/atari-fdisk/atari-fdisk-0.7.1.5.1.ebuild
new file mode 100644
index 00000000000..52a41622c22
--- /dev/null
+++ b/sys-fs/atari-fdisk/atari-fdisk-0.7.1.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator toolchain-funcs
+
+MY_PV=$(get_version_component_range 1-3)
+DEB_PV=$(get_version_component_range 4-5)
+DESCRIPTION="create and edit the partition table of a disk partitioned in Atari format"
+HOMEPAGE="http://packages.qa.debian.org/a/atari-fdisk.html"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${MY_PV}-${DEB_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 arm ~hppa ia64 m68k ~mips ~ppc s390 sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ COMPILE_ARCH=m68k \
+ || die
+}
+
+src_install() {
+ dodoc NEWS README TODO debian/changelog
+ doman debian/atari-fdisk.8
+
+ into /
+ if [[ $(tc-arch) == "m68k" ]] ; then
+ dosbin fdisk || die "sbin fdisk failed"
+ dosym fdisk /sbin/atari-fdisk
+ dosym atari-fdisk.8 /usr/share/man/man8/fdisk.8
+ else
+ dosbin atari-fdisk || die "sbin atari-fdisk failed"
+ fi
+}
diff --git a/sys-fs/atari-fdisk/atari-fdisk-0.7.1.5.4.ebuild b/sys-fs/atari-fdisk/atari-fdisk-0.7.1.5.4.ebuild
new file mode 100644
index 00000000000..84b470043b9
--- /dev/null
+++ b/sys-fs/atari-fdisk/atari-fdisk-0.7.1.5.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator toolchain-funcs
+
+MY_PV=$(get_version_component_range 1-3)
+DEB_PV=$(get_version_component_range 4-5)
+DESCRIPTION="create and edit the partition table of a disk partitioned in Atari format"
+HOMEPAGE="http://packages.qa.debian.org/a/atari-fdisk.html"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${MY_PV}-${DEB_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 m68k ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ COMPILE_ARCH=m68k \
+ || die
+}
+
+src_install() {
+ dodoc NEWS README TODO debian/changelog
+ doman debian/atari-fdisk.8
+
+ into /
+ if [[ $(tc-arch) == "m68k" ]] ; then
+ dosbin fdisk || die "sbin fdisk failed"
+ dosym fdisk /sbin/atari-fdisk
+ dosym atari-fdisk.8 /usr/share/man/man8/fdisk.8
+ else
+ dosbin atari-fdisk || die "sbin atari-fdisk failed"
+ fi
+}
diff --git a/sys-fs/atari-fdisk/metadata.xml b/sys-fs/atari-fdisk/metadata.xml
new file mode 100644
index 00000000000..0ba9416963a
--- /dev/null
+++ b/sys-fs/atari-fdisk/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>m68k@gentoo.org</email>
+</maintainer>
+</pkgmetadata>