summaryrefslogtreecommitdiff
path: root/sys-fs/aufs-util
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/aufs-util
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/aufs-util')
-rw-r--r--sys-fs/aufs-util/Manifest3
-rw-r--r--sys-fs/aufs-util/aufs-util-3.19_p20150323.ebuild46
-rw-r--r--sys-fs/aufs-util/aufs-util-3.19_p20150420.ebuild46
-rw-r--r--sys-fs/aufs-util/aufs-util-4.0_p20150420.ebuild47
-rw-r--r--sys-fs/aufs-util/files/aufs-util-4.0_p20150420-version.patch16
-rw-r--r--sys-fs/aufs-util/metadata.xml7
6 files changed, 165 insertions, 0 deletions
diff --git a/sys-fs/aufs-util/Manifest b/sys-fs/aufs-util/Manifest
new file mode 100644
index 00000000000..65e77e807f2
--- /dev/null
+++ b/sys-fs/aufs-util/Manifest
@@ -0,0 +1,3 @@
+DIST aufs-util-3.19_p20150323.tar.xz 97980 SHA256 6a7c342f7cda2abd7ee0eb20c40419c7e34a88cf73d77f4a9a697370a996fe7d SHA512 49f138538ea8997ddb6bedf368815f16a5d42a49b5f72c1548cd9c3718bb00831224e80e9b4dd8c984a6fb40b11223e317757020076d432117541f7d361b892b WHIRLPOOL 59d65f468bbb36ac11f200e45d2449549512a1b2168c4776764a540d22d919969067b551704d55403111a0b68364831152177dda8ace101fe77e158e86d82d25
+DIST aufs-util-3.19_p20150420.tar.xz 97980 SHA256 2ab7f16ee4a67b8ac85903da2e2f6569c8659ee217f060923ba93865a3ff212f SHA512 fe329e9efdbd7b585664b81c2bcd2d63ce5344d013eb2d76c6247e042c1cbe44a4a3ab6e8317734c06c24c1eeffe438d8f91a8e57d95b34e238b21a8b9389e8a WHIRLPOOL 0d3c6aa78e9ecbbb2cabbcddfbf7a9edd1d931b5993047e98f4eaf20e7c60c0077819a2c0b7d0f2e3fd85f6f9eedf86c17c508f3437194e2379295d94e1dc62d
+DIST aufs-util-4.0_p20150420.tar.xz 97924 SHA256 f6d19dad3729da05af9e283e48a4a573b7e00e5e822aa1741e0c225e69171fde SHA512 9a988dcd3640e4797c731ab921161bccbd125fc23475e39681b3a398a238715cb85ac8fe8dfc64053af7478c8c33fe28b7e8cc3a2f97eb31e3c4049305043085 WHIRLPOOL 50baac4fe8bfcc750038e586f9dc3fd2d819ba485951e624c0b07c95c81000fbe7c0b70cf55b61667be7210dff328290cbf95a198680e59549c31c3979d2c471
diff --git a/sys-fs/aufs-util/aufs-util-3.19_p20150323.ebuild b/sys-fs/aufs-util/aufs-util-3.19_p20150323.ebuild
new file mode 100644
index 00000000000..10ce3942ab3
--- /dev/null
+++ b/sys-fs/aufs-util/aufs-util-3.19_p20150323.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic linux-info multilib toolchain-funcs
+
+DESCRIPTION="Utilities are always necessary for aufs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+# git archive -v --prefix=${P}/ --remote=git://git.code.sf.net/p/aufs/aufs-util aufs3.14 -o ${P}.tar
+# xz -ve9 *.tar
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ !sys-fs/aufs2
+ !<sys-fs/aufs3-3_p20130318"
+DEPEND="${RDEPEND}
+ ~sys-fs/aufs-headers-${PV}"
+
+src_prepare() {
+ sed \
+ -e "/LDFLAGS += -static -s/d" \
+ -e "/CFLAGS/s:-O::g" \
+ -i Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e "s:m 644 -s:m 644:g" \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ -i libau/Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e '/LDLIBS/s:-lrt::g' \
+ -e '/LDLIBS/s:$: -lrt:g' \
+ -i fhsm/Makefile || die
+
+ tc-export CC AR
+ export HOSTCC=$(tc-getCC)
+}
diff --git a/sys-fs/aufs-util/aufs-util-3.19_p20150420.ebuild b/sys-fs/aufs-util/aufs-util-3.19_p20150420.ebuild
new file mode 100644
index 00000000000..10ce3942ab3
--- /dev/null
+++ b/sys-fs/aufs-util/aufs-util-3.19_p20150420.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic linux-info multilib toolchain-funcs
+
+DESCRIPTION="Utilities are always necessary for aufs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+# git archive -v --prefix=${P}/ --remote=git://git.code.sf.net/p/aufs/aufs-util aufs3.14 -o ${P}.tar
+# xz -ve9 *.tar
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ !sys-fs/aufs2
+ !<sys-fs/aufs3-3_p20130318"
+DEPEND="${RDEPEND}
+ ~sys-fs/aufs-headers-${PV}"
+
+src_prepare() {
+ sed \
+ -e "/LDFLAGS += -static -s/d" \
+ -e "/CFLAGS/s:-O::g" \
+ -i Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e "s:m 644 -s:m 644:g" \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ -i libau/Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e '/LDLIBS/s:-lrt::g' \
+ -e '/LDLIBS/s:$: -lrt:g' \
+ -i fhsm/Makefile || die
+
+ tc-export CC AR
+ export HOSTCC=$(tc-getCC)
+}
diff --git a/sys-fs/aufs-util/aufs-util-4.0_p20150420.ebuild b/sys-fs/aufs-util/aufs-util-4.0_p20150420.ebuild
new file mode 100644
index 00000000000..f7fee92dd67
--- /dev/null
+++ b/sys-fs/aufs-util/aufs-util-4.0_p20150420.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic linux-info multilib toolchain-funcs
+
+DESCRIPTION="Utilities are always necessary for aufs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+# git archive -v --prefix=${P}/ --remote=git://git.code.sf.net/p/aufs/aufs-util aufs4.0 -o ${P}.tar
+# xz -ve9 *.tar
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ !sys-fs/aufs2
+ !<sys-fs/aufs3-3_p20130318"
+DEPEND="${RDEPEND}
+ ~sys-fs/aufs-headers-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-version.patch
+ sed \
+ -e "/LDFLAGS += -static -s/d" \
+ -e "/CFLAGS/s:-O::g" \
+ -i Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e "s:m 644 -s:m 644:g" \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ -i libau/Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e '/LDLIBS/s:-lrt::g' \
+ -e '/LDLIBS/s:$: -lrt:g' \
+ -i fhsm/Makefile || die
+
+ tc-export CC AR
+ export HOSTCC=$(tc-getCC)
+}
diff --git a/sys-fs/aufs-util/files/aufs-util-4.0_p20150420-version.patch b/sys-fs/aufs-util/files/aufs-util-4.0_p20150420-version.patch
new file mode 100644
index 00000000000..b861bb2bb0b
--- /dev/null
+++ b/sys-fs/aufs-util/files/aufs-util-4.0_p20150420-version.patch
@@ -0,0 +1,16 @@
+ ver.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ver.c b/ver.c
+index 200b119..38abdd5 100644
+--- a/ver.c
++++ b/ver.c
+@@ -25,7 +25,7 @@
+ int main(int argc, char *argv[])
+ {
+ regex_t preg;
+- const char *pat = "^4\\.[0-9][0-9]";
++ const char *pat = "^4\\.[0-9][0-9]?";
+
+ if (regcomp(&preg, pat, REG_EXTENDED | REG_NOSUB))
+ AuFin("regcomp");
diff --git a/sys-fs/aufs-util/metadata.xml b/sys-fs/aufs-util/metadata.xml
new file mode 100644
index 00000000000..4a00a64b40a
--- /dev/null
+++ b/sys-fs/aufs-util/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>