summaryrefslogtreecommitdiff
path: root/sys-fs/bedup
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/bedup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/bedup')
-rw-r--r--sys-fs/bedup/Manifest1
-rw-r--r--sys-fs/bedup/bedup-0.9.0_p20140413-r1.ebuild28
-rw-r--r--sys-fs/bedup/bedup-9999.ebuild38
-rw-r--r--sys-fs/bedup/metadata.xml11
4 files changed, 78 insertions, 0 deletions
diff --git a/sys-fs/bedup/Manifest b/sys-fs/bedup/Manifest
new file mode 100644
index 00000000000..039529ae135
--- /dev/null
+++ b/sys-fs/bedup/Manifest
@@ -0,0 +1 @@
+DIST bedup-0.9.0_p20140413.tar.gz 48620 SHA256 f9c380074e3f13e42447c04a0fd5c1abca444487cf6ccb6400f09dcca14f90a6 SHA512 9a730dff2b2af239a6386d860881989de50f7a4fb6ae5b402c6dfe828308bbf4ccc2b6f616fdfc2b445fe23fbfcc302163b320813b50fa27940e578b5145345c WHIRLPOOL af4827f4514acc8380f312a72bb3208614f1f529e7373bca3bb610315e0474c9d7c7cbda1338d7019316e708f17ba73e71539092065041df588fd449f7639b54
diff --git a/sys-fs/bedup/bedup-0.9.0_p20140413-r1.ebuild b/sys-fs/bedup/bedup-0.9.0_p20140413-r1.ebuild
new file mode 100644
index 00000000000..8b6e089a104
--- /dev/null
+++ b/sys-fs/bedup/bedup-0.9.0_p20140413-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Btrfs file de-duplication tool"
+HOMEPAGE="https://github.com/g2p/bedup"
+SRC_URI="https://github.com/g2p/${PN}/archive/5189e166145b8954ac41883f81ef3c3b50dc96ab.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# we need btrfs-progs with includes installed.
+DEPEND=">=dev-python/cffi-0.5:=[${PYTHON_USEDEP}]
+ >=sys-fs/btrfs-progs-0.20_rc1_p358"
+RDEPEND="${DEPEND}
+ <dev-python/alembic-0.7[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8.2[sqlite,${PYTHON_USEDEP}]"
diff --git a/sys-fs/bedup/bedup-9999.ebuild b/sys-fs/bedup/bedup-9999.ebuild
new file mode 100644
index 00000000000..9f4323451a2
--- /dev/null
+++ b/sys-fs/bedup/bedup-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+#if LIVE
+EGIT_REPO_URI="git://github.com/g2p/bedup.git
+ https://github.com/g2p/bedup.git"
+inherit git-r3
+#endif
+
+inherit distutils-r1
+
+DESCRIPTION="Btrfs file de-duplication tool"
+HOMEPAGE="https://github.com/g2p/bedup"
+SRC_URI="https://github.com/g2p/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# we need btrfs-progs with includes installed.
+DEPEND=">=dev-python/cffi-0.5:=[${PYTHON_USEDEP}]
+ >=sys-fs/btrfs-progs-0.20_rc1_p358"
+RDEPEND="${DEPEND}
+ <dev-python/alembic-0.7[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8.2[sqlite,${PYTHON_USEDEP}]"
+
+#if LIVE
+SRC_URI=
+KEYWORDS=
+#endif
diff --git a/sys-fs/bedup/metadata.xml b/sys-fs/bedup/metadata.xml
new file mode 100644
index 00000000000..4882123dbb5
--- /dev/null
+++ b/sys-fs/bedup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">g2p/bedup</remote-id>
+ </upstream>
+</pkgmetadata>