summaryrefslogtreecommitdiff
path: root/sys-fs/davl
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/davl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/davl')
-rw-r--r--sys-fs/davl/Manifest1
-rw-r--r--sys-fs/davl/davl-1.2.4-r1.ebuild36
-rw-r--r--sys-fs/davl/files/davl-1.2.1-asneeded.patch41
-rw-r--r--sys-fs/davl/files/davl-1.2.4-fragment.patch20
-rw-r--r--sys-fs/davl/metadata.xml10
5 files changed, 108 insertions, 0 deletions
diff --git a/sys-fs/davl/Manifest b/sys-fs/davl/Manifest
new file mode 100644
index 00000000000..600c6a67cde
--- /dev/null
+++ b/sys-fs/davl/Manifest
@@ -0,0 +1 @@
+DIST davl-1.2.4.tar.bz2 47539 SHA256 d0a1b0a2528ff029374c5019b04140ca3a99baacb9576cbaa5ee4e87e6c34fb5 SHA512 71c33c0bfaca7c7557541517ec9e7b084e4d50e7504e02d412442566c6046c8a68fe4020e05a3e2da5c9309bd75ba06abba8f16fad96b476b5c961814d24d602 WHIRLPOOL 9378bbf5e47bce2afb8f7038914b535839da03b65e713072303b5efb23e035b792b82dae6233d0a9eb8730094294009d10f331c2099994019224ddbf6c71dbe4
diff --git a/sys-fs/davl/davl-1.2.4-r1.ebuild b/sys-fs/davl/davl-1.2.4-r1.ebuild
new file mode 100644
index 00000000000..a7707c75d75
--- /dev/null
+++ b/sys-fs/davl/davl-1.2.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Visualizes the fragmentation status of ext2/3 filesystems"
+HOMEPAGE="http://davl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6:2"
+DEPEND="${RDEPEND}
+ >=sys-fs/e2fsprogs-1.41.7-r1
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.2.1-asneeded.patch \
+ "${FILESDIR}"/${P}-fragment.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin src/{cdavl/cdavl,gdavl/gdavl}
+ dodoc README
+ doman doc/*.8
+}
diff --git a/sys-fs/davl/files/davl-1.2.1-asneeded.patch b/sys-fs/davl/files/davl-1.2.1-asneeded.patch
new file mode 100644
index 00000000000..e7c1c925bba
--- /dev/null
+++ b/sys-fs/davl/files/davl-1.2.1-asneeded.patch
@@ -0,0 +1,41 @@
+--- src/cdavl/Makefile
++++ src/cdavl/Makefile
+@@ -4,10 +4,6 @@
+ include $(PATH_LIST)
+
+
+-CC = gcc
+-DEBUG =
+-#DEBUG = -DDEBUG
+-CFLAGS = -Wall -g -O -D_FILE_OFFSET_BITS=64 $(DEBUG)
+ HEADERS = cdavl.h ../common/util.h ../drv/liveinfo_app.h
+ OBJS = ../common/util.o
+ CDAVL = cdavl
+--- src/gdavl/Makefile
++++ src/gdavl/Makefile
+@@ -4,22 +4,14 @@
+ include $(PATH_LIST)
+
+
+-CC = gcc
+-CFLAGS1 = -Wall -g -O `gtk-config --cflags --libs`
+-CFLAGS2 = -Wall -g -O `pkg-config --cflags --libs gtk+-2.0`
+-CFLAGS = -D$(GTK_VER)
+-ifeq ($(GTK_VER), GTK2)
+- CFLAGS += $(CFLAGS2)
+-else
+- CFLAGS += $(CFLAGS1)
+-endif
++CFLAGS += -D$(GTK_VER) `pkg-config --cflags gtk+-2.0`
++LDLIBS = `pkg-config --libs gtk+-2.0`
+ DEBUG =
+ #DEBUG = -D DEBUG
+ GDAVL = gdavl
+
+
+-$(GDAVL): gdavl.c if.c gdavl.h
+- $(CC) $(CFLAGS) $(DEBUG) -o $(GDAVL) gdavl.c if.c
++$(GDAVL): gdavl.o if.o
+
+ clean:
+ rm -rf $(GDAVL) *.o test/*.png test/log test/test.log
diff --git a/sys-fs/davl/files/davl-1.2.4-fragment.patch b/sys-fs/davl/files/davl-1.2.4-fragment.patch
new file mode 100644
index 00000000000..2b5e9338700
--- /dev/null
+++ b/sys-fs/davl/files/davl-1.2.4-fragment.patch
@@ -0,0 +1,20 @@
+cdavl.c:101:53: error: ‘struct ext2_super_block’ has no member named ‘s_log_frag_size’
+cdavl.c:105:53: error: ‘struct ext2_super_block’ has no member named ‘s_frags_per_group’
+
+http://bugs.gentoo.org/425820
+
+--- src/cdavl/cdavl.c
++++ src/cdavl/cdavl.c
+@@ -98,9 +98,11 @@
+ PRINT4("s_free_inodes_count: ", le32_to_cpu(sb->s_free_inodes_count));
+ PRINT4("s_first_data_block: ", le32_to_cpu(sb->s_first_data_block));
+ PRINT4("s_log_block_size: ", le32_to_cpu(sb->s_log_block_size));
++ #if 0
+ PRINT4("s_log_frag_size: ", le32_to_cpu(sb->s_log_frag_size));
+- PRINT4("s_blocks_per_group: ", le32_to_cpu(sb->s_blocks_per_group));
+ PRINT4("s_frags_per_group: ", le32_to_cpu(sb->s_frags_per_group));
++ #endif
++ PRINT4("s_blocks_per_group: ", le32_to_cpu(sb->s_blocks_per_group));
+ PRINT4("s_inodes_per_group: ", le32_to_cpu(sb->s_inodes_per_group));
+ PRINT4("s_mtime: ", le32_to_cpu(sb->s_mtime));
+ PRINT4("s_wtime: ", le32_to_cpu(sb->s_wtime));
diff --git a/sys-fs/davl/metadata.xml b/sys-fs/davl/metadata.xml
new file mode 100644
index 00000000000..37613359a0b
--- /dev/null
+++ b/sys-fs/davl/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>armin76@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">davl</remote-id>
+ </upstream>
+</pkgmetadata>