summaryrefslogtreecommitdiff
path: root/sys-fs/encfs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-14 08:34:04 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-08-14 08:34:52 -0400
commit3a99f331a3db0acb7fa15f2b6785392695a5e0f8 (patch)
tree4c065af09761d7cfb815047d85ed62b98e6fdec8 /sys-fs/encfs
parent4177de70d0520161bbfdbaedd7f46c4dc9655e33 (diff)
downloadgentoo-3a99f331a3db0acb7fa15f2b6785392695a5e0f8.tar.gz
gentoo-3a99f331a3db0acb7fa15f2b6785392695a5e0f8.tar.xz
sys-fs/encfs: add slot equals matching for boost and openssl
Gentoo-Bug: 557414 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-fs/encfs')
-rw-r--r--sys-fs/encfs/encfs-1.7.5.ebuild8
-rw-r--r--sys-fs/encfs/encfs-1.8.1.ebuild6
2 files changed, 7 insertions, 7 deletions
diff --git a/sys-fs/encfs/encfs-1.7.5.ebuild b/sys-fs/encfs/encfs-1.7.5.ebuild
index 7214cdad2e9..07f9147e36d 100644
--- a/sys-fs/encfs/encfs-1.7.5.ebuild
+++ b/sys-fs/encfs/encfs-1.7.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=2
+EAPI=5
inherit autotools eutils multilib
DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
@@ -14,8 +14,8 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~sparc x86"
IUSE="xattr"
-RDEPEND=">=dev-libs/boost-1.34
- >=dev-libs/openssl-0.9.7
+RDEPEND="dev-libs/boost:=
+ dev-libs/openssl:=
>=dev-libs/rlog-1.4
>=sys-fs/fuse-2.7.0
sys-libs/zlib"
diff --git a/sys-fs/encfs/encfs-1.8.1.ebuild b/sys-fs/encfs/encfs-1.8.1.ebuild
index 62024ad930e..abbaf69c6ca 100644
--- a/sys-fs/encfs/encfs-1.8.1.ebuild
+++ b/sys-fs/encfs/encfs-1.8.1.ebuild
@@ -14,10 +14,10 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~sparc ~x86"
IUSE="xattr nls"
-RDEPEND=">=dev-libs/boost-1.34
- >=sys-fs/fuse-2.5
- >=dev-libs/openssl-0.9.7
+RDEPEND="dev-libs/boost:=
+ dev-libs/openssl:=
>=dev-libs/rlog-1.3
+ >=sys-fs/fuse-2.5
sys-libs/zlib"
# Your libc probably provides xattrs, but to be safe
# we'll dep on sys-apps/attr. This should be fixed