summaryrefslogtreecommitdiff
path: root/sys-fs/encfs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/encfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/encfs')
-rw-r--r--sys-fs/encfs/Manifest2
-rw-r--r--sys-fs/encfs/encfs-1.7.5.ebuild44
-rw-r--r--sys-fs/encfs/encfs-1.8.1.ebuild50
-rw-r--r--sys-fs/encfs/files/encfs-1.7.5-fix-pod.patch16
-rw-r--r--sys-fs/encfs/metadata.xml12
5 files changed, 124 insertions, 0 deletions
diff --git a/sys-fs/encfs/Manifest b/sys-fs/encfs/Manifest
new file mode 100644
index 00000000000..08c219db54b
--- /dev/null
+++ b/sys-fs/encfs/Manifest
@@ -0,0 +1,2 @@
+DIST encfs-1.7.5.tar.gz 168162 SHA256 111f15521479832a0ec5473c7e201316c88cae4e2c70bf8cea7fa23acb42c017 SHA512 e0cb9181d9c6c54a36dd19ab7a78d6f9ad0f017129d1addab012e72e00a3bb7e19481a2fbc511fd2a505c8b971cd93a02e556c6420b07acfba68ac3c37d224d7 WHIRLPOOL d0036483f404e81ba34d90a3bb5e422bf5354a05727cb75dcf8ab39c77b11276a21ec9e1e7933f554dbeb77107f4773d7251fbf50d5f4e2109d22658b8303177
+DIST encfs-1.8.1.tar.gz 316534 SHA256 ed6b69d8aba06382ad01116bbce2e4ad49f8de85cdf4e2fab7ee4ac82af537e9 SHA512 47e6cdded84c65bdb98c14774472a2f9df67f2bea05e4c2e20811d785c5ee458b708030922db9a5b49382495235a329bc8e889d104cc8501cd954119699847c6 WHIRLPOOL ccbd21927a9395dc178c41ebdf2fced4f8f7e14c23194baca32aa4270526388a34fd8817c2675d8610f983a90f121629056817c6599944f60a5d73b970e968f1
diff --git a/sys-fs/encfs/encfs-1.7.5.ebuild b/sys-fs/encfs/encfs-1.7.5.ebuild
new file mode 100644
index 00000000000..7214cdad2e9
--- /dev/null
+++ b/sys-fs/encfs/encfs-1.7.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils multilib
+
+DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
+HOMEPAGE="https://vgough.github.io/encfs/"
+SRC_URI="https://github.com/vgough/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~sparc x86"
+IUSE="xattr"
+
+RDEPEND=">=dev-libs/boost-1.34
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/rlog-1.4
+ >=sys-fs/fuse-2.7.0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ xattr? ( sys-apps/attr )
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}/encfs-1.7.5-fix-pod.patch"
+ eautoreconf
+}
+
+src_configure() {
+ use xattr || export ac_cv_header_attr_xattr_h=no
+
+ econf \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+ find "${D}" -name '*.la' -delete
+}
diff --git a/sys-fs/encfs/encfs-1.8.1.ebuild b/sys-fs/encfs/encfs-1.8.1.ebuild
new file mode 100644
index 00000000000..62024ad930e
--- /dev/null
+++ b/sys-fs/encfs/encfs-1.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools eutils multilib
+
+DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
+HOMEPAGE="https://vgough.github.io/encfs/"
+SRC_URI="https://github.com/vgough/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~sparc ~x86"
+IUSE="xattr nls"
+
+RDEPEND=">=dev-libs/boost-1.34
+ >=sys-fs/fuse-2.5
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/rlog-1.3
+ sys-libs/zlib"
+# Your libc probably provides xattrs, but to be safe
+# we'll dep on sys-apps/attr. This should be fixed
+# if we ever create a virtual/attr.
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ xattr? ( sys-apps/attr )
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # configure searches for either attr/xattr.h or sys/xattr.h
+ use xattr || export ac_cv_header_{attr,sys}_xattr_h=no
+
+ econf \
+ $(use_enable nls) \
+ --disable-valgrind \
+ --enable-openssl \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README.md
+ find "${D}" -name '*.la' -delete
+}
diff --git a/sys-fs/encfs/files/encfs-1.7.5-fix-pod.patch b/sys-fs/encfs/files/encfs-1.7.5-fix-pod.patch
new file mode 100644
index 00000000000..1089a92da28
--- /dev/null
+++ b/sys-fs/encfs/files/encfs-1.7.5-fix-pod.patch
@@ -0,0 +1,16 @@
+diff -Naur encfs-1.7.5.orig/encfs/encfsctl.pod encfs-1.7.5/encfs/encfsctl.pod
+--- encfs-1.7.5.orig/encfs/encfsctl.pod 2011-12-29 17:26:28.000000000 -0500
++++ encfs-1.7.5/encfs/encfsctl.pod 2014-11-01 14:24:48.636330176 -0400
+@@ -1,4 +1,3 @@
+-=cut
+ Copyright (c) 2003-2004, Valient Gough <vgough@pobox.com>
+ All rights reserved.
+
+diff -Naur encfs-1.7.5.orig/encfs/encfs.pod encfs-1.7.5/encfs/encfs.pod
+--- encfs-1.7.5.orig/encfs/encfs.pod 2011-12-29 17:26:28.000000000 -0500
++++ encfs-1.7.5/encfs/encfs.pod 2014-11-01 14:24:51.132330290 -0400
+@@ -1,4 +1,3 @@
+-=cut
+ Copyright (c) 2003-2008, Valient Gough <vgough@pobox.com>
+ All rights reserved.
+
diff --git a/sys-fs/encfs/metadata.xml b/sys-fs/encfs/metadata.xml
new file mode 100644
index 00000000000..eadb5fd37f7
--- /dev/null
+++ b/sys-fs/encfs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">encfs</remote-id>
+ <remote-id type="github">vgough/encfs</remote-id>
+ </upstream>
+</pkgmetadata>