summaryrefslogtreecommitdiff
path: root/sys-fs/ext3grep
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/ext3grep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/ext3grep')
-rw-r--r--sys-fs/ext3grep/Manifest1
-rw-r--r--sys-fs/ext3grep/ext3grep-0.10.2.ebuild38
-rw-r--r--sys-fs/ext3grep/files/ext3grep-0.10.1-gcc44.patch197
-rw-r--r--sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch15
-rw-r--r--sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff34
-rw-r--r--sys-fs/ext3grep/metadata.xml10
6 files changed, 295 insertions, 0 deletions
diff --git a/sys-fs/ext3grep/Manifest b/sys-fs/ext3grep/Manifest
new file mode 100644
index 00000000000..e86cf54049e
--- /dev/null
+++ b/sys-fs/ext3grep/Manifest
@@ -0,0 +1 @@
+DIST ext3grep-0.10.2.tar.gz 236364 SHA256 586f3e939d2ffd782f6f006b81a3df2dc477c6da03f21edb8860c5c4f7198f3e SHA512 301a65c91d2342753a4588c40d496114067a18ceceb999f10fe3fc49c7d3a20c7836dba915575db352c89de7ff0ed3553cd8fbd2d1540109cb0ff7fa8f530b6f WHIRLPOOL ec56fae174c57c4736284f7f06628353b6c60490b1c9847fbade5808be50aa6a05aa427d8fa5d634c50dfdc196ef744b3dfc7e70955ea4122f2d84e7122259ae
diff --git a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
new file mode 100644
index 00000000000..c4d872ba50b
--- /dev/null
+++ b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Recover deleted files on an ext3 file system"
+HOMEPAGE="http://code.google.com/p/ext3grep/"
+SRC_URI="http://ext3grep.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug pch"
+
+DOCS="NEWS README"
+
+RDEPEND=""
+DEPEND="sys-fs/e2fsprogs
+ virtual/os-headers
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.10.1-gcc44.patch \
+ "${FILESDIR}"/${P}-include-unistd_h-for-sysconf.patch
+
+ # Fix build against latest e2fsprogs, taken from
+ # https://code.google.com/p/ext3grep/issues/detail?id=34
+ epatch "${FILESDIR}"/${P}-new-e2fsprogs.diff
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable pch)
+}
diff --git a/sys-fs/ext3grep/files/ext3grep-0.10.1-gcc44.patch b/sys-fs/ext3grep/files/ext3grep-0.10.1-gcc44.patch
new file mode 100644
index 00000000000..a7a668c783b
--- /dev/null
+++ b/sys-fs/ext3grep/files/ext3grep-0.10.1-gcc44.patch
@@ -0,0 +1,197 @@
+diff -Naur ext3grep-0.10.1-orig/src/commandline.cc ext3grep-0.10.1/src/commandline.cc
+--- ext3grep-0.10.1-orig/src/commandline.cc 2008-12-14 16:25:53.000000000 +0100
++++ ext3grep-0.10.1/src/commandline.cc 2009-08-04 00:25:40.000000000 +0200
+@@ -32,6 +32,8 @@
+ #include "globals.h"
+ #include "restore.h"
+ #include "accept.h"
++#include <ctime>
++#include <limits>
+
+ // Commandline options.
+ bool commandline_superblock = false;
+diff -Naur ext3grep-0.10.1-orig/src/custom.cc ext3grep-0.10.1/src/custom.cc
+--- ext3grep-0.10.1-orig/src/custom.cc 2008-10-23 00:20:32.000000000 +0200
++++ ext3grep-0.10.1/src/custom.cc 2009-08-04 00:25:40.000000000 +0200
+@@ -42,6 +42,9 @@
+ #include "get_block.h"
+ #include "init_consts.h"
+ #include "print_inode_to.h"
++#include <sys/time.h>
++#include <cstring>
++#include <ctime>
+
+ // The first part of this file was written and used for custom job:
+ // recovering emails on a 40 GB partition that had no information
+diff -Naur ext3grep-0.10.1-orig/src/debug.h ext3grep-0.10.1/src/debug.h
+--- ext3grep-0.10.1-orig/src/debug.h 2008-06-27 17:01:19.000000000 +0200
++++ ext3grep-0.10.1/src/debug.h 2009-08-04 00:25:07.000000000 +0200
+@@ -31,6 +31,7 @@
+
+ #include <iostream>
+ #include <cstdlib> // std::exit, EXIT_FAILURE
++#include <stdint.h>
+
+ #define AllocTag1(p)
+ #define AllocTag2(p, desc)
+diff -Naur ext3grep-0.10.1-orig/src/directories.cc ext3grep-0.10.1/src/directories.cc
+--- ext3grep-0.10.1-orig/src/directories.cc 2008-10-16 00:45:31.000000000 +0200
++++ ext3grep-0.10.1/src/directories.cc 2009-08-04 00:25:40.000000000 +0200
+@@ -33,6 +33,9 @@
+ #include "indirect_blocks.h"
+ #include "get_block.h"
+ #include "directories.h"
++#include <cstring>
++#include <ctime>
++#include <algorithm>
+
+ //-----------------------------------------------------------------------------
+ //
+diff -Naur ext3grep-0.10.1-orig/src/dir_inode_to_block.cc ext3grep-0.10.1/src/dir_inode_to_block.cc
+--- ext3grep-0.10.1-orig/src/dir_inode_to_block.cc 2008-06-28 15:40:06.000000000 +0200
++++ ext3grep-0.10.1/src/dir_inode_to_block.cc 2009-08-04 00:25:40.000000000 +0200
+@@ -40,6 +40,8 @@
+ #include "print_inode_to.h"
+ #include "directories.h"
+ #include "journal.h"
++#include <cstring>
++#include <limits>
+
+ //-----------------------------------------------------------------------------
+ //
+diff -Naur ext3grep-0.10.1-orig/src/histogram.cc ext3grep-0.10.1/src/histogram.cc
+--- ext3grep-0.10.1-orig/src/histogram.cc 2008-06-28 16:13:31.000000000 +0200
++++ ext3grep-0.10.1/src/histogram.cc 2009-08-04 00:25:40.000000000 +0200
+@@ -29,6 +29,7 @@
+ #endif
+
+ #include "commandline.h"
++#include <cstring>
+
+ //-----------------------------------------------------------------------------
+ //
+diff -Naur ext3grep-0.10.1-orig/src/indirect_blocks.cc ext3grep-0.10.1/src/indirect_blocks.cc
+--- ext3grep-0.10.1-orig/src/indirect_blocks.cc 2008-10-20 20:45:29.000000000 +0200
++++ ext3grep-0.10.1/src/indirect_blocks.cc 2009-08-04 00:25:40.000000000 +0200
+@@ -54,6 +54,7 @@
+ #include "forward_declarations.h"
+ #include "endian_conversion.h"
+ #include "superblock.h"
++#include <set>
+
+ //-----------------------------------------------------------------------------
+ //
+diff -Naur ext3grep-0.10.1-orig/src/init_directories.cc ext3grep-0.10.1/src/init_directories.cc
+--- ext3grep-0.10.1-orig/src/init_directories.cc 2008-06-29 21:08:31.000000000 +0200
++++ ext3grep-0.10.1/src/init_directories.cc 2009-08-04 00:25:40.000000000 +0200
+@@ -39,6 +39,7 @@
+ #include "get_block.h"
+ #include "journal.h"
+ #include "dir_inode_to_block.h"
++#include <limits>
+
+ all_directories_type all_directories;
+ inode_to_directory_type inode_to_directory;
+diff -Naur ext3grep-0.10.1-orig/src/init_files.cc ext3grep-0.10.1/src/init_files.cc
+--- ext3grep-0.10.1-orig/src/init_files.cc 2008-06-29 04:39:33.000000000 +0200
++++ ext3grep-0.10.1/src/init_files.cc 2009-08-04 00:25:40.000000000 +0200
+@@ -33,6 +33,7 @@
+ #include "globals.h"
+ #include "forward_declarations.h"
+ #include "journal.h"
++#include <algorithm>
+
+ //-----------------------------------------------------------------------------
+ //
+diff -Naur ext3grep-0.10.1-orig/src/inode.cc ext3grep-0.10.1/src/inode.cc
+--- ext3grep-0.10.1-orig/src/inode.cc 2008-06-29 04:44:39.000000000 +0200
++++ ext3grep-0.10.1/src/inode.cc 2009-08-04 00:25:41.000000000 +0200
+@@ -33,6 +33,7 @@
+ #include "globals.h"
+ #include "conversion.h"
+ #include "inode.h"
++#include <limits>
+
+ #if USE_MMAP
+ void inode_unmap(int group)
+diff -Naur ext3grep-0.10.1-orig/src/is_blockdetection.h ext3grep-0.10.1/src/is_blockdetection.h
+--- ext3grep-0.10.1-orig/src/is_blockdetection.h 2008-07-11 02:23:37.000000000 +0200
++++ ext3grep-0.10.1/src/is_blockdetection.h 2009-08-04 00:25:40.000000000 +0200
+@@ -31,6 +31,8 @@
+
+ #include "inode.h" // Needed for InodePointer
+
++#include <cstring>
++
+ // Return type of is_directory.
+ enum is_directory_type {
+ isdir_no = 0, // Block is not a directory.
+diff -Naur ext3grep-0.10.1-orig/src/journal.cc ext3grep-0.10.1/src/journal.cc
+--- ext3grep-0.10.1-orig/src/journal.cc 2008-10-18 03:06:35.000000000 +0200
++++ ext3grep-0.10.1/src/journal.cc 2009-08-04 00:25:40.000000000 +0200
+@@ -37,6 +37,8 @@
+ #include "indirect_blocks.h"
+ #include "get_block.h"
+ #include "commandline.h"
++#include <algorithm>
++#include <ctime>
+
+ //-----------------------------------------------------------------------------
+ //
+diff -Naur ext3grep-0.10.1-orig/src/last_undeleted_directory_inode_refering_to_block.cc ext3grep-0.10.1/src/last_undeleted_directory_inode_refering_to_block.cc
+--- ext3grep-0.10.1-orig/src/last_undeleted_directory_inode_refering_to_block.cc 2008-07-11 19:18:57.000000000 +0200
++++ ext3grep-0.10.1/src/last_undeleted_directory_inode_refering_to_block.cc 2009-08-04 00:25:41.000000000 +0200
+@@ -29,6 +29,7 @@
+ #include "is_blockdetection.h"
+ #include "inode_refers_to.h"
+ #include "journal.h"
++#include <limits>
+
+ // Return std::numeric_limits<int>::max() if the inode is still allocated
+ // and refering to the given block, otherwise return the Journal sequence
+diff -Naur ext3grep-0.10.1-orig/src/ostream_operators.cc ext3grep-0.10.1/src/ostream_operators.cc
+--- ext3grep-0.10.1-orig/src/ostream_operators.cc 2008-10-20 20:45:29.000000000 +0200
++++ ext3grep-0.10.1/src/ostream_operators.cc 2009-08-04 00:25:41.000000000 +0200
+@@ -31,6 +31,7 @@
+ #include "endian_conversion.h"
+ #include "superblock.h"
+ #include "globals.h"
++#include <ctime>
+
+ //-----------------------------------------------------------------------------
+ //
+diff -Naur ext3grep-0.10.1-orig/src/print_inode_to.cc ext3grep-0.10.1/src/print_inode_to.cc
+--- ext3grep-0.10.1-orig/src/print_inode_to.cc 2008-10-17 03:27:15.000000000 +0200
++++ ext3grep-0.10.1/src/print_inode_to.cc 2009-08-04 00:25:41.000000000 +0200
+@@ -30,6 +30,7 @@
+ #include "FileMode.h"
+ #include "globals.h"
+ #include "print_symlink.h"
++#include <ctime>
+
+ void print_inode_to(std::ostream& os, Inode const& inode)
+ {
+diff -Naur ext3grep-0.10.1-orig/src/restore.cc ext3grep-0.10.1/src/restore.cc
+--- ext3grep-0.10.1-orig/src/restore.cc 2008-10-18 17:30:54.000000000 +0200
++++ ext3grep-0.10.1/src/restore.cc 2009-08-04 00:25:41.000000000 +0200
+@@ -44,6 +44,9 @@
+ #include "FileMode.h"
+ #include "indirect_blocks.h"
+ #include "print_symlink.h"
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <fcntl.h>
+
+ #ifdef CPPGRAPH
+ void iterate_over_all_blocks_of__with__restore_file_action(void) { restore_file_action(0, 0, NULL); }
+diff -Naur ext3grep-0.10.1-orig/src/show_journal_inodes.cc ext3grep-0.10.1/src/show_journal_inodes.cc
+--- ext3grep-0.10.1-orig/src/show_journal_inodes.cc 2008-10-18 03:06:35.000000000 +0200
++++ ext3grep-0.10.1/src/show_journal_inodes.cc 2009-08-04 00:25:41.000000000 +0200
+@@ -30,6 +30,7 @@
+
+ #include "journal.h"
+ #include "print_inode_to.h"
++#include <limits>
+
+ void show_journal_inodes(int inodenr)
+ {
diff --git a/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch b/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch
new file mode 100644
index 00000000000..bf38c27e709
--- /dev/null
+++ b/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/422789
+
+--- src/init_consts.cc
++++ src/init_consts.cc
+@@ -27,6 +27,10 @@
+ #include "debug.h"
+ #endif
+
++#if USE_MMAP
++#include <unistd.h> /* sysconf */
++#endif
++
+ #include "globals.h"
+ #include "superblock.h"
+ #include "forward_declarations.h"
diff --git a/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff b/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff
new file mode 100644
index 00000000000..45b54b807bd
--- /dev/null
+++ b/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff
@@ -0,0 +1,34 @@
+diff -ur ext3grep-0.10.1/src/ext3.h ext3grep-0.10.1.new/src/ext3.h
+--- ext3grep-0.10.1/src/ext3.h 2008-04-09 11:20:31.000000000 +0000
++++ ext3grep-0.10.1.new/src/ext3.h 2011-12-10 07:00:50.000000000 +0000
+@@ -24,6 +24,17 @@
+ #ifndef EXT3_H
+ #define EXT3_H
+
++// this trickery needs to happen before ext2_fs is included so
++// bail out if it has already been included by another path
++#ifdef _LINUX_EXT2_FS_H
++ #error please include this file before any other includes of ext2fs/ext2_fs.h
++#endif
++
++// some versions of the ext2 headers call this s_frags_per_group and some
++// call it s_clusters_per_group, define one to the other so our code works
++// with both
++#define s_clusters_per_group s_frags_per_group
++
+ // Use the header files from e2progs (http://e2fsprogs.sourceforge.net)
+ // We can use these headers and then everything named ext2 or ext3.
+ #include <ext2fs/ext2_fs.h> // Definitions of ext2, ext3 and ext4.
+@@ -110,6 +121,12 @@
+ __u32 faddr(void) const { return i_faddr; }
+ __u16 uid_high(void) const { return i_uid_high; }
+ __u16 gid_high(void) const { return i_gid_high; }
++#ifndef i_reseved2
++ //i_reseved2 has been split into two fields in recent
++ //versions of the headers, luckilly we can still access
++ //it in one peice through the hurd side of the union
++ #define i_reserved2 osd2.hurd2.h_i_author
++#endif
+ __u32 reserved2(void) const { return i_reserved2; }
+
+ void set_reserved2(__u32 val) { i_reserved2 = val; }
diff --git a/sys-fs/ext3grep/metadata.xml b/sys-fs/ext3grep/metadata.xml
new file mode 100644
index 00000000000..d4c00544c52
--- /dev/null
+++ b/sys-fs/ext3grep/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">ext3grep</remote-id>
+ </upstream>
+</pkgmetadata>