summaryrefslogtreecommitdiff
path: root/sys-fs/ext4magic
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-19 02:28:57 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-19 02:28:57 -0400
commit029e17b98f838bdf8d1c6c1b89946db6dd63d2fe (patch)
tree9371b08fa63337682921c572628e8e5150c2546e /sys-fs/ext4magic
parent45c8ffbd7ce3d08a80af90255e71dfe57eb22a91 (diff)
downloadgentoo-029e17b98f838bdf8d1c6c1b89946db6dd63d2fe.tar.gz
gentoo-029e17b98f838bdf8d1c6c1b89946db6dd63d2fe.tar.xz
sys-fs/ext4magic: fix building w/newer glibc #580192
Diffstat (limited to 'sys-fs/ext4magic')
-rw-r--r--sys-fs/ext4magic/ext4magic-0.3.2.ebuild4
-rw-r--r--sys-fs/ext4magic/files/ext4magic-0.3.2-sysmacros.patch13
2 files changed, 17 insertions, 0 deletions
diff --git a/sys-fs/ext4magic/ext4magic-0.3.2.ebuild b/sys-fs/ext4magic/ext4magic-0.3.2.ebuild
index 3c16018f9f4..a7f2b13cbfe 100644
--- a/sys-fs/ext4magic/ext4magic-0.3.2.ebuild
+++ b/sys-fs/ext4magic/ext4magic-0.3.2.ebuild
@@ -24,6 +24,10 @@ DEPEND="${RDEPEND}"
DOCS="AUTHORS ChangeLog NEWS README TODO"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sysmacros.patch #580192
+}
+
src_configure() {
# build-system incorrectly recognizes '--disable-feature' options as enabled!
econf \
diff --git a/sys-fs/ext4magic/files/ext4magic-0.3.2-sysmacros.patch b/sys-fs/ext4magic/files/ext4magic-0.3.2-sysmacros.patch
new file mode 100644
index 00000000000..954d9612b5a
--- /dev/null
+++ b/sys-fs/ext4magic/files/ext4magic-0.3.2-sysmacros.patch
@@ -0,0 +1,13 @@
+https://sourceforge.net/p/ext4magic/tickets/4/
+https://bugs.gentoo.org/580192
+
+--- a/src/recover.c
++++ b/src/recover.c
+@@ -21,6 +21,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <utime.h>