summaryrefslogtreecommitdiff
path: root/sys-fs/extundelete
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/extundelete
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/extundelete')
-rw-r--r--sys-fs/extundelete/Manifest3
-rw-r--r--sys-fs/extundelete/extundelete-0.2.0-r1.ebuild27
-rw-r--r--sys-fs/extundelete/extundelete-0.2.0-r2.ebuild30
-rw-r--r--sys-fs/extundelete/extundelete-0.2.4.ebuild21
-rw-r--r--sys-fs/extundelete/files/extundelete-0.2.0-build.patch23
-rw-r--r--sys-fs/extundelete/metadata.xml12
6 files changed, 116 insertions, 0 deletions
diff --git a/sys-fs/extundelete/Manifest b/sys-fs/extundelete/Manifest
new file mode 100644
index 00000000000..3ba78306f20
--- /dev/null
+++ b/sys-fs/extundelete/Manifest
@@ -0,0 +1,3 @@
+DIST extundelete-0.2.0.tar.bz2 97851 SHA256 0f6a3004d8ddcafe63059a104c174f753c7fc95455081f3ff5aaf3b8c100f97b SHA512 2d4b18110795a5318fab5c5889a9b516360ea420215d0a3692322b30e87d5bb3954bbba725a067322cd76e7bba06466032a1405f9fc6dbc3f318723be238b317 WHIRLPOOL 5e79c5485eb323593289bc7b82a0960c9174e91f1491b9c64097c6095b7065b14dfafa3efe89030dbd3007d28ff54bb4d12814f5a5cf72920ceff63085c437a9
+DIST extundelete-0.2.4.tar.bz2 108472 SHA256 a1f9dd61247056d36401ce5d6785e74d08a184340eebd3865c345ddaa93f19f4 SHA512 5c896055b6fa3c38f283a043cca744513fdc1a60e212eac0c78fa868064a8eeb11f540c4cc5ca89ac68da0c1705a40fe45731c203b6748808f85e9870a207bcd WHIRLPOOL b7b9372ce38edf03c9d11199ff0ff225e1993b2e5a791f288db802f4a7789bca52c5e9d56361f18831cf472bdab4b7349e8b0f41ecbd26a6fcdee7d7a9772ec2
+DIST extundelete_0.2.0-2.1.debian.tar.gz 6862 SHA256 3e37f24ac60bd60a0d162184b2834b85bac0cd4cd2d055e1f687ed6a88f70f97 SHA512 37b74347a3017edfd28714731125f968f66beac1b7b7ebd1d44e3d3dff9da06216560433f330f4a544da24f7083f6e900fbe8a5c2930e8760405cb72e6a918e3 WHIRLPOOL e403d2f546d3d15032f6e49220cc0ca55bb9d7cfd0515030b57058e4d177f00ac34c378d08e5eb61245287322fa9d4d579d169e41e2b6b01e0109e112dff7642
diff --git a/sys-fs/extundelete/extundelete-0.2.0-r1.ebuild b/sys-fs/extundelete/extundelete-0.2.0-r1.ebuild
new file mode 100644
index 00000000000..525b7779556
--- /dev/null
+++ b/sys-fs/extundelete/extundelete-0.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+_E2FS=1.42
+
+DESCRIPTION="A utility to undelete files from an ext3 or ext4 partition"
+HOMEPAGE="http://extundelete.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/e2fsprogs-${_E2FS}
+ >=sys-libs/e2fsprogs-libs-${_E2FS}"
+DEPEND="${RDEPEND}"
+
+DOCS="README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
diff --git a/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild b/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild
new file mode 100644
index 00000000000..60884ae20e5
--- /dev/null
+++ b/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+_UNDEL_DEB=2.1
+_UNDEL_E2FS=1.42.6
+
+DESCRIPTION="A utility to undelete files from an ext3 or ext4 partition"
+HOMEPAGE="http://extundelete.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${_UNDEL_DEB}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/e2fsprogs-${_UNDEL_E2FS}
+ >=sys-libs/e2fsprogs-libs-${_UNDEL_E2FS}"
+DEPEND=${RDEPEND}
+
+DOCS=README
+
+src_prepare() {
+ local d=${WORKDIR}/debian/patches
+ EPATCH_SOURCE=${d} epatch $(<"${d}"/series)
+}
diff --git a/sys-fs/extundelete/extundelete-0.2.4.ebuild b/sys-fs/extundelete/extundelete-0.2.4.ebuild
new file mode 100644
index 00000000000..bc3ba3e6301
--- /dev/null
+++ b/sys-fs/extundelete/extundelete-0.2.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A utility to undelete files from an ext3 or ext4 partition"
+HOMEPAGE="http://extundelete.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="amd64 x86"
+IUSE=""
+
+E2FSPROGS=1.42.6
+RDEPEND=">=sys-fs/e2fsprogs-${E2FSPROGS}
+ >=sys-libs/e2fsprogs-libs-${E2FSPROGS}"
+DEPEND=${RDEPEND}
+
+DOCS=README
diff --git a/sys-fs/extundelete/files/extundelete-0.2.0-build.patch b/sys-fs/extundelete/files/extundelete-0.2.0-build.patch
new file mode 100644
index 00000000000..2bd56ef2bbd
--- /dev/null
+++ b/sys-fs/extundelete/files/extundelete-0.2.0-build.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/402633
+http://projects.archlinux.org/svntogit/community.git/tree/trunk/extundelete-build.patch?h=packages/extundelete
+
+--- src/extundelete.cc
++++ src/extundelete.cc
+@@ -943,3 +943,3 @@
+ {
+- group_descriptor_table[n] = fs->group_desc[n];
++ group_descriptor_table[n] = *ext2fs_group_desc(fs, fs->group_desc, n);
+ }
+@@ -2613,3 +2613,4 @@
+ inode->osd2.linux2.l_i_gid_high = le16_to_cpu( (uint16_t *) &inodebuf[item*60] );
+- inode->osd2.linux2.l_i_reserved2 = le32_to_cpu( (uint32_t *) &inodebuf[item*62] );
++ inode->osd2.linux2.l_i_checksum_lo = le16_to_cpu( (uint16_t *) &inodebuf[item*62] );
++ inode->osd2.linux2.l_i_reserved = le16_to_cpu( (uint16_t *) &inodebuf[item*63] );
+ }
+--- src/insertionops.cc
++++ src/insertionops.cc
+@@ -65,3 +65,3 @@
+ os << "# Blocks per group: " << s_block->s_blocks_per_group << std::endl;
+- os << "# Fragments per group: " << s_block->s_frags_per_group << std::endl;
++ os << "# Fragments per group: " << s_block->s_clusters_per_group << std::endl;
+ os << "# Inodes per group: " << s_block->s_inodes_per_group << std::endl;
diff --git a/sys-fs/extundelete/metadata.xml b/sys-fs/extundelete/metadata.xml
new file mode 100644
index 00000000000..3af20051255
--- /dev/null
+++ b/sys-fs/extundelete/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">extundelete</remote-id>
+ </upstream>
+</pkgmetadata>