summaryrefslogtreecommitdiff
path: root/sys-fs/fatsort
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/fatsort
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/fatsort')
-rw-r--r--sys-fs/fatsort/Manifest1
-rw-r--r--sys-fs/fatsort/fatsort-1.3.ebuild40
-rw-r--r--sys-fs/fatsort/files/fatsort-1.2-tests.patch30
-rw-r--r--sys-fs/fatsort/metadata.xml17
4 files changed, 88 insertions, 0 deletions
diff --git a/sys-fs/fatsort/Manifest b/sys-fs/fatsort/Manifest
new file mode 100644
index 00000000000..e949381427c
--- /dev/null
+++ b/sys-fs/fatsort/Manifest
@@ -0,0 +1 @@
+DIST fatsort-1.3.365.tar.gz 57209 SHA256 77acc374b189e80e3d75d3508f3c0ca559f8030f1c220f7cfde719a4adb03f3d SHA512 e3611841501e6dded8fd6270188ffb00191a20e93d84b0729cd2e215d37317f48e08bd67da41b88604858ef6f661e4b921b80645f454b78f91bfd2d0d4254d29 WHIRLPOOL 0998259baf3f315b0d7485fdf7d8172fa4c8f17f3f41fd163780eeaf7b6eda6c2e5dfdd99e9d0dd603bcd53aa6fc2a1ea6e1e2a2f14d211a8fc01b8db4ddeb9d
diff --git a/sys-fs/fatsort/fatsort-1.3.ebuild b/sys-fs/fatsort/fatsort-1.3.ebuild
new file mode 100644
index 00000000000..97697b8b8de
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+SVN_REV=365
+MY_P=${P}.${SVN_REV}
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players"
+HOMEPAGE="http://fatsort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="test? ( dev-util/bbe sys-fs/dosfstools )"
+
+RESTRICT="test? ( userpriv )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e '/^\(MANDIR=\|SBINDIR=\)/s|/usr/local|/usr|' \
+ $(find ./ -name Makefile) || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ DESTDIR="${D}"
+}
+
+src_test() {
+ make tests
+}
diff --git a/sys-fs/fatsort/files/fatsort-1.2-tests.patch b/sys-fs/fatsort/files/fatsort-1.2-tests.patch
new file mode 100644
index 00000000000..6fc44e23efc
--- /dev/null
+++ b/sys-fs/fatsort/files/fatsort-1.2-tests.patch
@@ -0,0 +1,30 @@
+diff -Naur tests/tc_check_consistent_version/Makefile tests/tc_check_consistent_version/Makefile
+--- tests/tc_check_consistent_version/Makefile 2013-12-10 21:52:36.773278926 +0100
++++ tests/tc_check_consistent_version/Makefile 2013-12-10 21:52:43.783278646 +0100
+@@ -2,8 +2,8 @@
+
+ all:
+ manver=\
+- `head -1 ../../man/fatsort.1 | sed -e "s/.* \([0-9.]*\)\"$$/\1/"`; \
+- progver=`../../src/fatsort -v | head -1 | sed -e "s/^.* \([0-9.]\+\) .*$$/\1/"`; \
++ `head -2 ../../man/fatsort.1 | tail -1 | sed -e "s/^.*\"fatsort \([0-9.]\+\)\".*$$/\1/"`; \
++ progver=`../../src/fatsort --version | head -1 | sed -e "s/^fatsort \([0-9.]\+\).*$$/\1/"`; \
+ changesver=`head -1 ../../CHANGES | sed -e "s/^.*v\([0-9.]\+\)$$/\1/"`; \
+ echo "#$$manver#$$progver#$$changesver#"; \
+ [ "$$manver" = "$$progver" ]; \
+diff -Naur tests/tc_pos_sort_modification_time/Makefile tests/tc_pos_sort_modification_time/Makefile
+--- tests/tc_pos_sort_modification_time/Makefile 2013-12-10 21:52:36.772278926 +0100
++++ tests/tc_pos_sort_modification_time/Makefile 2013-12-10 21:57:06.433268173 +0100
+@@ -44,10 +44,11 @@
+ sudo mount -o loop,codepage=850,iocharset=iso8859-1,utf8,uid=${MOUNT_UID},gid=${MOUNT_GID} ${FS_IMG} ${MOUNT_POINT}
+ cat ${DIRECTORIES} | while read dir; do mkdir -p "${MOUNT_POINT}/$$dir"; done
+ cat ${FILES} | while read file; do touch "${MOUNT_POINT}/$$file"; done
+- sleep 3
++ sleep 1
+ touch ${MOUNT_POINT}/last # alter modification time
++ sleep 1
+ touch ${MOUNT_POINT}/first -t 200001010101.01
+-
++ sleep 1
+ sudo umount -l ${MOUNT_POINT}
+ rmdir ${MOUNT_POINT}
diff --git a/sys-fs/fatsort/metadata.xml b/sys-fs/fatsort/metadata.xml
new file mode 100644
index 00000000000..0cac73550ec
--- /dev/null
+++ b/sys-fs/fatsort/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>billie@gentoo.org</email>
+ <name>Daniel Pielmeier</name>
+ </maintainer>
+ <longdescription><pkg>sys-fs/fatsort</pkg> is a utility that sorts FAT16 and FAT32 partitions. It even can
+ handle long file name entries. It reads the boot sector and sorts the
+ directory structure recursively. The main use case is to sort files on an
+ Audio player that does not implement the sorting function itself but plays
+ the files in the same order as they were copied to the disk.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">fatsort</remote-id>
+ </upstream>
+</pkgmetadata>