summaryrefslogtreecommitdiff
path: root/sys-fs/gfs2-utils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/gfs2-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/gfs2-utils')
-rw-r--r--sys-fs/gfs2-utils/Manifest3
-rw-r--r--sys-fs/gfs2-utils/gfs2-utils-3.1.2.ebuild50
-rw-r--r--sys-fs/gfs2-utils/gfs2-utils-3.1.3.ebuild50
-rw-r--r--sys-fs/gfs2-utils/gfs2-utils-3.1.5.ebuild52
-rw-r--r--sys-fs/gfs2-utils/metadata.xml6
5 files changed, 161 insertions, 0 deletions
diff --git a/sys-fs/gfs2-utils/Manifest b/sys-fs/gfs2-utils/Manifest
new file mode 100644
index 00000000000..ee76e4c3891
--- /dev/null
+++ b/sys-fs/gfs2-utils/Manifest
@@ -0,0 +1,3 @@
+DIST gfs2-utils-3.1.2.tar.gz 348485 SHA256 34e3eabb0b95bcb4358268df6209af597688e7138161152b51d1c60b533d9fbd
+DIST gfs2-utils-3.1.3.tar.gz 356745 SHA256 0f27670ef1cb46105e9adbe3ffbc7bd51112bbb12164754d9d0c799344b6fe33 SHA512 3a3ac7cd446d20ebdae2f8283acc828a9e104509e35196c8320579f7bc7dd4eb1fb75873541f10bcdd614505beba6c70f188428a2ddac7725c2fa23c9cc86910 WHIRLPOOL cd2e1cf15435b087d74c0f0e82ff565f596a62396832e36b4c788b0d1839ab00415b954477666f73fd491860022adaa646dfbe33691a2f738e4e13bc9259e604
+DIST gfs2-utils-3.1.5.tar.gz 336862 SHA256 8676bb20e0961883920803e19e79dc6205df86ef4c66080275706c6da9a13d18 SHA512 85fea4ea93eaad2f0bdb6c57c9d193a8ee8be47e05dff15f2883ca11487f49d843a2d02590f4844c7ce9d80f8967bd6dd18b652e56f78f9f3ae9e9c7274b285e WHIRLPOOL 7a5027b9302da04d55ddd44b18e1638a30c1adfcbf30041dd609198ada36b0a7258ba52ca7df291cd2c587ec0c1664d357b73cf5c54846afb2ab2eabb05ea2c0
diff --git a/sys-fs/gfs2-utils/gfs2-utils-3.1.2.ebuild b/sys-fs/gfs2-utils/gfs2-utils-3.1.2.ebuild
new file mode 100644
index 00000000000..147b1246777
--- /dev/null
+++ b/sys-fs/gfs2-utils/gfs2-utils-3.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools linux-info
+
+DESCRIPTION="GFS2 Utilities"
+HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
+SRC_URI="https://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="sys-cluster/corosync
+ sys-cluster/openais
+ sys-cluster/liblogthread
+ sys-cluster/libccs
+ sys-cluster/libfence
+ sys-cluster/libdlm
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ mkdir m4
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --with-kernel="${KERNEL_DIR}" \
+ --localstatedir=/var
+}
+
+src_install() {
+ default
+ rm -rf "${D}/usr/share/doc"
+ dodoc doc/*.txt
+
+ rmdir "${D}"/var/run/{cluster,} # cman-init.d creates it
+
+ keepdir /var/{lib,log}/cluster
+}
diff --git a/sys-fs/gfs2-utils/gfs2-utils-3.1.3.ebuild b/sys-fs/gfs2-utils/gfs2-utils-3.1.3.ebuild
new file mode 100644
index 00000000000..ed55398c516
--- /dev/null
+++ b/sys-fs/gfs2-utils/gfs2-utils-3.1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools linux-info
+
+DESCRIPTION="GFS2 Utilities"
+HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
+SRC_URI="https://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="sys-cluster/corosync
+ sys-cluster/openais
+ sys-cluster/liblogthread
+ sys-cluster/libccs
+ sys-cluster/libfence
+ sys-cluster/libdlm
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ mkdir m4
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --with-kernel="${KERNEL_DIR}" \
+ --localstatedir=/var
+}
+
+src_install() {
+ default
+ rm -rf "${D}/usr/share/doc"
+ dodoc doc/*.txt
+
+ rmdir "${D}"/var/run/{cluster,} # cman-init.d creates it
+
+ keepdir /var/{lib,log}/cluster
+}
diff --git a/sys-fs/gfs2-utils/gfs2-utils-3.1.5.ebuild b/sys-fs/gfs2-utils/gfs2-utils-3.1.5.ebuild
new file mode 100644
index 00000000000..c20be01e89a
--- /dev/null
+++ b/sys-fs/gfs2-utils/gfs2-utils-3.1.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools linux-info
+
+DESCRIPTION="GFS2 Utilities"
+HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
+SRC_URI="https://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="sys-cluster/corosync
+ sys-cluster/openais
+ sys-cluster/liblogthread
+ sys-cluster/libccs
+ sys-cluster/libfence
+ sys-cluster/libdlm
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --localstatedir=/var
+}
+
+src_compile() {
+ # parallel build is broken
+ emake -j1
+}
+
+src_install() {
+ default
+ rm -rf "${D}/usr/share/doc"
+ dodoc doc/*.txt
+
+ keepdir /var/{lib,log}/cluster
+}
diff --git a/sys-fs/gfs2-utils/metadata.xml b/sys-fs/gfs2-utils/metadata.xml
new file mode 100644
index 00000000000..71656942007
--- /dev/null
+++ b/sys-fs/gfs2-utils/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <longdescription>GFS2 Utilities</longdescription>
+</pkgmetadata>