summaryrefslogtreecommitdiff
path: root/sys-fs/lufs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/lufs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/lufs')
-rw-r--r--sys-fs/lufs/Manifest1
-rw-r--r--sys-fs/lufs/files/lufs-0.9.7-enable-gnome-2.patch72
-rw-r--r--sys-fs/lufs/files/lufs-0.9.7-fPIC.patch12
-rw-r--r--sys-fs/lufs/files/lufs-0.9.7-gcc43.patch33
-rw-r--r--sys-fs/lufs/files/lufs-automount-port.diff28
-rw-r--r--sys-fs/lufs/files/lufs-no-kernel.patch111
-rw-r--r--sys-fs/lufs/lufs-0.9.7-r3.ebuild71
-rw-r--r--sys-fs/lufs/metadata.xml8
8 files changed, 336 insertions, 0 deletions
diff --git a/sys-fs/lufs/Manifest b/sys-fs/lufs/Manifest
new file mode 100644
index 00000000000..39790d71508
--- /dev/null
+++ b/sys-fs/lufs/Manifest
@@ -0,0 +1 @@
+DIST lufs-0.9.7.tar.gz 537772 SHA256 2d91457906ee2ff1e26de82987019fe2efe22d9c3b6c7741b7ed8fffbae51411
diff --git a/sys-fs/lufs/files/lufs-0.9.7-enable-gnome-2.patch b/sys-fs/lufs/files/lufs-0.9.7-enable-gnome-2.patch
new file mode 100644
index 00000000000..6d6d4ba3b1a
--- /dev/null
+++ b/sys-fs/lufs/files/lufs-0.9.7-enable-gnome-2.patch
@@ -0,0 +1,72 @@
+diff -upr -x aclocal.m4 -x Makefile.in -x configure -x '.*' -x autom4te.cache -x kernel lufs-0.9.7.orig/config.h.in lufs-0.9.7/config.h.in
+--- lufs-0.9.7.orig/config.h.in 2003-10-29 22:48:48.000000000 +0000
++++ lufs-0.9.7/config.h.in 2004-01-13 22:51:00.000000000 +0000
+@@ -9,6 +9,9 @@
+ /* Define if libchipcard is present. */
+ #undef HAS_LIBCHIPCARD
+
++/* Define if using libgnome-2 rather than 1. */
++#undef HAS_LIBGNOME_2
++
+ /* Define if ssh is found. */
+ #undef HAS_SSH
+
+diff -upr -x aclocal.m4 -x Makefile.in -x configure -x '.*' -x autom4te.cache -x kernel lufs-0.9.7.orig/configure.in lufs-0.9.7/configure.in
+--- lufs-0.9.7.orig/configure.in 2003-10-29 22:40:28.000000000 +0000
++++ lufs-0.9.7/configure.in 2004-01-13 22:50:20.802647656 +0000
+@@ -164,7 +164,9 @@ AC_SUBST(SSHPROG)
+ dnl Checking gnome
+ AC_CHECK_PROG(GCONF, gnome-config, gnome-config)
+ AC_CHECK_PROG(GVFSCONF, gnome-vfs-config, gnome-vfs-config)
++AC_CHECK_PROG(PKGCONF, pkg-config, pkg-config)
+ AC_CHECK_LIB(gnomevfs, gnome_vfs_init, HAS_GNOMEVFS=1,)
++AC_CHECK_LIB(gnomevfs-2, gnome_vfs_init, HAS_GNOMEVFS2=1,`$PKGCONF --libs-only-l gnome-vfs-2.0`)
+ if test "$GCONF" -a "$GVFSCONF" -a "$HAS_GNOMEVFS"
+ then
+ AC_DEFINE([HAS_GVFS], 1, [Define if gvfs is to be built.])
+@@ -172,6 +174,16 @@ then
+ GVFS_LDADD="`$GCONF --libs gnome` `$GVFSCONF --libs`"
+ GVFS_CFLAGS="`$GCONF --cflags gnome` `$GVFSCONF --cflags`"
+ opt_fs="$opt_fs gvfs"
++elif test "$PKGCONF" -a "$HAS_GNOMEVFS2"
++then
++ AC_DEFINE([HAS_GVFS], 1, [Define if gvfs is to be built.])
++ AC_DEFINE([HAS_LIBGNOME_2], 1, [Define if using libgnome-2 rather than 1.])
++ define_has_libgnome_2="#define HAS_LIBGNOME_2"
++ AC_SUBST(define_has_libgnome_2)
++
++ GVFS_LDADD="`$PKGCONF --libs libgnome-2.0` `$PKGCONF --libs gnome-vfs-2.0`"
++ GVFS_CFLAGS="`$PKGCONF --cflags libgnome-2.0` `$PKGCONF --cflags gnome-vfs-2.0`"
++ opt_fs="$opt_fs gvfs"
+ fi
+ AC_SUBST(GVFS_LDADD)
+ AC_SUBST(GVFS_CFLAGS)
+diff -upr -x aclocal.m4 -x Makefile.in -x configure -x '.*' -x autom4te.cache -x kernel lufs-0.9.7.orig/filesystems/gvfs/gvfs.cpp lufs-0.9.7/filesystems/gvfs/gvfs.cpp
+--- lufs-0.9.7.orig/filesystems/gvfs/gvfs.cpp 2003-03-08 21:45:29.000000000 +0000
++++ lufs-0.9.7/filesystems/gvfs/gvfs.cpp 2004-01-13 22:55:44.906376400 +0000
+@@ -36,8 +36,13 @@
+ #include <lufs/fs.h>
+
+ #include "gvfs.h"
++#include "config.h"
+
++#ifdef HAS_LIBGNOME_2
++#include <libgnome/libgnome.h>
++#else
+ #include <gnome.h>
++#endif
+ #include <libgnomevfs/gnome-vfs.h>
+
+ extern "C" {
+@@ -275,7 +280,11 @@ GVFS::do_readdir(char* d, struct directo
+ goto out_uri;
+ }
+
++#ifdef HAS_LIBGNOME_2
++ if(gnome_vfs_directory_open_from_uri(&dir, uri, GNOME_VFS_FILE_INFO_DEFAULT) != GNOME_VFS_OK){
++#else
+ if(gnome_vfs_directory_open_from_uri(&dir, uri, GNOME_VFS_FILE_INFO_DEFAULT, NULL) != GNOME_VFS_OK){
++#endif
+ WARN("could not open directory!");
+ goto out_info;
+ }
diff --git a/sys-fs/lufs/files/lufs-0.9.7-fPIC.patch b/sys-fs/lufs/files/lufs-0.9.7-fPIC.patch
new file mode 100644
index 00000000000..05bb1d2f5d2
--- /dev/null
+++ b/sys-fs/lufs/files/lufs-0.9.7-fPIC.patch
@@ -0,0 +1,12 @@
+--- filesystems/gnetfs/Makefile.in 2004-03-18 15:59:28.391299639 +0000
++++ filesystems/gnetfs/Makefile.in 2004-03-18 15:59:45.316142704 +0000
+@@ -197,7 +197,7 @@
+ @AMDEP_TRUE@ ./$(DEPDIR)/vtree.Plo ./$(DEPDIR)/xfer.Plo
+-COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
++COMPILE = $(CC) -fPIC $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
++LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -prefer-pic $(DEFS) $(DEFAULT_INCLUDES) \
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
diff --git a/sys-fs/lufs/files/lufs-0.9.7-gcc43.patch b/sys-fs/lufs/files/lufs-0.9.7-gcc43.patch
new file mode 100644
index 00000000000..3736ba62b01
--- /dev/null
+++ b/sys-fs/lufs/files/lufs-0.9.7-gcc43.patch
@@ -0,0 +1,33 @@
+--- filesystems/ftpfs/ftplib.cpp.orig 2008-06-08 20:01:35.000000000 +0200
++++ filesystems/ftpfs/ftplib.cpp 2008-06-08 20:01:53.000000000 +0200
+@@ -20,6 +20,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <cstring>
+ #include <unistd.h>
+ #include <netdb.h>
+ #include <stdio.h>
+--- filesystems/ftpfs/ftpfs.h.orig 2008-06-08 20:04:33.000000000 +0200
++++ filesystems/ftpfs/ftpfs.h 2008-06-08 20:05:07.000000000 +0200
+@@ -23,6 +23,8 @@
+ #ifndef _FTPFS_H_
+ #define _FTPFS_H_
+
++#include <cstdlib>
++#include <cstring>
+ using namespace std;
+
+ struct directory;
+--- filesystems/sshfs/sftplib.h.orig 2008-06-08 20:08:55.000000000 +0200
++++ filesystems/sshfs/sftplib.h 2008-06-08 20:09:43.000000000 +0200
+@@ -28,6 +28,9 @@
+
+ #include <string>
+
++#include <cstring>
++#include <cstdlib>
++
+ using namespace std;
+
+ #define MAXDATA 32768
diff --git a/sys-fs/lufs/files/lufs-automount-port.diff b/sys-fs/lufs/files/lufs-automount-port.diff
new file mode 100644
index 00000000000..b184b20aba9
--- /dev/null
+++ b/sys-fs/lufs/files/lufs-automount-port.diff
@@ -0,0 +1,28 @@
+Files lufs-0.9.5.org/util/a.out and lufs-0.9.5/util/a.out differ
+diff -Nur lufs-0.9.5.org/util/auto.sshfs.c lufs-0.9.5/util/auto.sshfs.c
+--- lufs-0.9.5.org/util/auto.sshfs.c 2003-10-24 16:51:49.000000000 +0200
++++ lufs-0.9.5/util/auto.sshfs.c 2003-10-24 16:54:15.000000000 +0200
+@@ -26,6 +26,8 @@
+ int
+ main(int argc, char **argv){
+ char *c;
++ char *d;
++ int port = 22;
+
+ if(argc < 2)
+ return 1;
+@@ -34,8 +36,12 @@
+ return 1;
+
+ *c = 0;
+-
+- printf("-fstype=lufs,fs=sshfs,quiet,host=%s,username=%s none\n", c + 1, argv[1]);
++ d = strchr(c + 1, ':');
++ if (d) {
++ port = atoi(d + 1);
++ *d = 0;
++ }
++ printf("-fstype=lufs,fs=sshfs,quiet,host=%s,port=%d,username=%s none\n", c + 1,port, argv[1]);
+
+ return 0;
+ }
diff --git a/sys-fs/lufs/files/lufs-no-kernel.patch b/sys-fs/lufs/files/lufs-no-kernel.patch
new file mode 100644
index 00000000000..75a67dbf9a1
--- /dev/null
+++ b/sys-fs/lufs/files/lufs-no-kernel.patch
@@ -0,0 +1,111 @@
+diff -pur lufs-0.9.7.orig/configure.in lufs-0.9.7/configure.in
+--- lufs-0.9.7.orig/configure.in 2005-02-07 07:59:18.000000000 +0100
++++ lufs-0.9.7/configure.in 2005-02-07 07:59:40.000000000 +0100
+@@ -9,107 +9,6 @@ AM_INIT_AUTOMAKE(lufs,0.9.7)
+ dnl "static" FSs
+ opt_fs="localfs locasefs ftpfs gnetfs"
+
+-AC_ARG_ENABLE(kernel-support,
+- [ --enable-kernel-support enable building of the kernel module (default=yes)],
+- [ KERNEL_SUPPORT=$enableval ],)
+-
+-if test "$KERNEL_SUPPORT" != "no"
+-then
+-
+- dnl Checking os
+- AC_MSG_CHECKING(OS)
+- OS_DIR=`uname -s`
+- if test ! -d kernel/$OS_DIR
+- then
+- AC_MSG_ERROR($OS_DIR - not supported!)
+- else
+- AC_MSG_RESULT($OS_DIR)
+- fi
+-
+- dnl LINUX kernel configuration
+- if test "$OS_DIR"="Linux"
+- then
+-
+- dnl Checking kernel & headers
+- AC_MSG_CHECKING(kernel)
+- AC_ARG_WITH(kernel,
+- [ --with-kernel=VERSION specify a kernel version to compile for],
+- [KERNEL_VERSION=$withval],
+- [KERNEL_VERSION=`uname -r`])
+- MODULES_DIR=/lib/modules/$KERNEL_VERSION
+- AC_MSG_RESULT($KERNEL_VERSION)
+-
+- AC_MSG_CHECKING(kernel support)
+- KERNEL_DIR=`echo $KERNEL_VERSION | cut -d'.' -f1,2`
+- if test ! -d kernel/$OS_DIR/$KERNEL_DIR
+- then
+- AC_MSG_ERROR([$KERNEL_DIR not supported!])
+- else
+- AC_MSG_RESULT([supported in kernel/$OS_DIR/$KERNEL_DIR])
+- fi
+-
+- AC_MSG_CHECKING(kernel headers)
+- AC_ARG_WITH(kheaders,
+- [ --with-kheaders=DIR specify the location of the kernel headers],
+- [KERNEL_HDR=$withval],
+- [KERNEL_HDR=$MODULES_DIR/build/include])
+- if test ! -f $KERNEL_HDR/linux/fs.h
+- then
+- AC_MSG_ERROR([not found in $KERNEL_HDR. please install them!])
+- else
+- AC_MSG_RESULT([found in $KERNEL_HDR])
+- fi
+-
+- AC_MSG_CHECKING(kernel configuration)
+- if test -f $MODULES_DIR/build/.config
+- then
+- tmp=`cat $MODULES_DIR/build/.config | grep CONFIG_MODVERSIONS=y`
+- if test "$tmp"
+- then
+- AC_MSG_RESULT([found, using modversions])
+- MODVERSIONS="yes"
+-# MODV_FLAGS="-DMODVERSIONS -include $KERNEL_HDR/linux/modversions.h"
+- else
+- AC_MSG_RESULT([found, not using modversions])
+- fi
+- else
+- AC_MSG_RESULT([not found at $MODULES_DIR/build/.config, assuming modversions support])
+- MODVERSIONS="yes"
+-# MODV_FLAGS="-DMODVERSIONS -include $KERNEL_HDR/linux/modversions.h"
+- fi
+-
+- AC_ARG_ENABLE(modversions,
+- [ --enable-modversions enable modeversions support (default=auto-detect)],
+- [ if test $enableval = "yes"; then MODVERSIONS="yes"; else MODVERSIONS=""; fi ],)
+-
+- if test $MODVERSIONS; then
+- AC_MSG_CHECKING(modversions.h)
+- if test -f $KERNEL_HDR/linux/modversions.h; then
+- MODV_FILE="$KERNEL_HDR/linux/modversions.h"
+- fi
+-
+- if test -f $KERNEL_HDR/config/modversions.h; then
+- MODV_FILE="$KERNEL_HDR/config/modversions.h"
+- fi
+-
+- if test $MODV_FILE; then
+- MODV_FLAGS="-DMODVERSIONS -include $MODV_FILE"
+- AC_MSG_RESULT([$MODV_FILE])
+- else
+- AC_MSG_ERROR([not found!])
+- fi
+- fi
+-
+- AC_SUBST(MODV_FLAGS)
+- AC_SUBST(KERNEL_DIR)
+- AC_SUBST(MODULES_DIR)
+- AC_SUBST(KERNEL_HDR)
+-
+- fi
+-fi
+-AC_SUBST(OS_DIR)
+-
+-
+ dnl options
+ AC_ARG_ENABLE(debug,
+ [ --enable-debug enable debug messages to stdout (default=no)],
diff --git a/sys-fs/lufs/lufs-0.9.7-r3.ebuild b/sys-fs/lufs/lufs-0.9.7-r3.ebuild
new file mode 100644
index 00000000000..07d107b75c0
--- /dev/null
+++ b/sys-fs/lufs/lufs-0.9.7-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="User-mode filesystem implementation"
+HOMEPAGE="http://sourceforge.net/projects/lufs/"
+SRC_URI="mirror://sourceforge/lufs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~amd64"
+IUSE="debug"
+
+RDEPEND="sys-fs/lufis"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-fPIC.patch
+ epatch "${FILESDIR}"/lufs-automount-port.diff
+ epatch "${FILESDIR}"/${P}-enable-gnome-2.patch
+ epatch "${FILESDIR}"/lufs-no-kernel.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+
+ filesystems="ftpfs localfs"
+ use amd64 || filesystems+=" sshfs"
+
+ eautoreconf
+}
+
+src_compile() {
+ einfo "Compiling for ${filesystems}"
+ unset ARCH
+ econf $(use_enable debug) || die
+
+ cd filesystems
+ local i
+ for i in ${filesystems} ; do
+ cd ${i}
+ emake || die "emake ${i} failed"
+ cd ..
+ done
+}
+
+src_install() {
+ cd filesystems
+ local i
+ for i in ${filesystems} ; do
+ cd ${i}
+ emake DESTDIR="${D}" install || die "emake install ${i} failed"
+ cd ..
+ done
+}
+
+pkg_postinst() {
+ ewarn "Lufs Kernel support and lufsd,lufsmnt have been disabled in favour"
+ ewarn "of lufis, please use lufis to mount lufs-filesystems, eg:"
+ if use amd64; then
+ elog "# lufis fs=ftpfs,host=ftp.kernel.org /mnt/lufis/ -s"
+ else
+ elog "# lufis fs=sshfs,host=dev.gentoo.org,username=genstef /mnt/lufis/ -s"
+ fi
+ ewarn "If something does not work for you with this setup please"
+ ewarn "complain to bugs.gentoo.org"
+ einfo "Note: There is also the native sshfs-fuse implementation now"
+ use amd64 && ewarn "lufs-sshfs does not work on amd64 and is disabled there."
+}
diff --git a/sys-fs/lufs/metadata.xml b/sys-fs/lufs/metadata.xml
new file mode 100644
index 00000000000..65b57aa6ecc
--- /dev/null
+++ b/sys-fs/lufs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <upstream>
+ <remote-id type="sourceforge">lufs</remote-id>
+ </upstream>
+</pkgmetadata>