summaryrefslogtreecommitdiff
path: root/sys-fs/lvm2
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2016-01-04 20:55:40 -0600
committerDoug Goldstein <cardoe@gentoo.org>2016-01-04 20:56:08 -0600
commitf5a9734bbb67f004930c8bf8e03ad5e61a4c2d7f (patch)
treea5963a09996c1a96efadb28567819f66f8388c09 /sys-fs/lvm2
parent5e3dd682f73e207a12f3703d706c57886095cb23 (diff)
downloadgentoo-f5a9734bbb67f004930c8bf8e03ad5e61a4c2d7f.tar.gz
gentoo-f5a9734bbb67f004930c8bf8e03ad5e61a4c2d7f.tar.xz
sys-fs/lvm2: bump to fix lvmetad init script depend
In my previous bump I incorrectly left the hardcoded dependency on lvmetad so the lvm script still always depended on lvmetad. This fixes that and makes it truly dynamic and adds instructions so that people can ensure their next boot works properly. Package-Manager: portage-2.2.26 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/files/lvm.rc-2.02.116-r4 (renamed from sys-fs/lvm2/files/lvm.rc-2.02.116-r3)3
-rw-r--r--sys-fs/lvm2/lvm2-2.02.116-r4.ebuild (renamed from sys-fs/lvm2/lvm2-2.02.116-r3.ebuild)8
2 files changed, 7 insertions, 4 deletions
diff --git a/sys-fs/lvm2/files/lvm.rc-2.02.116-r3 b/sys-fs/lvm2/files/lvm.rc-2.02.116-r4
index 059e8805a35..8478c239f8f 100644
--- a/sys-fs/lvm2/files/lvm.rc-2.02.116-r3
+++ b/sys-fs/lvm2/files/lvm.rc-2.02.116-r4
@@ -21,7 +21,6 @@ _need_lvmetad()
depend() {
before checkfs fsck
after modules device-mapper
- need lvmetad sysfs
# We may use lvmetad based on the configuration. If we added lvmetad
# support while lvm2 is running then we aren't dependent on it. For the
# more common case, if its disabled in the config we aren't dependent
@@ -35,7 +34,7 @@ depend() {
_need="${_need} lvmetad"
fi
fi
- need ${_need}
+ need sysfs ${_need}
}
config='global { locking_dir = "/run/lock/lvm" }'
diff --git a/sys-fs/lvm2/lvm2-2.02.116-r3.ebuild b/sys-fs/lvm2/lvm2-2.02.116-r4.ebuild
index bbb4279c222..5d54576bb18 100644
--- a/sys-fs/lvm2/lvm2-2.02.116-r3.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.116-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -230,7 +230,7 @@ src_install() {
if use !device-mapper-only ; then
newinitd "${FILESDIR}"/dmeventd.initd-2.02.67-r1 dmeventd
- newinitd "${FILESDIR}"/lvm.rc-2.02.116-r3 lvm
+ newinitd "${FILESDIR}"/lvm.rc-2.02.116-r4 lvm
newconfd "${FILESDIR}"/lvm.confd-2.02.28-r2 lvm
newinitd "${FILESDIR}"/lvm-monitoring.initd-2.02.105-r2 lvm-monitoring
@@ -270,6 +270,10 @@ pkg_postinst() {
ewarn
ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
ewarn "to enable lvm autoactivation and metadata caching."
+ ewarn
+ ewarn "After enabling or disabling lvmetad in /etc/lvm/lvm.conf you must"
+ ewarn "run the following to update the init script dependencies: "
+ ewarn "# rc-update -u"
}
src_test() {