summaryrefslogtreecommitdiff
path: root/sys-fs/rarfs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/rarfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/rarfs')
-rw-r--r--sys-fs/rarfs/Manifest1
-rw-r--r--sys-fs/rarfs/metadata.xml11
-rw-r--r--sys-fs/rarfs/rarfs-0.1.1.ebuild38
3 files changed, 50 insertions, 0 deletions
diff --git a/sys-fs/rarfs/Manifest b/sys-fs/rarfs/Manifest
new file mode 100644
index 00000000000..5a20627b191
--- /dev/null
+++ b/sys-fs/rarfs/Manifest
@@ -0,0 +1 @@
+DIST rarfs-0.1.1.tar.gz 349283 SHA256 e4855ab457e0be327641fc5aed958da3a06996425de4183055f2aad428ff0c1c SHA512 a374dc2dcd83808296dc0b0b3109fd84771d47956cc30fa16ac53cc768ae5ff717cff2fa22ebcbacdd72b645b75986c5d44e47aa1a52a92f230f1944ceaa8b28 WHIRLPOOL 8f1c613ad0b70aac85c3533b79b5e8599a3765d4e60633b294c307481dedcb5b91b6a30bce40429b153896f2f5e80105554d19fec813f5231fd505ad6611d70f
diff --git a/sys-fs/rarfs/metadata.xml b/sys-fs/rarfs/metadata.xml
new file mode 100644
index 00000000000..5c1e2c8b685
--- /dev/null
+++ b/sys-fs/rarfs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">rarfs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/rarfs/rarfs-0.1.1.ebuild b/sys-fs/rarfs/rarfs-0.1.1.ebuild
new file mode 100644
index 00000000000..e663922d38f
--- /dev/null
+++ b/sys-fs/rarfs/rarfs-0.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit python
+
+DESCRIPTION="Fuse module to mount uncompressed RAR archives"
+HOMEPAGE="http://sourceforge.net/projects/rarfs/"
+SRC_URI="mirror://sourceforge/rarfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/fuse"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+
+src_install() {
+ install_prarfs() {
+ python_convert_shebangs -q ${PYTHON_ABI} scripts/prarfs
+ newbin scripts/prarfs prarfs-${PYTHON_ABI}
+ }
+ python_execute_function -q install_prarfs
+ python_generate_wrapper_scripts "${ED}/usr/bin/prarfs"
+
+ dobin src/rarfs
+ dodoc ${DOCS[@]}
+}