summaryrefslogtreecommitdiff
path: root/sys-fs/reiserfs-defrag
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/reiserfs-defrag
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/reiserfs-defrag')
-rw-r--r--sys-fs/reiserfs-defrag/Manifest2
-rw-r--r--sys-fs/reiserfs-defrag/metadata.xml16
-rw-r--r--sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.1.ebuild29
-rw-r--r--sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.2.ebuild25
4 files changed, 72 insertions, 0 deletions
diff --git a/sys-fs/reiserfs-defrag/Manifest b/sys-fs/reiserfs-defrag/Manifest
new file mode 100644
index 00000000000..1fc56bbeccb
--- /dev/null
+++ b/sys-fs/reiserfs-defrag/Manifest
@@ -0,0 +1,2 @@
+DIST reiserfs-defrag-0.2.1.tar.gz 48556 SHA256 eca38a4a0e7268bcf76f51e8d0d48e46213aa86105f20398769da9ab75d278ce SHA512 ba0959d74659df9956a930724024c3cbba4cac93275fdf3707333f38c5c0f07e17420b07387e52e7533ed17ddd8fc9fec7ce0e8a553e888109badbb64bedb737 WHIRLPOOL 8bbee9eced591324dfe9dd4aafdfd2df00c18a53136887ed3cb3a935dc9e19eb107ac8739cef5107c7c3b91d556d7e293790bac4ae5507dc260eb1fec8458248
+DIST reiserfs-defrag-0.2.2.tar.gz 52988 SHA256 28fc7fe7373fab0e90f74acaf2fbfcf2578f7b04eeadcecb50f88bee2b67e718 SHA512 1e8dfb085a7635eda92bb820d3089b8ca2101fb00ede971b8de24018250a2238067e8db4e5f52b3d3aca2c45c8a395ae6687ce762d355e814697faef8ff59025 WHIRLPOOL 20699c5cff706ed8177aabf2d70b61acd46c6316d11dd4b110b3ced854db7950d7443008ad445e168222773f5bd9666a103cddf0cc3bcc65548d3b5a58f1009e
diff --git a/sys-fs/reiserfs-defrag/metadata.xml b/sys-fs/reiserfs-defrag/metadata.xml
new file mode 100644
index 00000000000..0be16b34138
--- /dev/null
+++ b/sys-fs/reiserfs-defrag/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>ibragimovrinat@mail.ru</email>
+ <name>Rinat Ibragimov</name>
+ </maintainer>
+ <bugs-to>https://github.com/i-rinat/reiserfs-defrag/issues</bugs-to>
+ <remote-id type="github">i-rinat/reiserfs-defrag</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.1.ebuild b/sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.1.ebuild
new file mode 100644
index 00000000000..51eb987cba0
--- /dev/null
+++ b/sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Small defragmentation tool for reiserfs"
+HOMEPAGE="https://github.com/i-rinat/reiserfs-defrag"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc ChangeLog README.md
+}
+
+pkg_postinst() {
+ ewarn "Defragmentation should be done OFFLINE only! You MUST unmount your reiserfs partition before starting ${PN}"
+}
diff --git a/sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.2.ebuild b/sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.2.ebuild
new file mode 100644
index 00000000000..6a0cb564108
--- /dev/null
+++ b/sys-fs/reiserfs-defrag/reiserfs-defrag-0.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Small defragmentation tool for reiserfs"
+HOMEPAGE="https://github.com/i-rinat/reiserfs-defrag"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README.md )
+
+pkg_postinst() {
+ ewarn "Defragmentation should be done OFFLINE only! You MUST unmount your reiserfs partition before starting ${PN}"
+}