summaryrefslogtreecommitdiff
path: root/sys-fs/reiserfsprogs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-05 13:59:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-05 13:59:28 +0200
commit547624bfcfd063cea4c9b7bbabe508a086140f83 (patch)
treeb5610cd79586b4375d001a17c8de3818f40d9250 /sys-fs/reiserfsprogs
parentb87c75785966b17e6762c71b1a777e84d5f3eea2 (diff)
downloadgentoo-547624bfcfd063cea4c9b7bbabe508a086140f83.tar.gz
gentoo-547624bfcfd063cea4c9b7bbabe508a086140f83.tar.xz
sys-fs/reiserfsprogs: Don't include sys/acl.h (bug #585978).
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-fs/reiserfsprogs')
-rw-r--r--sys-fs/reiserfsprogs/files/reiserfsprogs-3.6.25-no_acl.patch12
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild18
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.26.ebuild7
3 files changed, 32 insertions, 5 deletions
diff --git a/sys-fs/reiserfsprogs/files/reiserfsprogs-3.6.25-no_acl.patch b/sys-fs/reiserfsprogs/files/reiserfsprogs-3.6.25-no_acl.patch
new file mode 100644
index 00000000000..6a3768154cb
--- /dev/null
+++ b/sys-fs/reiserfsprogs/files/reiserfsprogs-3.6.25-no_acl.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/585978
+
+--- a/reiserfscore/xattr.c
++++ b/reiserfscore/xattr.c
+@@ -1,7 +1,6 @@
+ #include <sys/types.h>
+ #include <stdio.h>
+ #include <errno.h>
+-#include <sys/acl.h>
+ #include "reiserfs_lib.h"
+
+ static inline unsigned short from32to16(unsigned int x)
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild
index 04cc6a0dd02..e5bc6dfa203 100644
--- a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.25.ebuild
@@ -15,13 +15,23 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc64 -sparc x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.6.25-no_acl.patch"
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
src_configure() {
append-flags -std=gnu89 #427300
- econf \
- --bindir="${EPREFIX}/bin" \
- --libdir="${EPREFIX}/$(get_libdir)" \
- --sbindir="${EPREFIX}/sbin" \
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --libdir="${EPREFIX}/$(get_libdir)"
+ --sbindir="${EPREFIX}/sbin"
$(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.26.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.26.ebuild
index 0704720cc94..d6725dee34e 100644
--- a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.26.ebuild
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.26.ebuild
@@ -15,13 +15,18 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.6.25-no_acl.patch"
+)
+
src_prepare() {
+ epatch "${PATCHES[@]}"
eautoreconf
}
src_configure() {
append-flags -std=gnu89 #427300
- myeconfargs=(
+ local myeconfargs=(
--bindir="${EPREFIX}/bin"
--libdir="${EPREFIX}/$(get_libdir)"
--sbindir="${EPREFIX}/sbin"