summaryrefslogtreecommitdiff
path: root/sys-fs/squashfuse
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/squashfuse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/squashfuse')
-rw-r--r--sys-fs/squashfuse/Manifest1
-rw-r--r--sys-fs/squashfuse/metadata.xml14
-rw-r--r--sys-fs/squashfuse/squashfuse-0.1_p20130530.ebuild45
3 files changed, 60 insertions, 0 deletions
diff --git a/sys-fs/squashfuse/Manifest b/sys-fs/squashfuse/Manifest
new file mode 100644
index 00000000000..6bf6392c6e4
--- /dev/null
+++ b/sys-fs/squashfuse/Manifest
@@ -0,0 +1 @@
+DIST squashfuse-0.1_p20130530.zip 70224 SHA256 821c2e3ea484315f27b424326a7488c8880a64ab5d212774864dcb0b5d95675d SHA512 1e2ba5a61cdc5eac3fcf13d5d2a55d0656ac247b057f7cff9ef5365eb59f52fa6159cd2ea73475627e62f53fab72c5d12819161e794c683d53059f7667a774f0 WHIRLPOOL 0d07722d4d7f22e4d2dc68b0eedbaf9f3d4d09a6eeaac31bd3956996e73842750f056eb88a1ba68bd4fb8584714913c09a0550180c31bd2ec182bb1901beac73
diff --git a/sys-fs/squashfuse/metadata.xml b/sys-fs/squashfuse/metadata.xml
new file mode 100644
index 00000000000..582c3386d1d
--- /dev/null
+++ b/sys-fs/squashfuse/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <bugs-to>mailto:dave@vasilevsky.ca</bugs-to>
+ <changelog>https://github.com/vasi/squashfuse/commits/master</changelog>
+ <doc>https://raw.github.com/vasi/squashfuse/master/README</doc>
+ <remote-id type="github">vasi/squashfuse</remote-id>
+ </upstream>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-fs/squashfuse/squashfuse-0.1_p20130530.ebuild b/sys-fs/squashfuse/squashfuse-0.1_p20130530.ebuild
new file mode 100644
index 00000000000..08b8d0c72d0
--- /dev/null
+++ b/sys-fs/squashfuse/squashfuse-0.1_p20130530.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools
+
+DESCRIPTION="FUSE filesystem to mount squashfs archives"
+HOMEPAGE="https://github.com/vasi/squashfuse"
+EGIT_COMMIT="f03158f49cb4adbb6459cb2a1898e586b488cb10"
+SRC_URI="https://github.com/vasi/squashfuse/archive/${EGIT_COMMIT}.zip -> ${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="lzma lzo +zlib"
+REQUIRED_USE="|| ( lzma zlib lzo )"
+
+COMMON_DEPEND="
+ >=sys-fs/fuse-2.8.6:=
+ lzma? ( >=app-arch/xz-utils-5.0.4:= )
+ zlib? ( >=sys-libs/zlib-1.2.5-r2:= )
+ lzo? ( >=dev-libs/lzo-2.06:= )
+"
+DEPEND="app-arch/unzip
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ mv ${PN}-${EGIT_COMMIT}/* ./ || die
+}
+
+src_prepare() {
+ sed -i -e "1s:\\[0\\.1\\]:[${PV}]:" configure.ac || die
+ AT_M4DIR=${S}/m4 eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use lzma || echo --without-xz) \
+ $(use lzo || echo --without-lzo) \
+ $(use zlib || echo --without-zlib)
+}