summaryrefslogtreecommitdiff
path: root/sys-fs/ufsutils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/ufsutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/ufsutils')
-rw-r--r--sys-fs/ufsutils/Manifest2
-rw-r--r--sys-fs/ufsutils/metadata.xml5
-rw-r--r--sys-fs/ufsutils/ufsutils-8.2_p3.ebuild47
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-fs/ufsutils/Manifest b/sys-fs/ufsutils/Manifest
new file mode 100644
index 00000000000..31b41db833d
--- /dev/null
+++ b/sys-fs/ufsutils/Manifest
@@ -0,0 +1,2 @@
+DIST ufsutils_8.2-3.debian.tar.gz 23469 SHA256 6040ad18ddbf9fa37b87b084fe6cf19c50f63456d15b6726067c558f8383b795 SHA512 7bc925e742eaf4e1837ca4b46afa7966490234492eeb40ad8fabf71550a79890f3294780c2dbdf3593a82fc8e0708cf4c72baba81f4fec9a884cfa545c8895c8 WHIRLPOOL eb161eebfa50316283813cf774f701d24bdc718db268e541f564e8a93e7486eb060138c53fa1ed78bcbe3485457a59b6b9e17ca7309743805df864b215606faf
+DIST ufsutils_8.2.orig.tar.gz 463499 SHA256 6298d2a94fb601f6951bf81ce074e6af597e8867ac210d8ff73348aeb3738bd9 SHA512 f378372c2493c16fe8cb3977f4ed2d104e747895e97d7642d21b5e87a2a03ac696bbac093e534e13c2f1dc4638741edcbbb0ddec5abcbfa6b4f7401efbf7cf14 WHIRLPOOL ae944c34162727d37a3ea9ff63876ed75f55830c655b6a15afbf8d29bc4bd362cf76b07e8c2521ea42b1440247c5be3d290c4f310593aa8fa0dc950c2dd65e54
diff --git a/sys-fs/ufsutils/metadata.xml b/sys-fs/ufsutils/metadata.xml
new file mode 100644
index 00000000000..ecedda4aa2c
--- /dev/null
+++ b/sys-fs/ufsutils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>bsd</herd>
+</pkgmetadata>
diff --git a/sys-fs/ufsutils/ufsutils-8.2_p3.ebuild b/sys-fs/ufsutils/ufsutils-8.2_p3.ebuild
new file mode 100644
index 00000000000..ede8bde27a2
--- /dev/null
+++ b/sys-fs/ufsutils/ufsutils-8.2_p3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="FFS/UFS/UFS2 filesystem utilities from FreeBSD"
+HOMEPAGE="http://packages.debian.org/source/sid/ufsutils"
+
+SRC_URI="mirror://debian/pool/main/u/${PN}/${PN}_${PV%_*}.orig.tar.gz
+ mirror://debian/pool/main/u/${PN}/${PN}_${PV%_*}-${PV##*_p}.debian.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-libs/libbsd
+ dev-libs/libedit
+ sys-libs/ncurses"
+
+S="${WORKDIR}/${P%_*}"
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}/debian/patches" EPATCH_SUFFIX="patch" \
+ EPATCH_OPTS="-p1" EPATCH_FORCE="yes" epatch
+
+ # growfs is not properly ported
+ sed -e "s:sbin/growfs::" -i Makefile
+
+ sed -e "s:^\(prefix = \)\(.*\):\1${EPREFIX}usr:" \
+ -e "s:^\(libdir = \$(exec_prefix)\/\)\(.*\):\1$(get_libdir):" \
+ -i Makefile.common
+}
+
+src_compile(){
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)
+ dodir /usr/sbin
+ dodir /usr/share/man/man8
+ emake DESTDIR="${ED}" install
+}