summaryrefslogtreecommitdiff
path: root/sys-fs/yaffs2utils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/yaffs2utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/yaffs2utils')
-rw-r--r--sys-fs/yaffs2utils/Manifest1
-rw-r--r--sys-fs/yaffs2utils/files/yaffs2utils-0.2.9-build.patch47
-rw-r--r--sys-fs/yaffs2utils/files/yaffs2utils-0.2.9-unyaffs2-pointer.patch13
-rw-r--r--sys-fs/yaffs2utils/metadata.xml5
-rw-r--r--sys-fs/yaffs2utils/yaffs2utils-0.2.9.ebuild32
5 files changed, 98 insertions, 0 deletions
diff --git a/sys-fs/yaffs2utils/Manifest b/sys-fs/yaffs2utils/Manifest
new file mode 100644
index 00000000000..99fe950b0e0
--- /dev/null
+++ b/sys-fs/yaffs2utils/Manifest
@@ -0,0 +1 @@
+DIST yaffs2utils-0.2.9.tar.gz 39689 SHA256 9b0912bf683eb839b6e57c9255c83894c3b700d16489a49d319c54c1abf8f6d7 SHA512 001a2452515f750bdb2251feebfe20c4f1b716b3c850e13646ee054f8e607c18ecfc2781a2f3e1f288b8b32661b11fec8a87e88d8bd4a44c98cad4dbbffd489b WHIRLPOOL bb615f7994af6840950030c4e79cc78a109c3c03aac2efb3c177d3abe0d96af2e58655cb0a7a653817c6812033c3d877597a555bebcdd15b677c3debcac76879
diff --git a/sys-fs/yaffs2utils/files/yaffs2utils-0.2.9-build.patch b/sys-fs/yaffs2utils/files/yaffs2utils-0.2.9-build.patch
new file mode 100644
index 00000000000..c16d4de141e
--- /dev/null
+++ b/sys-fs/yaffs2utils/files/yaffs2utils-0.2.9-build.patch
@@ -0,0 +1,47 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,21 +18,15 @@
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ #
+
+-CROSS =
+-CC = $(CROSS)gcc
+
+-CFLAGS = -I. -I./yaffs2
+-CFLAGS += -O2
+-CFLAGS += -Wall -Wshadow -Winline -Wpointer-arith -Wnested-externs \
+- -Wwrite-strings -Wstrict-prototypes -Wmissing-declarations \
+- -Wmissing-prototypes -Wredundant-decls
++CPPFLAGS += -I. -I./yaffs2
+
+-CFLAGS += -D_HAVE_MMAP
++CPPFLAGS += -D_HAVE_MMAP
+
+ #CFLAGS += -D_MKYAFFS2_DEBUG
+ #CFLAGS += -D_UNYAFFS2_DEBUG
+
+-LDFLAGS += -lm
++LDLIBS += -lm
+
+ YAFFS2SRCS = yaffs2/yaffs_hweight.c yaffs2/yaffs_ecc.c \
+ yaffs2/yaffs_packedtags1.c yaffs2/yaffs_packedtags2.c
+@@ -60,14 +54,16 @@ all: $(TARGET)
+ install:
+ cp $(TARGET) $(INSTALLDIR)
+
++LINK = $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LDLIBS)
++
+ mkyaffs2: $(YAFFS2OBJS) $(LIBOBJS) $(MKYAFFS2OBJS)
+- $(CC) -o $@ $(YAFFS2OBJS) $(LIBOBJS) $(MKYAFFS2OBJS) $(LDFLAGS)
++ $(LINK)
+
+ unyaffs2: $(YAFFS2OBJS) $(LIBOBJS) $(UNYAFFS2OBJS)
+- $(CC) -o $@ $(YAFFS2OBJS) $(LIBOBJS) $(UNYAFFS2OBJS) $(LDFLAGS)
++ $(LINK)
+
+ unspare2: $(YAFFS2OBJS) $(LIBOBJS) $(UNSPARE2OBJS)
+- $(CC) -o $@ $(YAFFS2OBJS) $(LIBOBJS) $(UNSPARE2OBJS) $(LDFLAGS)
++ $(LINK)
+
+ clean:
+ rm -rf $(YAFFS2OBJS) $(LIBOBJS) \
diff --git a/sys-fs/yaffs2utils/files/yaffs2utils-0.2.9-unyaffs2-pointer.patch b/sys-fs/yaffs2utils/files/yaffs2utils-0.2.9-unyaffs2-pointer.patch
new file mode 100644
index 00000000000..3730ab41248
--- /dev/null
+++ b/sys-fs/yaffs2utils/files/yaffs2utils-0.2.9-unyaffs2-pointer.patch
@@ -0,0 +1,13 @@
+https://code.google.com/p/yaffs2utils/issues/detail?id=42
+
+--- a/unyaffs2.c
++++ b/unyaffs2.c
+@@ -1102,7 +1102,7 @@ unyaffs2_extract_hardlink (const char *fpath, struct unyaffs2_obj *obj)
+ char *lnkfile;
+
+ struct unyaffs2_obj *equiv;
+- union unyaffs2_file_variant *variant;
++ union unyaffs2_file_variant variant;
+
+ equiv = unyaffs2_follow_hardlink(obj);
+ if (equiv == NULL) {
diff --git a/sys-fs/yaffs2utils/metadata.xml b/sys-fs/yaffs2utils/metadata.xml
new file mode 100644
index 00000000000..5c40e771595
--- /dev/null
+++ b/sys-fs/yaffs2utils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>embedded</herd>
+</pkgmetadata>
diff --git a/sys-fs/yaffs2utils/yaffs2utils-0.2.9.ebuild b/sys-fs/yaffs2utils/yaffs2utils-0.2.9.ebuild
new file mode 100644
index 00000000000..dbc6c8acfeb
--- /dev/null
+++ b/sys-fs/yaffs2utils/yaffs2utils-0.2.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="tools for generating YAFFS images"
+HOMEPAGE="http://code.google.com/p/yaffs2utils/"
+SRC_URI="https://yaffs2utils.googlecode.com/files/0.2.9.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-unyaffs2-pointer.patch
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin unspare2 mkyaffs2 unyaffs2
+ dodoc CHANGES README
+}