summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-04-02 20:07:51 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-19 15:14:34 +0200
commitda09ac44fb20dff40323d47197ad93e8e400227e (patch)
tree1b3791f6a9dbe18c4e5c9fea5a327883bc0d27f4 /sys-fs
parent93837aa48ab90e32e6f0594e1c185cf525047221 (diff)
downloadgentoo-da09ac44fb20dff40323d47197ad93e8e400227e.tar.gz
gentoo-da09ac44fb20dff40323d47197ad93e8e400227e.tar.xz
sys-fs/tmsu: new ebuild
Closes: https://github.com/gentoo/gentoo/pull/4347 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/tmsu/Manifest1
-rw-r--r--sys-fs/tmsu/metadata.xml21
-rw-r--r--sys-fs/tmsu/tmsu-0.6.1.ebuild41
3 files changed, 63 insertions, 0 deletions
diff --git a/sys-fs/tmsu/Manifest b/sys-fs/tmsu/Manifest
new file mode 100644
index 00000000000..c909ea38cc3
--- /dev/null
+++ b/sys-fs/tmsu/Manifest
@@ -0,0 +1 @@
+DIST tmsu-0.6.1.tar.gz 92874 SHA256 00483d9ca12cb868e9587207556a8293bd43ee5a2993a6fe9f0c93edef918a7f SHA512 53bc9d880f9138e9d88b25a151f72a5a3110418002c2a1a6101d2794c0b6fd854ebd52e589f3b1ffa18f1b5c2f2298550246fc6cb1bfebbfd0131692c2fa5512 WHIRLPOOL 3f5de7d6935464b2bef84408146e2458048e51fbfd63a88055ba560c738c4d24fade4484be44729187d06a5a2af407d4fd7c7fbb1b24731f8a78b743825f05a7
diff --git a/sys-fs/tmsu/metadata.xml b/sys-fs/tmsu/metadata.xml
new file mode 100644
index 00000000000..06bdd804eaf
--- /dev/null
+++ b/sys-fs/tmsu/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ TMSU is a tool for tagging your files. It provides a simple
+ command-line utility for applying tags and a virtual
+ filesystem to give you a tag-based view of your files from
+ any other program.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">oniony/TMSU</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/tmsu/tmsu-0.6.1.ebuild b/sys-fs/tmsu/tmsu-0.6.1.ebuild
new file mode 100644
index 00000000000..d37b3371128
--- /dev/null
+++ b/sys-fs/tmsu/tmsu-0.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_PN="github.com/oniony/TMSU/"
+DESCRIPTION="Files tagger and virtual tag-based filesystem"
+HOMEPAGE="https://github.com/oniony/TMSU/wiki"
+SRC_URI="https://github.com/oniony/TMSU/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test zsh-completion"
+
+RDEPEND="
+ zsh-completion? ( app-shells/zsh )
+"
+DEPEND="
+ dev-go/go-sqlite3
+ dev-lang/go
+ dev-libs/go-fuse
+"
+
+src_unpack() {
+ default
+ mv TMSU-${PV} ${P} || die "Failed to move sorce directory."
+}
+
+src_install() {
+ dobin misc/bin/*
+ doman misc/man/tmsu.*
+ newbin TMSU tmsu
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/zsh/_tmsu
+ fi
+}