summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-05-05 02:35:07 +0200
committerRobin H. Johnson <robbat2@gentoo.org>2018-05-08 10:11:05 -0700
commitda222eb668e9d0743688b0bd1608fd0824b1b8b1 (patch)
tree05ee379fcd28ad3328ceac438c97c087b72297ba /sys-fs
parent1ec1595e6328e5f68dd1ce669e2841e052360c55 (diff)
downloadgentoo-da222eb668e9d0743688b0bd1608fd0824b1b8b1.tar.gz
gentoo-da222eb668e9d0743688b0bd1608fd0824b1b8b1.tar.xz
sys-fs/lvm2-2.02.17{1,2,3}: Fix static build
Closes: https://bugs.gentoo.org/617756 Package-Manager: Portage-2.3.35, Repoman-2.3.9 (cherry picked from commit 0d57a354c5b3ab9db2b8e2ea6adbdad2dd6a1c03) Closes: https://github.com/gentoo/gentoo/pull/8265 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/files/lvm2-2.02.171-static-libm.patch13
-rw-r--r--sys-fs/lvm2/lvm2-2.02.171.ebuild3
-rw-r--r--sys-fs/lvm2/lvm2-2.02.172.ebuild3
-rw-r--r--sys-fs/lvm2/lvm2-2.02.173.ebuild3
4 files changed, 19 insertions, 3 deletions
diff --git a/sys-fs/lvm2/files/lvm2-2.02.171-static-libm.patch b/sys-fs/lvm2/files/lvm2-2.02.171-static-libm.patch
new file mode 100644
index 00000000000..1cbf956db25
--- /dev/null
+++ b/sys-fs/lvm2/files/lvm2-2.02.171-static-libm.patch
@@ -0,0 +1,13 @@
+diff --git a/make.tmpl.in b/make.tmpl.in
+index a40eaaa15..7eea943aa 100644
+--- a/make.tmpl.in
++++ b/make.tmpl.in
+@@ -53,7 +53,7 @@ PYCOMPILE = $(top_srcdir)/autoconf/py-compile
+
+ LIBS = @LIBS@
+ # Extra libraries always linked with static binaries
+-STATIC_LIBS = $(SELINUX_STATIC_LIBS) $(UDEV_STATIC_LIBS) $(BLKID_STATIC_LIBS)
++STATIC_LIBS = $(SELINUX_STATIC_LIBS) $(UDEV_STATIC_LIBS) $(BLKID_STATIC_LIBS) $(M_LIBS)
+ DEFS += @DEFS@
+ # FIXME set this only where it's needed, not globally?
+ CFLAGS ?= @COPTIMISE_FLAG@ @CFLAGS@
diff --git a/sys-fs/lvm2/lvm2-2.02.171.ebuild b/sys-fs/lvm2/lvm2-2.02.171.ebuild
index 63f12d1d8cd..fccd403cbc9 100644
--- a/sys-fs/lvm2/lvm2-2.02.171.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.171.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -66,6 +66,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.02.99-locale-muck.patch #330373
"${FILESDIR}"/${PN}-2.02.70-asneeded.patch # -Wl,--as-needed
"${FILESDIR}"/${PN}-2.02.139-dynamic-static-ldflags.patch #332905
+ "${FILESDIR}"/${PN}-2.02.171-static-libm.patch #617756
"${FILESDIR}"/${PN}-2.02.129-static-pkgconfig-libs.patch #370217, #439414 + blkid
"${FILESDIR}"/${PN}-2.02.130-pthread-pkgconfig.patch #492450
#"${FILESDIR}"/${PN}-2.02.145-mkdev.patch #580062 # Merged upstream
diff --git a/sys-fs/lvm2/lvm2-2.02.172.ebuild b/sys-fs/lvm2/lvm2-2.02.172.ebuild
index 4c21fcf3446..0d9e8e6dc47 100644
--- a/sys-fs/lvm2/lvm2-2.02.172.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.172.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -66,6 +66,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.02.99-locale-muck.patch #330373
"${FILESDIR}"/${PN}-2.02.70-asneeded.patch # -Wl,--as-needed
"${FILESDIR}"/${PN}-2.02.139-dynamic-static-ldflags.patch #332905
+ "${FILESDIR}"/${PN}-2.02.171-static-libm.patch #617756
"${FILESDIR}"/${PN}-2.02.172-static-pkgconfig-libs.patch #370217, #439414 + blkid
"${FILESDIR}"/${PN}-2.02.130-pthread-pkgconfig.patch #492450
#"${FILESDIR}"/${PN}-2.02.145-mkdev.patch #580062 # Merged upstream
diff --git a/sys-fs/lvm2/lvm2-2.02.173.ebuild b/sys-fs/lvm2/lvm2-2.02.173.ebuild
index 4c21fcf3446..0d9e8e6dc47 100644
--- a/sys-fs/lvm2/lvm2-2.02.173.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.173.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -66,6 +66,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.02.99-locale-muck.patch #330373
"${FILESDIR}"/${PN}-2.02.70-asneeded.patch # -Wl,--as-needed
"${FILESDIR}"/${PN}-2.02.139-dynamic-static-ldflags.patch #332905
+ "${FILESDIR}"/${PN}-2.02.171-static-libm.patch #617756
"${FILESDIR}"/${PN}-2.02.172-static-pkgconfig-libs.patch #370217, #439414 + blkid
"${FILESDIR}"/${PN}-2.02.130-pthread-pkgconfig.patch #492450
#"${FILESDIR}"/${PN}-2.02.145-mkdev.patch #580062 # Merged upstream