summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-13 14:29:58 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-13 14:40:40 -0400
commitfce1098ddbdcbbcb84bd34430de4bcad597cd8fc (patch)
tree136997c8fe6c274acdc8393c5e549fa40d2d92bf /sys-fs
parentab7c08d07012cc807a506a10625b44e9fcb1cc97 (diff)
downloadgentoo-fce1098ddbdcbbcb84bd34430de4bcad597cd8fc.tar.gz
gentoo-fce1098ddbdcbbcb84bd34430de4bcad597cd8fc.tar.xz
sys-fs/squashfs-tools: fix building w/newer glibc
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-4.3-sysmacros.patch25
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild4
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-sysmacros.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-sysmacros.patch
new file mode 100644
index 00000000000..1430b1a2ee0
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-sysmacros.patch
@@ -0,0 +1,25 @@
+sys/types.h might not always include sys/sysmacros.h for major/minor/makedev
+
+--- a/squashfs-tools/mksquashfs.c
++++ b/squashfs-tools/mksquashfs.c
+@@ -59,6 +59,7 @@
+ #else
+ #include <endian.h>
+ #include <sys/sysinfo.h>
++#include <sys/sysmacros.h>
+ #endif
+
+ #include "squashfs_fs.h"
+--- a/squashfs-tools/unsquashfs.c
++++ b/squashfs-tools/unsquashfs.c
+@@ -38,6 +38,10 @@
+ #include <limits.h>
+ #include <ctype.h>
+
++#ifdef linux
++#include <sys/sysmacros.h>
++#endif
++
+ struct cache *fragment_cache, *data_cache;
+ struct queue *to_reader, *to_inflate, *to_writer, *from_writer;
+ pthread_t *thread, *inflator_thread;
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild
index ae89fac4a29..fb5398a03ff 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.3.ebuild
@@ -27,6 +27,10 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/squashfs${PV}/${PN}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sysmacros.patch
+}
+
use10() { usex $1 1 2 ; }
src_configure() {