summaryrefslogtreecommitdiff
path: root/sys-kernel/git-sources
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2016-06-05 18:45:29 -0400
committerMike Pagano <mpagano@gentoo.org>2016-06-05 18:45:47 -0400
commitf9c6d7c99ca8fc8cce35956bb322341bbf57f0a4 (patch)
tree42ef50c79cc3389ebb62f03b7e91e061af0a4d68 /sys-kernel/git-sources
parentbcd92038135dae3fea3f1cdeb70674de3e4860ef (diff)
downloadgentoo-f9c6d7c99ca8fc8cce35956bb322341bbf57f0a4.tar.gz
gentoo-f9c6d7c99ca8fc8cce35956bb322341bbf57f0a4.tar.xz
sys-kernel/git-sources: Linux patch 4.7_rc2
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.7_rc2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 97d9d8e985d..3d5edef4218 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-4.6.tar.xz 89461728 SHA256 a93771cd5a8ad27798f22e9240538dfea48d3a2bf2a6a6ab415de3f02d25d866 SHA512 df5ee40b0ebd89914a900f63c32a481cb4f405d8f792b2d03ea167ce9c5bdf75154c7bd8ecd7ebac77a8dbf2b077c972cbfe6b95163e27c38c1fefc6ddbdfa0b WHIRLPOOL 50ee28a06930ffb29ade1aa5fb4e3bf165ead92cb660dc6771a265cdbc2240713ebf14fe235fa153d8b6e3ab853852ea06c2525209cd7989aa3d6f6fad5b7edf
DIST patch-4.7-rc1.xz 5372116 SHA256 113a5441c67316e27b3c90d6ee07edd5e6df4e943dd4f126fd994231320afd45 SHA512 b1028e3ab5772c2b87a576dceda9dc4fc543cc72710d8a249cff324d0774dcd97b1e2aa1895894d0e3190fe283345c36405a772c25b2c3be6f510dbff6de8b74 WHIRLPOOL 13f61237f9acf9c78c3aed260f1d9fbc041e01014b97ef05636b55b96fc473ad02eb7d225c393a55e7d0ac3cab548c84e619f8c2ffc45e4b8b01904e6f8a8ece
+DIST patch-4.7-rc2.xz 5421916 SHA256 d323fd8f7ad015a1f929a3c2ebd99067475d64311b69fe66089a9b1600fba7b0 SHA512 c9853d063dba5978ad963e98c980205780ad4e3634af1478caaa7e2e1880c54d7cde8c70cce3350a44bb9f7171d7405d994eebe03a9526b4363d228d9b2073a7 WHIRLPOOL 730f616cecbfcab73747888788a4c108dc4925cac0026e6003a8589376a0d74a9445fa5bac92550053dfbe3dd7c8bd199060d58019306b9f8c0158e293e33e77
diff --git a/sys-kernel/git-sources/git-sources-4.7_rc2.ebuild b/sys-kernel/git-sources/git-sources-4.7_rc2.ebuild
new file mode 100644
index 00000000000..d666eac1026
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.7_rc2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_BASE_VER="4.6"
+K_EXP_GENPATCHES_NOUSE="1"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}