summaryrefslogtreecommitdiff
path: root/sys-kernel/git-sources
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2015-11-23 09:06:12 -0500
committerMike Pagano <mpagano@gentoo.org>2015-11-23 09:06:12 -0500
commitfa0cefd5c3a900480ea9b986af1fc3778118e184 (patch)
treeb146de096b469ef7c1bb7fde08f6d43fda74c469 /sys-kernel/git-sources
parentecfc032db1e72db14342644a81c6edd310d1c4e9 (diff)
downloadgentoo-fa0cefd5c3a900480ea9b986af1fc3778118e184.tar.gz
gentoo-fa0cefd5c3a900480ea9b986af1fc3778118e184.tar.xz
sys-kernel/git-sources: Linux patch 4.4_rc2
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.4_rc2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index efd7f672efd..7812c0d98b3 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-4.3.tar.xz 86920812 SHA256 4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae SHA512 d25812043850530fdcfdb48523523ee980747f3c2c1266149330844dae2cba0d056d4ddd9c0f129f570f5d1f6df5c20385aec5f6a2e0755edc1e2f5f93e2c6bc WHIRLPOOL e3f131443acc14d4f67bbd3f4e1c57af3d822c41c85a112564d54667a591c8619dce42327fd8166d30a2d7adfaf433c2e2134d4995c91c08f65ac0cc2190f935
DIST patch-4.4-rc1.xz 6387896 SHA256 3870efdb5dfdbcb17d5a233e8e9c69156609825a3fb344b8f0fcecb92646360d SHA512 8012aa366ae77ab9bc17d66d1912908f18624c5a7803e7acbbe0cf3fe8633517a6dc12affb47a2c90fbbfb9acd762be511b01abc16650d8c7ac526896210005f WHIRLPOOL fc8d501aceb8f9b9957e37109fafe05f666300368c60d73686ab0f1e87a21f5e8a605f23abd063b7cdf6df9ae33ccd079d2aea811444a4c5938180dcb161947d
+DIST patch-4.4-rc2.xz 6472332 SHA256 04a2fe6ce8711a01617e459d6908bfbd7715a0e4106fbd05372e12ba7ad03158 SHA512 c4690fa99a3e2f48de8093c3ce68605e79fdb12dde2483a5f147c43fefaa5002153f50006599a2f0b59a014265dcaf4bf16925bcea674b9a82f0ddac2cdc88ae WHIRLPOOL 163b4beed95a8eb1f0068c7c2fcfa4a294fd35072dd6b48aaebc079e8720ec9aabd6fc06edd32bbd79ab28d0ba943851aa5abafd8c5a564f40dcd9ee1665f485
diff --git a/sys-kernel/git-sources/git-sources-4.4_rc2.ebuild b/sys-kernel/git-sources/git-sources-4.4_rc2.ebuild
new file mode 100644
index 00000000000..5b6ded7aad8
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.4_rc2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_BASE_VER="4.3"
+K_EXP_GENPATCHES_NOUSE="1"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}