summaryrefslogtreecommitdiff
path: root/sys-kernel
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2015-11-05 11:08:25 -0500
committerMike Pagano <mpagano@gentoo.org>2015-11-05 11:08:25 -0500
commiteb0a0187bf96cdaacc186ea5277602d789c6ff27 (patch)
tree114da715bc9ca29431c0e016b2704cdde94cb914 /sys-kernel
parent296866130232bd0aeed4bc8e5b8dc7efd2db4069 (diff)
downloadgentoo-eb0a0187bf96cdaacc186ea5277602d789c6ff27.tar.gz
gentoo-eb0a0187bf96cdaacc186ea5277602d789c6ff27.tar.xz
sys-kernel/linux-docs: Linux documentation for the 4.3 series.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-docs/Manifest1
-rw-r--r--sys-kernel/linux-docs/linux-docs-4.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/Manifest b/sys-kernel/linux-docs/Manifest
index 94d5bec56f4..0aaf612927a 100644
--- a/sys-kernel/linux-docs/Manifest
+++ b/sys-kernel/linux-docs/Manifest
@@ -4,3 +4,4 @@ DIST linux-3.14.22.tar.xz 78451580 SHA256 77a0c7a41b1fc4232a959c539e48f98071769c
DIST linux-3.16.6.tar.xz 80524980 SHA256 31e9dcffd79933040b8a91d36ac1d75fa4ad554656665c3d9c8fbd9fa73006f2 SHA512 ef850b73d28f3432d55389a251bf4244c464af52ff02ed87a5707ff4467932b7b8f12182017f73e73671ae893b44e17e4f4414b023848b8ba4869b1cd3ac6086 WHIRLPOOL a23c1503bdaf3ffe2bc1ea2351d2a0612d20f6d144d5a2d2595fc051ac2292da84d91053c64f4391b91bcc46edf0fe0bee49329ff8ca70beafc04e50e4c0571b
DIST linux-3.4.104.tar.xz 67176948 SHA256 8bf42d8befdd61a296546dfb626eca7c108b7c3eb0c284f4bd4273c628e1c275 SHA512 a8d86b0fa9bbb602262f8e4155870a5e33224597030d6b6777480ea81127564d9bf94389d8adb59c8e9cec2f586f59031968d33ec3b6b82c10e13924c303872b WHIRLPOOL 95cb16ceab4899689145385c5acbe4cf46682e9f5258dc99b6b890347c06aba903858a0fd98d9d34a264a9db46c54e9fa6da0821bb33bd3a2a3fb6a82ba7f451
DIST linux-4.1.4.tar.xz 83015496 SHA256 3ee2f2bdcb8ecf729fc7ed0545a6a2292f2853bd0eb259bc4124265a6ad4909f SHA512 a87b9692fe6f17c562c60a82640d26278ec6c6ce90c433b184162f216733e6a228ebb5a5d167e787bb260dcf90edc99413cf0e282744ed682539b171b1e616c3 WHIRLPOOL 666ed8c4cde164dd20264d49b4b3800a599ac020563c8181e5265639efe82406cb09663c86c83c228bdfc5d03b0364e058ac365c490cc0e066c49d42b0821967
+DIST linux-4.3.tar.xz 86920812 SHA256 4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae SHA512 d25812043850530fdcfdb48523523ee980747f3c2c1266149330844dae2cba0d056d4ddd9c0f129f570f5d1f6df5c20385aec5f6a2e0755edc1e2f5f93e2c6bc WHIRLPOOL e3f131443acc14d4f67bbd3f4e1c57af3d822c41c85a112564d54667a591c8619dce42327fd8166d30a2d7adfaf433c2e2134d4995c91c08f65ac0cc2190f935
diff --git a/sys-kernel/linux-docs/linux-docs-4.3.ebuild b/sys-kernel/linux-docs/linux-docs-4.3.ebuild
new file mode 100644
index 00000000000..21e5ba8e9b8
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-4.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="mirror://kernel/linux/kernel/v3.x/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE="html"
+DEPEND="app-text/docbook-sgml-utils
+ app-text/xmlto
+ sys-apps/sed
+ ~app-text/docbook-xml-dtd-4.1.2"
+RDEPEND=""
+
+src_prepare() {
+
+ sed -i \
+ -e "s:db2:docbook2:g" \
+ -e "s:/usr/local/man:${D}/usr/share/man:g" \
+ "${S}"/Documentation/DocBook/Makefile
+
+ # fix for parallel build as per bug #248337
+ sed -i \
+ -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
+ "${S}"/Makefile
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ emake mandocs || die "make mandocs failed"
+
+ if use html; then
+ emake htmldocs || die "make htmldocs failed"
+ fi
+}
+
+src_install() {
+ local file
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make installmandocs || die "make installmandocs failed"
+
+ if use html; then
+ # There is no subdirectory named "index"
+ dohtml Documentation/DocBook/index.html
+ rm Documentation/DocBook/index.html
+ for file in Documentation/DocBook/*.html; do
+ dohtml -r ${file/\.html/}
+ done
+ fi
+}