summaryrefslogtreecommitdiff
path: root/sys-libs/glibc
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-30 15:55:57 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-30 18:01:21 -0400
commit7998e81a4b5423a4501ee8faee05089c9f3df7c5 (patch)
treeabe8d8a8fb8e2e7279e9d64217a446ac2f240256 /sys-libs/glibc
parentf3a77a809fe55f649025718d9c335ac07b87387e (diff)
downloadgentoo-7998e81a4b5423a4501ee8faee05089c9f3df7c5.tar.gz
gentoo-7998e81a4b5423a4501ee8faee05089c9f3df7c5.tar.xz
sys-libs/glibc: add USE=rpc to control obsolete RPC/NIS APIs #381391 #576278
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/files/eblits/src_configure.eblit2
-rw-r--r--sys-libs/glibc/glibc-2.23.ebuild2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild2
-rw-r--r--sys-libs/glibc/metadata.xml1
4 files changed, 4 insertions, 3 deletions
diff --git a/sys-libs/glibc/files/eblits/src_configure.eblit b/sys-libs/glibc/files/eblits/src_configure.eblit
index 99964fbee98..41ba5ddf7ad 100644
--- a/sys-libs/glibc/files/eblits/src_configure.eblit
+++ b/sys-libs/glibc/files/eblits/src_configure.eblit
@@ -113,7 +113,7 @@ glibc_do_configure() {
--with-bugurl=http://bugs.gentoo.org/
--with-pkgversion="$(glibc_banner)"
$(use_multiarch || echo --disable-multi-arch)
- --enable-obsolete-rpc
+ $(in_iuse rpc && use_enable rpc obsolete-rpc || echo --enable-obsolete-rpc)
$(in_iuse systemtap && use_enable systemtap)
$(in_iuse nscd && use_enable nscd)
${EXTRA_ECONF}
diff --git a/sys-libs/glibc/glibc-2.23.ebuild b/sys-libs/glibc/glibc-2.23.ebuild
index a9d384a9b29..c8cb72a8145 100644
--- a/sys-libs/glibc/glibc-2.23.ebuild
+++ b/sys-libs/glibc/glibc-2.23.ebuild
@@ -30,7 +30,7 @@ GCC_BOOTSTRAP_VER="4.7.3-r1"
PATCH_VER="3" # Gentoo patchset
: ${NPTL_KERN_VER:="2.6.32"} # min kernel version nptl requires
-IUSE="debug gd hardened multilib nscd selinux systemtap profile suid vanilla crosscompile_opts_headers-only"
+IUSE="debug gd hardened multilib nscd +rpc selinux systemtap profile suid vanilla crosscompile_opts_headers-only"
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index d2b9c01ed96..3263afea861 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -30,7 +30,7 @@ GCC_BOOTSTRAP_VER="4.7.3-r1"
PATCH_VER="" # Gentoo patchset
: ${NPTL_KERN_VER:="2.6.32"} # min kernel version nptl requires
-IUSE="debug gd hardened multilib nscd selinux systemtap profile suid vanilla crosscompile_opts_headers-only"
+IUSE="debug gd hardened multilib nscd +rpc selinux systemtap profile suid vanilla crosscompile_opts_headers-only"
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
diff --git a/sys-libs/glibc/metadata.xml b/sys-libs/glibc/metadata.xml
index 4fdcae4d830..e6ebe220ca6 100644
--- a/sys-libs/glibc/metadata.xml
+++ b/sys-libs/glibc/metadata.xml
@@ -9,6 +9,7 @@
<flag name="debug">When USE=hardened, allow fortify/stack violations to dump core (SIGABRT) and not kill self (SIGKILL)</flag>
<flag name="gd">build memusage and memusagestat tools</flag>
<flag name="nscd">Build, and enable support for, the Name Service Cache Daemon</flag>
+ <flag name="rpc">Enable obsolete RPC/NIS layers (disabling is experimental -- see bug 381391)</flag>
<flag name="suid">Make internal pt_chown helper setuid -- not needed if using Linux and have /dev/pts mounted with gid=5</flag>
<flag name="systemtap">enable systemtap static probe points</flag>
</use>