summaryrefslogtreecommitdiff
path: root/sys-libs/libraw1394
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/libraw1394
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/libraw1394')
-rw-r--r--sys-libs/libraw1394/Manifest3
-rw-r--r--sys-libs/libraw1394/libraw1394-2.0.8.ebuild29
-rw-r--r--sys-libs/libraw1394/libraw1394-2.1.0-r1.ebuild22
-rw-r--r--sys-libs/libraw1394/libraw1394-2.1.1.ebuild22
-rw-r--r--sys-libs/libraw1394/metadata.xml5
5 files changed, 81 insertions, 0 deletions
diff --git a/sys-libs/libraw1394/Manifest b/sys-libs/libraw1394/Manifest
new file mode 100644
index 00000000000..4d8eed1a328
--- /dev/null
+++ b/sys-libs/libraw1394/Manifest
@@ -0,0 +1,3 @@
+DIST libraw1394-2.0.8.tar.xz 279060 SHA256 e8c2fa8860a3e4067d9342490842f63f2cde2015521092064ba383aa75104467 SHA512 92f83c1b005fd043a14b15779ca24204ff2da59798531a90db147d964c3b53328c5a7ff7834a624aa2c7913e0780c4d75283fe13f7cea6b2cd2cb4b14800551e WHIRLPOOL c815a2a8c3c4e330e6d4bc6ec09f8215af92c3aa8a3d7915a4b77cdbf85fa26eee65e980e02f181eea4525677db0826acdeb0060fa277c755e28a79e4ca08e5f
+DIST libraw1394-2.1.0.tar.xz 291456 SHA256 0b3126d8158d156de9da2ff4d861c47857acc4318a7ac260258015a22071964f SHA512 04295c2b4391b1c61cc1c65dbe5921f5e208bbb311104366d5756a82a6c53f1339c368fe76077318b22e2402fd8f679236606d0be4898728a9dba2d7a8989b9e WHIRLPOOL f89a4abe1a1c5a7c22a88e8d397f03e6fe2943af18d721ab87eace027b43fb899658beea9b94ea6909398aa6b14920da58cbf8a3934df18acc0b587102b50d02
+DIST libraw1394-2.1.1.tar.xz 309396 SHA256 1bab9780189f9d1eb4e973df12679c04f979c21e024240fc98e536ff5b680ee9 SHA512 ed6acf10e50593e6070764e57cb6cc0eabb6f2bc4b4ed805a55cdfc37109c1975eb597dfbef9b6f8bc73a9e9270e7d643956489f54682f4c670fa510ef726fbe WHIRLPOOL 10e075374855c03395cefb7357f055fafd223b91b7e89ed22d96d691a398d3371db580e38fd53718305a5b1f2708bd52bc55cf1ccedfa5e508bd6e64bc04f6ad
diff --git a/sys-libs/libraw1394/libraw1394-2.0.8.ebuild b/sys-libs/libraw1394/libraw1394-2.0.8.ebuild
new file mode 100644
index 00000000000..f09d6677e86
--- /dev/null
+++ b/sys-libs/libraw1394/libraw1394-2.0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="library that provides direct access to the IEEE 1394 bus"
+HOMEPAGE="http://ieee1394.wiki.kernel.org/"
+SRC_URI="mirror://kernel/linux/libs/ieee1394/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
+IUSE="static-libs"
+
+DEPEND="app-arch/xz-utils"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ econf \
+ --without-fw-dir \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/sys-libs/libraw1394/libraw1394-2.1.0-r1.ebuild b/sys-libs/libraw1394/libraw1394-2.1.0-r1.ebuild
new file mode 100644
index 00000000000..7cbb5128a9f
--- /dev/null
+++ b/sys-libs/libraw1394/libraw1394-2.1.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+inherit autotools-multilib
+
+DESCRIPTION="library that provides direct access to the IEEE 1394 bus"
+HOMEPAGE="http://ieee1394.wiki.kernel.org/"
+SRC_URI="mirror://kernel/linux/libs/ieee1394/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86"
+IUSE="static-libs"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r4
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
diff --git a/sys-libs/libraw1394/libraw1394-2.1.1.ebuild b/sys-libs/libraw1394/libraw1394-2.1.1.ebuild
new file mode 100644
index 00000000000..792bf6d0e17
--- /dev/null
+++ b/sys-libs/libraw1394/libraw1394-2.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+inherit autotools-multilib
+
+DESCRIPTION="library that provides direct access to the IEEE 1394 bus"
+HOMEPAGE="http://ieee1394.wiki.kernel.org/"
+SRC_URI="mirror://kernel/linux/libs/ieee1394/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r4
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
diff --git a/sys-libs/libraw1394/metadata.xml b/sys-libs/libraw1394/metadata.xml
new file mode 100644
index 00000000000..96a2d586367
--- /dev/null
+++ b/sys-libs/libraw1394/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>