summaryrefslogtreecommitdiff
path: root/sys-libs/librtas/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/librtas/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/librtas/files')
-rw-r--r--sys-libs/librtas/files/librtas-1.3.3-open.patch22
-rw-r--r--sys-libs/librtas/files/librtas-1.3.3-remove-doc.patch14
-rw-r--r--sys-libs/librtas/files/librtas-1.3.6-symlink.patch24
-rw-r--r--sys-libs/librtas/files/librtas-1.3.8-symlink.patch20
4 files changed, 80 insertions, 0 deletions
diff --git a/sys-libs/librtas/files/librtas-1.3.3-open.patch b/sys-libs/librtas/files/librtas-1.3.3-open.patch
new file mode 100644
index 00000000000..46bdede6efd
--- /dev/null
+++ b/sys-libs/librtas/files/librtas-1.3.3-open.patch
@@ -0,0 +1,22 @@
+--- librtas_src/syscall_rmo.bak 2010-02-01 10:38:01.000000000 -0500
++++ librtas-1.3.3/librtas_src/syscall_rmo.c 2010-02-01 10:38:25.000000000 -0500
+@@ -117,7 +117,7 @@
+
+ /* Lazily open lock file */
+ if (wa_config.lockfile_fd < 0) {
+- wa_config.lockfile_fd = open(lockfile_path, O_CREAT | O_RDWR);
++ wa_config.lockfile_fd = open(lockfile_path, O_CREAT | O_RDWR, 644);
+ if (wa_config.lockfile_fd < 0) {
+ dbg1("could not open lockfile %s\n", lockfile_path);
+ return RTAS_IO_ASSERT;
+--- librtas_src/common.bak 2010-02-01 10:37:34.000000000 -0500
++++ librtas-1.3.3/librtas_src/common.c 2010-02-01 10:37:50.000000000 -0500
+@@ -65,7 +65,7 @@
+ npaths = sizeof(proc_rtas_paths) / sizeof(char *);
+ for (i = 0; i < npaths; i++) {
+ sprintf(full_name, "%s/%s", proc_rtas_paths[i], name);
+- fd = open(full_name, mode);
++ fd = open(full_name, mode, 644);
+ if (fd >= 0)
+ break;
+ }
diff --git a/sys-libs/librtas/files/librtas-1.3.3-remove-doc.patch b/sys-libs/librtas/files/librtas-1.3.3-remove-doc.patch
new file mode 100644
index 00000000000..66d9aeaabeb
--- /dev/null
+++ b/sys-libs/librtas/files/librtas-1.3.3-remove-doc.patch
@@ -0,0 +1,14 @@
+--- librtas-1.3.3.orig/Makefile 2007-04-12 15:01:01.000000000 -0500
++++ librtas-1.3.3/Makefile 2007-05-29 11:55:54.000000000 -0500
+@@ -15,11 +15,9 @@
+ @$(foreach d,$(SUBDIRS), $(MAKE) -C $d;)
+
+ install:
+- @$(call install_doc,$(FILES),$(DESTDIR))
+ @$(foreach d,$(SUBDIRS), $(MAKE) -C $d install;)
+
+ uninstall:
+- @$(call uninstall_doc,$(FILES),$(DESTDIR))
+ @$(foreach d,$(SUBDIRS), $(MAKE) -C $d uninstall;)
+
+ rpm: all
diff --git a/sys-libs/librtas/files/librtas-1.3.6-symlink.patch b/sys-libs/librtas/files/librtas-1.3.6-symlink.patch
new file mode 100644
index 00000000000..f9536f42749
--- /dev/null
+++ b/sys-libs/librtas/files/librtas-1.3.6-symlink.patch
@@ -0,0 +1,24 @@
+QA Notice: Missing soname symlink(s):
+usr/lib64/libofdt.so.1 -> libofdt.so.1.3.6
+usr/lib64/librtas.so.1 -> librtas.so.1.3.6
+
+--- libofdt_src/Makefile
++++ libofdt_src/Makefile
+@@ -27,6 +27,7 @@
+ @$(call install_lib,$(LIBOFDT),$(DESTDIR))
+ @$(call install_inc,$(LIBOFDT_SHIP_HDR),$(DESTDIR))
+ @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME)
++ @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME).1
+
+ uninstall:
+ @$(call uninstall_lib,$(LIBOFDT),$(DESTDIR))
+--- librtas_src/Makefile
++++ librtas_src/Makefile
+@@ -33,6 +33,7 @@
+ @$(call install_lib,$(LIBRTAS),$(DESTDIR))
+ @$(call install_inc,$(HEADERS),$(DESTDIR))
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
++ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).1
+
+ uninstall:
+ @$(call uninstall_lib,$(LIBRTAS),$(DESTDIR))
diff --git a/sys-libs/librtas/files/librtas-1.3.8-symlink.patch b/sys-libs/librtas/files/librtas-1.3.8-symlink.patch
new file mode 100644
index 00000000000..c3faeaf41e2
--- /dev/null
+++ b/sys-libs/librtas/files/librtas-1.3.8-symlink.patch
@@ -0,0 +1,20 @@
+--- libofdt_src/Makefile
++++ libofdt_src/Makefile
+@@ -27,6 +27,7 @@
+ @$(call install_lib,$(LIBOFDT),$(DESTDIR))
+ @$(call install_inc,$(LIBOFDT_SHIP_HDR),$(DESTDIR))
+ @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME)
++ @ln -sf $(LIBOFDT) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBOFDT))/$(LIBOFDT_SONAME).1
+
+ uninstall:
+ @$(call uninstall_lib,$(LIBOFDT),$(DESTDIR))
+--- librtas_src/Makefile
++++ librtas_src/Makefile
+@@ -33,6 +33,7 @@
+ @$(call install_lib,$(LIBRTAS),$(DESTDIR))
+ @$(call install_inc,$(HEADERS),$(DESTDIR))
+ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
++ @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).1
+
+ uninstall:
+ @$(call uninstall_lib,$(LIBRTAS),$(DESTDIR))