summaryrefslogtreecommitdiff
path: root/sys-libs/libsmbios
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/libsmbios
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/libsmbios')
-rw-r--r--sys-libs/libsmbios/Manifest1
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.2.28-cppunit-tests.patch11
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.2.28-gcc46.patch11
-rw-r--r--sys-libs/libsmbios/files/libsmbios-fix-pie.patch30
-rw-r--r--sys-libs/libsmbios/libsmbios-2.2.28.ebuild79
-rw-r--r--sys-libs/libsmbios/metadata.xml11
6 files changed, 143 insertions, 0 deletions
diff --git a/sys-libs/libsmbios/Manifest b/sys-libs/libsmbios/Manifest
new file mode 100644
index 00000000000..1b9dd9031b0
--- /dev/null
+++ b/sys-libs/libsmbios/Manifest
@@ -0,0 +1 @@
+DIST libsmbios-2.2.28.tar.bz2 943292 SHA256 dd247fd43296df3352435b090dd789a22a89c4b316e98b46b915323290a3e350 SHA512 64477adb4cc647613c682d8ff30ced0c951bc83d4cfc696dc343690fb37155e53b0c8c338c7c66822f3b91480fadaf5f70eee6b1ec33371c623213ea07d2b78f WHIRLPOOL e0427e406426705163614f76ac460fa1778b94ad9ce180f606cdf02ff037ee29275830e48065e8a883a19ebe314cc77eabf3cf6a4f9f5c8d5d0b2372486d64ac
diff --git a/sys-libs/libsmbios/files/libsmbios-2.2.28-cppunit-tests.patch b/sys-libs/libsmbios/files/libsmbios-2.2.28-cppunit-tests.patch
new file mode 100644
index 00000000000..61f39278721
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-2.2.28-cppunit-tests.patch
@@ -0,0 +1,11 @@
+diff -Naur libsmbios-2.2.28/src/libsmbios_c/smi/smi_linux.c libsmbios-2.2.28.new/src/libsmbios_c/smi/smi_linux.c
+--- libsmbios-2.2.28/src/libsmbios_c/smi/smi_linux.c 2010-06-11 11:31:01.000000000 -0400
++++ libsmbios-2.2.28.new/src/libsmbios_c/smi/smi_linux.c 2012-06-21 14:57:15.000000000 -0400
+@@ -48,6 +48,7 @@
+ #define bufsize 256
+
+ // not in header file. for private use by unit tests.
++LIBSMBIOS_C_DLL_SPEC void set_basedir(const char *); // needed to link tests
+ void set_basedir(const char *newdir)
+ {
+ sysfs_basedir = newdir;
diff --git a/sys-libs/libsmbios/files/libsmbios-2.2.28-gcc46.patch b/sys-libs/libsmbios/files/libsmbios-2.2.28-gcc46.patch
new file mode 100644
index 00000000000..0532e01b436
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-2.2.28-gcc46.patch
@@ -0,0 +1,11 @@
+--- libsmbios-2.2.28/src/include/smbios/config/compiler/gcc.hpp
++++ libsmbios-2.2.28/src/include/smbios/config/compiler/gcc.hpp
+@@ -113,7 +113,7 @@
+ # error "Compiler not configured - please reconfigure"
+ #endif
+ //
+-#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ > 5))
++#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ > 7))
+ # if defined(LIBSMBIOS_ASSERT_CONFIG)
+ # error "Unknown compiler version - please run the configure tests and report the results"
+ # else
diff --git a/sys-libs/libsmbios/files/libsmbios-fix-pie.patch b/sys-libs/libsmbios/files/libsmbios-fix-pie.patch
new file mode 100644
index 00000000000..9162044169e
--- /dev/null
+++ b/sys-libs/libsmbios/files/libsmbios-fix-pie.patch
@@ -0,0 +1,30 @@
+diff -Naur libsmbios-2.2.19.orig/src/bin/dellMediaDirectCtl.cpp libsmbios-2.2.19/src/bin/dellMediaDirectCtl.cpp
+--- libsmbios-2.2.19.orig/src/bin/dellMediaDirectCtl.cpp 2009-02-26 14:29:03.000000000 +0000
++++ libsmbios-2.2.19/src/bin/dellMediaDirectCtl.cpp 2011-01-20 06:55:48.000000000 +0000
+@@ -183,16 +183,21 @@
+ {
+ iopl(3);
+
++ u32 tmpebx;
+ __asm__ __volatile__ (
+- // magic port
+- "outb %%al, %%dx \n\t"
+-
++ "movl %%ebx,%[tmpebx]\n\t"
++ "movl %[ebx],%%ebx\n\t"
++ // magic port
++ "outb %%al, %%dx \n\t"
++ "movl %%ebx,%[ebx]\n\t"
++ "movl %[tmpebx],%%ebx\n\t"
+ : /* output args */
+ "=a" (r->eax),
+- "=b" (r->ebx),
++ [ebx] "=rm" (r->ebx),
+ "=c" (r->ecx),
+ "=S" (r->esi),
+- "=D" (r->edi)
++ "=D" (r->edi),
++ [tmpebx] "+m" (tmpebx)
+ : /* input args */
+ "0" (r->eax),
+ "1" (r->ebx),
diff --git a/sys-libs/libsmbios/libsmbios-2.2.28.ebuild b/sys-libs/libsmbios/libsmbios-2.2.28.ebuild
new file mode 100644
index 00000000000..e3eb600c351
--- /dev/null
+++ b/sys-libs/libsmbios/libsmbios-2.2.28.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 flag-o-matic autotools
+
+DESCRIPTION="Provide access to (SM)BIOS information"
+HOMEPAGE="http://linux.dell.com/libsmbios/main/index.html"
+SRC_URI="http://linux.dell.com/libsmbios/download/libsmbios/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2 OSL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ia64 x86"
+IUSE="doc graphviz nls python static-libs test"
+
+RDEPEND="dev-libs/libxml2
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ graphviz? ( media-gfx/graphviz )
+ nls? ( sys-devel/gettext )
+ test? ( >=dev-util/cppunit-1.9.6 )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.2.28-gcc46.patch \
+ "${FILESDIR}"/${PN}-fix-pie.patch \
+ "${FILESDIR}"/${PN}-2.2.28-cppunit-tests.patch
+
+ >pkg/py-compile
+
+ # dist-lzma was removed from automake-1.12 (bug #422779)
+ sed 's@dist-lzma@dist-xz@' -i "${S}"/configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ #Remove -O3 for bug #290097
+ replace-flags -O3 -O2
+
+ econf \
+ $(use_enable doc doxygen) \
+ $(use_enable graphviz) \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ rm -rf "${D}etc/yum"
+ rm -rf "${D}usr/lib/yum-plugins"
+ if ! use python ; then
+ rmdir "${D}libsmbios_c" "${D}usr/share/smbios-utils"
+ rm -rf "${D}etc"
+ else
+ local python_scriptroot="/usr/sbin"
+ python_doscript "${D}"/usr/sbin/smbios-{lcd-brightness,passwd,rbu-bios-update,sys-info,token-ctl,wakeup-ctl,wireless-ctl}
+ fi
+
+ insinto /usr/include/
+ doins -r src/include/smbios/
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ use static-libs || prune_libtool_files --all
+}
diff --git a/sys-libs/libsmbios/metadata.xml b/sys-libs/libsmbios/metadata.xml
new file mode 100644
index 00000000000..560c25a05c2
--- /dev/null
+++ b/sys-libs/libsmbios/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+</maintainer>
+<longdescription>The libsmbios project aims towards providing access to as much
+BIOS information as possible. It does this by providing a library of functions
+that can be used as well as sample binaries.</longdescription>
+</pkgmetadata>