summaryrefslogtreecommitdiff
path: root/sys-libs/llvm-libunwind
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-14 23:02:10 +0100
committerMichał Górny <mgorny@gentoo.org>2017-03-14 23:22:23 +0100
commit109221b0f5dd0110a835d72f4d8171e3b7a6cebb (patch)
treedbff28c2f7cf45d303f219598c052f358c19bbbf /sys-libs/llvm-libunwind
parent2c6d60a736a66a541e299f07df4079cf664b411c (diff)
downloadgentoo-109221b0f5dd0110a835d72f4d8171e3b7a6cebb.tar.gz
gentoo-109221b0f5dd0110a835d72f4d8171e3b7a6cebb.tar.xz
sys-libs/llvm-libunwind: Use llvm.eclass for reliable upgrade from :0
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-4.0.0.ebuild2
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0.ebuild
index 3b6d8416990..76ccc916619 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0.ebuild
@@ -6,7 +6,7 @@ EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
# (needed due to CMAKE_BUILD_TYPE != Gentoo)
CMAKE_MIN_VERSION=3.7.0-r1
-inherit cmake-multilib
+inherit cmake-multilib llvm
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index 79b7bb37ac2..963c0a6450e 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
# (needed due to CMAKE_BUILD_TYPE != Gentoo)
CMAKE_MIN_VERSION=3.7.0-r1
-inherit cmake-multilib git-r3
+inherit cmake-multilib git-r3 llvm
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"