summaryrefslogtreecommitdiff
path: root/sys-libs/llvm-libunwind
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-23 18:50:16 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-24 21:03:48 +0200
commit378cdc1215e43c02a03a0bbd7ab907611fc75af9 (patch)
tree60be83c07584439ba7f52b0483845358ec146d36 /sys-libs/llvm-libunwind
parent7c02e9368a187e1b70666d504f96e356afd65442 (diff)
downloadgentoo-378cdc1215e43c02a03a0bbd7ab907611fc75af9.tar.gz
gentoo-378cdc1215e43c02a03a0bbd7ab907611fc75af9.tar.xz
sys-libs/llvm-libunwind: Branch for 5.0.0 release
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-5.0.9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-5.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-5.0.9999.ebuild
new file mode 100644
index 00000000000..fc8c13fc44b
--- /dev/null
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-5.0.9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
+inherit cmake-multilib git-r3 llvm
+
+DESCRIPTION="C++ runtime stack unwinder from LLVM"
+HOMEPAGE="https://github.com/llvm-mirror/libunwind"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/libunwind.git
+ https://github.com/llvm-mirror/libunwind.git"
+EGIT_BRANCH="release_50"
+
+LICENSE="|| ( UoI-NCSA MIT )"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +static-libs"
+
+RDEPEND="!sys-libs/libunwind"
+# LLVM 4 required for llvm-config --cmakedir
+DEPEND=">=sys-devel/llvm-4"
+
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+ local libdir=$(get_libdir)
+
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+ -DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
+ -DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+
+ # install headers like sys-libs/libunwind
+ doheader "${S}"/include/*.h
+}